Upgrade to 2.0.

This commit is contained in:
Thomas Gellekum 1998-05-28 07:39:25 +00:00
parent 65034b6090
commit 6d45df077a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11173
4 changed files with 62 additions and 69 deletions

View file

@ -1,12 +1,12 @@
# New ports collection makefile for: xgalaga
# Version required: 1.6c
# Version required: 2.0
# Date created: 27 August 1995
# Whom: asami
#
# $Id: Makefile,v 1.5 1997/09/06 05:32:33 max Exp $
# $Id: Makefile,v 1.6 1997/12/25 22:29:20 asami Exp $
#
DISTNAME= xgalaga-1.6c
DISTNAME= xgalaga-2.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
@ -15,30 +15,24 @@ MAINTAINER= ports@FreeBSD.ORG
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
USE_IMAKE= yes
NO_INSTALL_MANPAGES= yes
HAS_CONFIGURE= yes
USE_X11= yes
# xgalaga has a very strange usage of these variables...
CONFIGURE_ARGS= --prefix=${X11BASE}/lib/X11/xgalaga \
--exec_prefix=${X11BASE}/bin
EXTRA_PATCH= patch-ab
.if defined(NOSOUND)
CONFIGURE_ARGS+= --without-sound
.endif
nosound:
@echo "Okay, making a quiet version of xgalaga...."
@cp ${FILESDIR}/${EXTRA_PATCH} ${PATCHDIR}
@${MAKE} ${.MAKEFLAGS} all
pre-clean:
@rm -f ${PATCHDIR}/${EXTRA_PATCH}
pre-patch:
@if [ ! -f ${PATCHDIR}/${EXTRA_PATCH} ]; then \
echo "*****************************************************" ; \
echo "* Note that you can build a version of xgalaga that *" ; \
echo "* doesn't use the sound driver by typing *" ; \
echo "* \"make nosound\" *" ; \
echo "* following a \"make clean\". *" ; \
echo "* Try it if you don't have a sound card and are *" ; \
echo "* getting core dumps. *" ; \
echo "*****************************************************" ; \
fi
pre-configure:
@${ECHO} "*****************************************************"
@${ECHO} "* Note that you can build a version of xgalaga that *"
@${ECHO} "* doesn't use the sound driver by typing *"
@${ECHO} "* \"make -DNOSOUND\" *"
@${ECHO} "* following a \"make clean\". *"
@${ECHO} "* Try it if you don't have a sound card and are *"
@${ECHO} "* getting core dumps. *"
@${ECHO} "*****************************************************"
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (xgalaga-1.6c.tar.gz) = b4e44a21b569d00f7656abbbd9e73b0b
MD5 (xgalaga-2.0.tar.gz) = ffc1d86b0757a57d23d1cc971014cc43

View file

@ -1,43 +1,25 @@
--- ./libsprite/Imakefile.org Mon May 15 17:52:06 1995
+++ ./libsprite/Imakefile Wed May 24 02:30:34 1995
@@ -1,5 +1,5 @@
--- Makefile.in.orig Sun Apr 12 10:10:46 1998
+++ Makefile.in Thu May 28 09:41:05 1998
@@ -43,11 +43,12 @@
$(CC) $(LDFLAGS) -o $(SOUNDSRV) $(SOUNDOBJS) $(SOUNDLIBS)
- XPMINCLUDE = -I/usr/include/X11
+ XPMINCLUDE = -I$(INCROOT)/X11
install: all
- mkinstalldirs $(bindir)
+ ./mkinstalldirs $(bindir)
+ ./mkinstalldirs $(prefix)
$(INSTALL) $(TARGET) $(bindir)/$(TARGET)
$(INSTALL) $(SOUNDSRV) $(prefix)/$(SOUNDSRV)
- mkinstalldirs $(prefix)/sounds
- mkinstalldirs $(prefix)/levels
+ ./mkinstalldirs $(prefix)/sounds
+ ./mkinstalldirs $(prefix)/levels
for i in levels/*.xgl; do $(INSTALL) $$i $(prefix)/$$i ; done
for i in sounds/*.raw; do $(INSTALL) $$i $(prefix)/$$i ; done
EXTRA_INCLS = $(XPMINCLUDE)
@@ -75,4 +76,4 @@
cd libsprite;$(MAKE) distclean
--- Imakefile.orig Sat Nov 30 01:02:20 1996
+++ Imakefile Sat Nov 30 01:04:33 1996
@@ -9,7 +9,7 @@
XCOMM your system. If not doing "make install", set this to where the
XCOMM files are now.
- XGALAGADIR = /usr/games/xgalaga
+ XGALAGADIR = $(LIBDIR)/xgalaga
SCOREFILE = $(XGALAGADIR)/.xgalscores
SOUNDDIR = $(XGALAGADIR)/sounds
@@ -18,8 +18,8 @@
XCOMM with the standard X libs, you shouldn't need to change this.
XCOMM otherwise make these point at wherever you put it.
- XPMLIB = -lXpm
- XPMINCLUDE = -I/usr/include/X11
+ XPMLIB = -L$(USRLIBDIR) -lXpm
+ XPMINCLUDE = -I$(INCROOT)/X11
XSPRITELIB = -L./libsprite -lXsprite
@@ -141,9 +141,9 @@
#endif
#ifdef PCSP_ONLY
- PCSPDEF = -DPCSP_ONLY=1
+ PCSPDEF = -DPCSP_ONLY=1
#else
- PCSPDEF = -DPCSP_ONLY=0
+ PCSPDEF = -DPCSP_ONLY=0
#endif
#ifndef SOUND
depend:
- makedepend $(CFLAGS) $(SRCS)
\ No newline at end of file
+ makedepend $(CFLAGS) $(SRCS)

View file

@ -1,5 +1,4 @@
bin/xgal
lib/X11/xgalaga/.xgalscores
bin/xgalaga
lib/X11/xgalaga/xgal.sndsrv.freebsd
lib/X11/xgalaga/sounds/ddloo.raw
lib/X11/xgalaga/sounds/explode.raw
@ -9,3 +8,21 @@ lib/X11/xgalaga/sounds/shield.raw
lib/X11/xgalaga/sounds/smart.raw
lib/X11/xgalaga/sounds/torphit.raw
lib/X11/xgalaga/sounds/warp.raw
lib/X11/xgalaga/levels/level1.xgl
lib/X11/xgalaga/levels/level2.xgl
lib/X11/xgalaga/levels/level3.xgl
lib/X11/xgalaga/levels/level4.xgl
lib/X11/xgalaga/levels/level5.xgl
lib/X11/xgalaga/levels/level6.xgl
lib/X11/xgalaga/levels/level7.xgl
lib/X11/xgalaga/levels/level8.xgl
lib/X11/xgalaga/levels/level9.xgl
lib/X11/xgalaga/levels/level10.xgl
lib/X11/xgalaga/levels/level11.xgl
lib/X11/xgalaga/levels/level12.xgl
lib/X11/xgalaga/levels/level13.xgl
lib/X11/xgalaga/levels/level14.xgl
lib/X11/xgalaga/levels/level15.xgl
@dirrm lib/X11/xgalaga/levels
@dirrm lib/X11/xgalaga/sounds
@dirrm lib/X11/xgalaga