o Update to 0.12

o Check __FreeBSD_version < 500018 which doesn't have libreadline 4.2

PR:		38454, 39640
Submitted by:	Tilman Linneweh <tilman@arved.de>,
		KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Hye-Shik Chang 2002-07-04 07:11:43 +00:00
parent 63a209ecea
commit 6d80918d43
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62414
4 changed files with 50 additions and 24 deletions

View file

@ -7,24 +7,27 @@
#
PORTNAME= rlwrap
PORTVERSION= 0.10
PORTVERSION= 0.12
CATEGORIES= devel
MASTER_SITES= http://utopia.knoware.nl/~hlub/uck/rlwrap/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500018
BROKEN= "Requires readline 4.2 or newer"
.endif
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
ALL_TARGET= # empty
MANCOMPRESSED= no
MAN1= rlwrap.1
post-patch:
@${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (rlwrap-0.10.tgz) = 4cc2ab18b15f96eb05dedfe365d0f0e1
MD5 (rlwrap-0.12.tgz) = 27f04e27b202c4ee8b896e36f5067473

View file

@ -1,11 +1,34 @@
--- Makefile.in.orig Thu Sep 20 00:20:54 2001
+++ Makefile.in Thu Sep 20 00:21:03 2001
@@ -27,7 +27,7 @@
--- Makefile.in.orig Fri Jun 21 18:13:49 2002
+++ Makefile.in Thu Jul 4 15:46:48 2002
@@ -14,6 +14,8 @@
oldincludedir = /usr/include
+CPPFLAGS = @CPPFLAGS@
+
LDFLAGS = @LDFLAGS@ -L$(libdir)
LIBS = @LIBS@
SHELL = /bin/sh
@@ -21,7 +23,7 @@
rlwrap: $(OBJECTS)
- $(CC) -o rlwrap $(OBJECTS) @READLINELIB@ @READLINE_SUPPLIB@
+ $(CC) -o rlwrap $(OBJECTS) @READLINELIB@ @READLINE_SUPPLIB@ @LDFLAGS@
CC = @CC@
-CFLAGS= @CFLAGS@ -DVERSION=\"$(VERSION)\" -DSYSCONFDIR=\"$(sysconfdir)\" -Wall -I . -I $(includedir)
+CFLAGS= @CFLAGS@ $(CPPFLAGS) -DVERSION=\"$(VERSION)\" -DSYSCONFDIR=\"$(sysconfdir)\" -Wall -I . -I $(includedir)
SOURCES = main.c signals.c utils.c readline.c pty.c completion.c term.c
OBJECTS = main.o signals.o utils.o readline.o pty.o completion.o term.o
TESTCLIENT=testclient
@@ -50,10 +52,11 @@
check: @CHECK@
$(OBJECTS) : rlwrap.h
no_perl :
- @echo "warning: test client not made because configure didn't find perl"
+ sed -e 's#\@PERLBIN\@#/usr/bin/perl#' $(TESTCLIENT).in > $(TESTCLIENT) &&\
+ chmod a+x $(TESTCLIENT)
_testclient:
- perl -p -e 's#\@PERLBIN\@#$(PERL)#' $(TESTCLIENT).in > $(TESTCLIENT) &&\
+ sed -e 's#\@PERLBIN\@#$(PERL)#' $(TESTCLIENT).in > $(TESTCLIENT) &&\
chmod a+x $(TESTCLIENT)
_check: $(TESTCLIENT) rlwrap

View file

@ -1,13 +1,13 @@
--- rlwrap.h.orig Sun Aug 12 18:59:20 2001
+++ rlwrap.h Sun Aug 12 18:58:52 2001
@@ -34,6 +34,10 @@
#include <getopt.h>
#endif
--- rlwrap.h.orig Tue Sep 11 06:02:47 2001
+++ rlwrap.h Mon Mar 4 07:37:19 2002
@@ -36,6 +36,10 @@
#include <stdlib.h>
#include <time.h>
+#ifdef HAVE_GETOPT_LONG
+#include <getopt.h>
+#endif
+
#include <string.h>
#include <errno.h>
#include <stdarg.h>
#ifdef HAVE_GETOPT_H
#include <getopt.h>
#endif