- Fix pkg_plist and unbreak;
- Define USE_LIBTOOL_VER; - Bump PORTREVISION. PR: ports/74828 Submitted by: maintainer.
This commit is contained in:
parent
d87e7e0e7c
commit
6dd190dc6c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123589
8 changed files with 598 additions and 493 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= gromacs
|
||||
PORTVERSION= 3.2.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
|
||||
|
||||
|
@ -17,14 +18,13 @@ COMMENT= Compute molecular dynamics
|
|||
LIB_DEPENDS= fftw:${PORTSDIR}/math/fftw:install
|
||||
.endif
|
||||
.ifdef WITH_MPI
|
||||
BUILD_DEPENDS= ${LOCALPREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich:install
|
||||
RUN_DEPENDS= ${LOCALPREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich:install
|
||||
BUILD_DEPENDS= ${LOCALBASE}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
|
||||
RUN_DEPENDS= ${LOCALBASE}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
|
||||
.endif
|
||||
|
||||
BROKEN= Broken pkg-plist
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
|
||||
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
|
||||
|
@ -33,9 +33,9 @@ PLIST_SUB= BUILD=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
|||
|
||||
.ifndef WITHOUT_FFTW
|
||||
.ifdef WITH_FLOAT
|
||||
IGNORE= Cannot currently build with fftw and single precision floating point
|
||||
IGNORE= Cannot currently build with fftw and single precision floating point
|
||||
.elifdef WITH_MPI
|
||||
IGNORE= Cannot currently build with fftw and mpi support
|
||||
IGNORE= Cannot currently build with fftw and mpi support
|
||||
.endif
|
||||
.endif
|
||||
|
||||
|
@ -48,20 +48,23 @@ CONFIGURE_ARGS+= --with-x
|
|||
USE_XLIB= yes
|
||||
.endif
|
||||
|
||||
.ifdef WITHOUT_FFTW
|
||||
CONFIGURE_ARGS+= --without-fftw
|
||||
.ifndef WITH_FLOAT
|
||||
CONFIGURE_ARGS+= --disable-float --program-suffix=
|
||||
PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
|
||||
.else
|
||||
PLIST_SUB+= SUFFIX_D= SUFFIX_DOUBLE=
|
||||
.endif
|
||||
|
||||
.ifndef WITHOUT_FLOAT
|
||||
CONFIGURE_ARGS+= --disable-float
|
||||
.ifdef WITHOUT_FFTW
|
||||
CONFIGURE_ARGS+= --without-fftw
|
||||
.endif
|
||||
|
||||
.ifdef WITH_MPI
|
||||
CONFIGURE_ARGS+= --enable-mpi
|
||||
CONFIGURE_ENV+= MPICC=${PREFIX}/mpich/bin/mpicc
|
||||
PLIST_SUB+= WITH_MPI= _MPI=_mpi
|
||||
PLIST_SUB+= WITH_MPI= SUFFIX_MPI=_mpi WITHOUT_MPI="@comment "
|
||||
.else
|
||||
PLIST_SUB+= WITH_MPI="@comment " SUFFIX_MPI=
|
||||
PLIST_SUB+= WITH_MPI="@comment " SUFFIX_MPI= WITHOUT_MPI=
|
||||
.endif
|
||||
|
||||
MAN1= anadock.1 \
|
||||
|
|
15
science/gromacs/files/patch-src::contrib::Makefile.in
Normal file
15
science/gromacs/files/patch-src::contrib::Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/contrib/Makefile.in.orig Mon Mar 1 20:49:01 2004
|
||||
+++ src/contrib/Makefile.in Thu Dec 9 19:54:56 2004
|
||||
@@ -307,10 +307,10 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/sigeps.Po
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
F77COMPILE = $(F77) $(AM_FFLAGS) $(FFLAGS)
|
||||
LTF77COMPILE = $(LIBTOOL) --mode=compile $(F77) $(AM_FFLAGS) $(FFLAGS)
|
22
science/gromacs/files/patch-src::gmxlib::Makefile.in
Normal file
22
science/gromacs/files/patch-src::gmxlib::Makefile.in
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- src/gmxlib/Makefile.in.orig Mon Mar 1 20:49:02 2004
|
||||
+++ src/gmxlib/Makefile.in Thu Dec 9 00:11:00 2004
|
||||
@@ -292,16 +292,16 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/xtcio.Plo ./$(DEPDIR)/xvgr.Plo
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
F77COMPILE = $(F77) $(AM_FFLAGS) $(FFLAGS)
|
||||
LTF77COMPILE = $(LIBTOOL) --mode=compile $(F77) $(AM_FFLAGS) $(FFLAGS)
|
||||
F77LD = $(F77)
|
||||
CCASCOMPILE = $(CCAS) $(AM_CCASFLAGS) $(CCASFLAGS)
|
||||
-LTCCASCOMPILE = $(LIBTOOL) --mode=compile $(CCAS) $(AM_CCASFLAGS) \
|
||||
+LTCCASCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CCAS) $(AM_CCASFLAGS) \
|
||||
$(CCASFLAGS)
|
||||
DIST_SOURCES = $(libgmx@LIBSUFFIX@_la_SOURCES) \
|
||||
$(EXTRA_libgmx@LIBSUFFIX@_la_SOURCES)
|
15
science/gromacs/files/patch-src::kernel::Makefile.in
Normal file
15
science/gromacs/files/patch-src::kernel::Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/kernel/Makefile.in.orig Mon Mar 1 20:49:03 2004
|
||||
+++ src/kernel/Makefile.in Thu Dec 9 00:33:06 2004
|
||||
@@ -367,10 +367,10 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/xutils.Po
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
DIST_SOURCES = $(ffscan_SOURCES) $(gmxcheck_SOURCES) gmxdump.c \
|
||||
$(grompp_SOURCES) luck.c $(mdrun_SOURCES) $(pdb2gmx_SOURCES) \
|
15
science/gromacs/files/patch-src::mdlib::Makefile.in
Normal file
15
science/gromacs/files/patch-src::mdlib::Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/mdlib/Makefile.in.orig Mon Mar 1 20:49:03 2004
|
||||
+++ src/mdlib/Makefile.in Thu Dec 9 00:22:03 2004
|
||||
@@ -233,10 +233,10 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/vcm.Plo ./$(DEPDIR)/wnblist.Plo
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
F77COMPILE = $(F77) $(AM_FFLAGS) $(FFLAGS)
|
||||
LTF77COMPILE = $(LIBTOOL) --mode=compile $(F77) $(AM_FFLAGS) $(FFLAGS)
|
15
science/gromacs/files/patch-src::ngmx::Makefile.in
Normal file
15
science/gromacs/files/patch-src::ngmx::Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/ngmx/Makefile.in.orig Mon Mar 1 20:49:04 2004
|
||||
+++ src/ngmx/Makefile.in Thu Dec 9 19:53:57 2004
|
||||
@@ -272,10 +272,10 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/xrama.Po ./$(DEPDIR)/xutil.Po
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
DIST_SOURCES = $(dlg_SOURCES) $(gmxlogo_SOURCES) $(highway_SOURCES) \
|
||||
$(ngmx_SOURCES) $(scrollw_SOURCES) $(showcol_SOURCES) \
|
15
science/gromacs/files/patch-src::tools::Makefile.in
Normal file
15
science/gromacs/files/patch-src::tools::Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/tools/Makefile.in.orig Mon Mar 1 20:49:06 2004
|
||||
+++ src/tools/Makefile.in Thu Dec 9 19:35:43 2004
|
||||
@@ -744,10 +744,10 @@
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/xpm2ps.Po
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
DIST_SOURCES = $(libgmxana@LIBSUFFIX@_la_SOURCES) $(anadock_SOURCES) \
|
||||
average.c $(cdist_SOURCES) $(disco_SOURCES) do_dssp.c \
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue