- Update MASTER_SITES

- Fix build with clang
- Add MAKE_JOBS_SAFE
- Reformat pkg-descr

PR:		175592
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2013-02-04 14:26:51 +00:00
parent 9e2c91a9b4
commit 6e00b2437a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311619
11 changed files with 156 additions and 26 deletions

View file

@ -1,30 +1,33 @@
# New ports collection makefile for: xataxx
# Date created: 4 July 1998
# Whom: Andrey Zakhvatov
#
# Created by: Andrey Zakhvatov
# $FreeBSD$
#
PORTNAME= xataxx
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ftp://ftp.x.org/R5contrib/
MASTER_SITES= XCONTRIB/../R5contrib
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Strategy game of position and movement for X Window System
USE_IMAKE= yes
OPTIONS_DEFINE= DOCS
USE_XORG= x11 xext
USE_IMAKE= yes
MAKE_JOBS_SAFE= yes
MAN6= xataxx.6
.include <bsd.port.options.mk>
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xataxx
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xataxx
${INSTALL_DATA} ${WRKSRC}/TODO ${PREFIX}/share/doc/xataxx
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in README TODO
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- main.c Sun May 5 06:53:44 1991
+++ /home/andy/tmp/wrk/main.c Sat Jul 4 21:31:38 1998
@@ -160,7 +160,7 @@
int x;
{
int z1, z2, z3, z4, z=0;
- char nn[6];
+ static char nn[6];
z1 = (int) (x)/1000;
z2 = (int) (x)/100-(10*z1);

View file

@ -0,0 +1,22 @@
--- bits.c.orig
+++ bits.c
@@ -1,7 +1,10 @@
#include <stdio.h>
+#include <stdlib.h>
#include <ctype.h>
#include <X11/Xlib.h>
+#include <X11/Xutil.h>
#include <math.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/time.h>
#include "struct.h"
@@ -16,7 +19,7 @@
#define NFDSHIFT 5 /* Shift based on above */
#ifndef howmany
#define howmany(x, y) (((x)+((y)-1))/(y))
-#endif howmany
+#endif
#define NBBY 8 /* number of bits in a byte */

View file

@ -0,0 +1,16 @@
--- board.c.orig
+++ board.c
@@ -1,3 +1,4 @@
+#include <stdlib.h>
#include <X11/Xlib.h>
#include "struct.h"
@@ -461,7 +462,7 @@
}
}
if (best_count==-1)
- return;
+ return(0);
move_piece(best.ox,best.oy,best.nx,best.ny,player);
}

View file

@ -0,0 +1,8 @@
--- demo.c.orig
+++ demo.c
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <X11/Xlib.h>
#include "struct.h"

View file

@ -0,0 +1,27 @@
--- display.c.orig
+++ display.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include <math.h>
@@ -145,7 +147,7 @@
int occ,x,y;
if (currdpy != dpy && !botmode)
- return;
+ return(0);
wipemap(currdpy, currbamp, currgc, currscr, currwin);
for (y=0;y!=ysize;y++)
for (x=0;x!=xsize;x++)
@@ -386,7 +388,7 @@
XFlush(currdpy);
}
XNextEvent(dpy,&event);
- return;
+ return(0);
}
}

View file

@ -0,0 +1,19 @@
--- main.c.orig
+++ main.c
@@ -1,4 +1,7 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <unistd.h>
#include <X11/Xlib.h>
#include <math.h>
#include "struct.h"
@@ -160,7 +163,7 @@
int x;
{
int z1, z2, z3, z4, z=0;
- char nn[6];
+ static char nn[6];
z1 = (int) (x)/1000;
z2 = (int) (x)/100-(10*z1);

View file

@ -0,0 +1,27 @@
--- nubot.c.orig
+++ nubot.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <strings.h>
#include <X11/Xlib.h>
#include "struct.h"
@@ -172,7 +174,7 @@
list_moves(player, board, movel);
- if (movel[0].ox==(-1)) return; /* there are no legal moves */
+ if (movel[0].ox==(-1)) return(0); /* there are no legal moves */
if (botlevel==0) {
for (ix=0; movel[ix].ox!=(-1); ix++);
@@ -180,7 +182,7 @@
best = &(movel[ix]);
move_piece(best->ox,best->oy,best->nx,best->ny,player);
- return;
+ return(0);
};
for (ix=0; movel[ix].ox!=(-1); ix++) {

View file

@ -0,0 +1,9 @@
--- parse.c.orig
+++ parse.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
#include <strings.h>
#include "struct.h"

View file

@ -0,0 +1,11 @@
--- zot.c.orig
+++ zot.c
@@ -23,7 +23,7 @@
GC bgc;
if (!wflump)
- return;
+ return(0);
zot(dx, dy, cmaps, cdpy, cscr, cgc, cwin, cmap);
}

View file

@ -1,4 +1,3 @@
XAtaxx is a strategy game based on Ataxx, a popular arcade
video game. It is a game of position and movement. The
object is to have the most pieces of your color on the
board at the end of the game.
XAtaxx is a strategy game based on Ataxx, a popular arcade video game.
It is a game of position and movement. The object is to have the most
pieces of your color on the board at the end of the game.