- fix case problems with PAPERSIZE
- fix install of emacs support files PR: 161059 Submitted by: Osamu Tsumori Feature safe: yes
This commit is contained in:
parent
d0fd839488
commit
6e72b5d939
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286059
2 changed files with 13 additions and 10 deletions
|
@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.enst.fr/pub/unix/a2ps/ \
|
|||
ftp://ftp3.ru.freebsd.org/pub/unix/postscript/a2ps/ \
|
||||
${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMESUFFIX= -${PAPERSIZE}${PKGNAMESUFFIX2}
|
||||
PKGNAMESUFFIX= -${PAPERSIZE:L}${PKGNAMESUFFIX2}
|
||||
.if defined(WITH_I18N) || make(makesum) || defined(FETCH_ALL)
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${I18N_PACKAGE}${EXTRACT_SUFX}
|
||||
.endif
|
||||
|
@ -38,7 +38,7 @@ PAPERSIZECNF= ${PAPERSIZE:S/l/L/:S/a/A/}
|
|||
STRIP=
|
||||
CONFIGURE_ARGS= --with-medium=${PAPERSIZECNF} --sharedstatedir=${PREFIX}/share --sysconfdir=${PREFIX}/etc --datadir=${PREFIX}/share --localstatedir=${PREFIX}/share
|
||||
|
||||
.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter && ${PAPERSIZE} != letterdj
|
||||
.if ${PAPERSIZE:L} != a4 && ${PAPERSIZE} != letter && ${PAPERSIZE} != letterdj
|
||||
.BEGIN:
|
||||
@${ECHO_CMD}
|
||||
@${ECHO_CMD} "PAPERSIZE incorrect value: ${PAPERSIZE}."
|
||||
|
@ -48,10 +48,10 @@ CONFIGURE_ARGS= --with-medium=${PAPERSIZECNF} --sharedstatedir=${PREFIX}/share -
|
|||
@${FALSE}
|
||||
.endif
|
||||
|
||||
.if ${PAPERSIZE} == a4
|
||||
.if ${PAPERSIZE:L} == a4
|
||||
CONFLICTS?= a2ps-letter-4.* a2ps-letterdj-4.*
|
||||
.else
|
||||
.if ${PAPERSIZE} == letter
|
||||
.if ${PAPERSIZE:L} == letter
|
||||
CONFLICTS?= a2ps-a4-4.* a2ps-letterdj-4.*
|
||||
.else
|
||||
CONFLICTS?= a2ps-a4-4.* a2ps-letter-4.*
|
||||
|
|
|
@ -1,21 +1,24 @@
|
|||
--- contrib/emacs/Makefile.in.orig Thu Feb 24 19:01:08 2000
|
||||
+++ contrib/emacs/Makefile.in Fri Apr 4 20:41:55 2003
|
||||
@@ -159,7 +159,8 @@
|
||||
Index: contrib/emacs/Makefile.in
|
||||
--- Makefile.in.orig 2011-09-27 15:17:26.000000000 +0900
|
||||
+++ Makefile.in 2011-09-27 15:18:10.000000000 +0900
|
||||
@@ -159,8 +159,9 @@
|
||||
|
||||
install-dist_lispLISP: $(dist_lisp_LISP) $(ELCFILES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- $(mkinstalldirs) $(DESTDIR)$(lispdir)
|
||||
- @list='$(dist_lisp_LISP)'; for p in $$list; do \
|
||||
+ if test $(EMACS) != no; then \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(lispdir) \
|
||||
@list='$(dist_lisp_LISP)'; for p in $$list; do \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(lispdir); \
|
||||
+ list='$(dist_lisp_LISP)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
|
||||
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(lispdir)/$$f"; \
|
||||
@@ -169,7 +170,8 @@
|
||||
echo " $(INSTALL_DATA) $${p}c $(DESTDIR)$(lispdir)/$${f}c"; \
|
||||
$(INSTALL_DATA) $${p}c $(DESTDIR)$(lispdir)/$${f}c; \
|
||||
else : ; fi; \
|
||||
- done
|
||||
+ done \
|
||||
+ done; \
|
||||
+ fi
|
||||
|
||||
uninstall-dist_lispLISP:
|
||||
|
|
Loading…
Reference in a new issue