Upgrade to version 1.0.3pl1.
PR: 6884 Submitted by: maintainer
This commit is contained in:
parent
72f6265503
commit
6e7b3ce4b7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11423
8 changed files with 30 additions and 30 deletions
|
@ -1,12 +1,13 @@
|
|||
# New ports collection makefile for: proftpd
|
||||
# Version required: 1.0.0
|
||||
# Version required: 1.0.3pl1
|
||||
# Date created: 26 January 1998
|
||||
# Whom: Stephane Legrand
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1998/02/13 17:39:02 vanilla Exp $
|
||||
# $Id: Makefile,v 1.2 1998/02/20 06:39:07 obrien Exp $
|
||||
#
|
||||
|
||||
DISTNAME= proftpd-1.0.0
|
||||
DISTNAME= proftpd-1.0.3pl1
|
||||
PKGNAME= proftpd-1.0.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.proftpd.org/distrib/
|
||||
|
||||
|
@ -20,17 +21,16 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
|
||||
|
||||
#
|
||||
# Ugly but "configure --prefix=..." doesn't seem work :(
|
||||
# So, do a "sed" to set prefix to $PREFIX
|
||||
# - "configure --prefix=..." doesn't seem to work :(
|
||||
# do a "sed" to set prefix to $PREFIX
|
||||
#
|
||||
# Ugly again, do a "sed" to set the config dir to ${PREFIX}/etc
|
||||
# - do a "sed" to set the config dir to ${PREFIX}/etc
|
||||
#
|
||||
|
||||
post-configure:
|
||||
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
|
||||
${SED} -e "s:^prefix=\/usr:prefix=${PREFIX}:" \
|
||||
-e "s:^etcdir=\/etc:etcdir=${PREFIX}\/etc:" \
|
||||
-e "s:^libexecdir=\/libexec:libexecdir=${PREFIX}\/libexec:" \
|
||||
< ${WRKSRC}/Makefile.pre_sed > ${WRKSRC}/Makefile
|
||||
|
||||
${MV} ${WRKSRC}/config.h ${WRKSRC}/config.h.pre_sed
|
||||
|
@ -61,6 +61,6 @@ post-install:
|
|||
strip ${PREFIX}/bin/ftpcount \
|
||||
${PREFIX}/bin/ftpwho \
|
||||
${PREFIX}/libexec/proftpd \
|
||||
${PREFIX}/sbin/ftpshut
|
||||
${PREFIX}/sbin/ftpshut \
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (proftpd-1.0.0.tar.gz) = 736719658018ef370aa88d3e52ef021d
|
||||
MD5 (proftpd-1.0.3pl1.tar.gz) = 4f6c85a84ba42365704df359fd2aae0b
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- modules/mod_auth.c.orig Tue Nov 11 09:17:23 1997
|
||||
+++ modules/mod_auth.c Fri Feb 20 00:38:05 1998
|
||||
--- modules//mod_auth.c.orig Sun Jun 7 16:17:57 1998
|
||||
+++ modules/mod_auth.c Sun Jun 7 16:21:29 1998
|
||||
@@ -177,7 +177,7 @@
|
||||
/* Is this the proper behavior when timing out? */
|
||||
send_response_async(R_421,"Login Timeout (%d seconds): closing control connection.",
|
||||
|
@ -9,7 +9,7 @@
|
|||
(void*)0,NULL);
|
||||
remove_timer(TIMER_IDLE,ANY_MODULE);
|
||||
remove_timer(TIMER_NOXFER,ANY_MODULE);
|
||||
@@ -731,10 +731,10 @@
|
||||
@@ -763,10 +763,10 @@
|
||||
}
|
||||
|
||||
if(c)
|
||||
|
@ -22,7 +22,7 @@
|
|||
origuser,session.c->remote_name,inet_ntoa(*session.c->remote_ipaddr));
|
||||
|
||||
session.user = pstrdup(permanent_pool,auth_map_uid(pw->pw_uid));
|
||||
@@ -955,7 +955,7 @@
|
||||
@@ -987,7 +987,7 @@
|
||||
send_response(R_530,"%s",
|
||||
sreplace(cmd->tmp_pool,maxstr,"%m",maxn,NULL));
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/proftpd.8.orig Wed Oct 29 10:51:30 1997
|
||||
+++ src/proftpd.8 Fri Feb 20 00:48:52 1998
|
||||
--- src/proftpd.8.orig Sun Jun 7 16:26:39 1998
|
||||
+++ src/proftpd.8 Sun Jun 7 16:27:44 1998
|
||||
@@ -19,6 +19,12 @@
|
||||
may be invoked by the Internet "super-server" inetd(8) each time a
|
||||
connection to the FTP service is made, or alternatively it can be run as a
|
||||
|
|
|
@ -1,12 +1,13 @@
|
|||
# New ports collection makefile for: proftpd
|
||||
# Version required: 1.0.0
|
||||
# Version required: 1.0.3pl1
|
||||
# Date created: 26 January 1998
|
||||
# Whom: Stephane Legrand
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1998/02/13 17:39:02 vanilla Exp $
|
||||
# $Id: Makefile,v 1.2 1998/02/20 06:39:07 obrien Exp $
|
||||
#
|
||||
|
||||
DISTNAME= proftpd-1.0.0
|
||||
DISTNAME= proftpd-1.0.3pl1
|
||||
PKGNAME= proftpd-1.0.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.proftpd.org/distrib/
|
||||
|
||||
|
@ -20,17 +21,16 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
|
||||
|
||||
#
|
||||
# Ugly but "configure --prefix=..." doesn't seem work :(
|
||||
# So, do a "sed" to set prefix to $PREFIX
|
||||
# - "configure --prefix=..." doesn't seem to work :(
|
||||
# do a "sed" to set prefix to $PREFIX
|
||||
#
|
||||
# Ugly again, do a "sed" to set the config dir to ${PREFIX}/etc
|
||||
# - do a "sed" to set the config dir to ${PREFIX}/etc
|
||||
#
|
||||
|
||||
post-configure:
|
||||
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
|
||||
${SED} -e "s:^prefix=\/usr:prefix=${PREFIX}:" \
|
||||
-e "s:^etcdir=\/etc:etcdir=${PREFIX}\/etc:" \
|
||||
-e "s:^libexecdir=\/libexec:libexecdir=${PREFIX}\/libexec:" \
|
||||
< ${WRKSRC}/Makefile.pre_sed > ${WRKSRC}/Makefile
|
||||
|
||||
${MV} ${WRKSRC}/config.h ${WRKSRC}/config.h.pre_sed
|
||||
|
@ -61,6 +61,6 @@ post-install:
|
|||
strip ${PREFIX}/bin/ftpcount \
|
||||
${PREFIX}/bin/ftpwho \
|
||||
${PREFIX}/libexec/proftpd \
|
||||
${PREFIX}/sbin/ftpshut
|
||||
${PREFIX}/sbin/ftpshut \
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (proftpd-1.0.0.tar.gz) = 736719658018ef370aa88d3e52ef021d
|
||||
MD5 (proftpd-1.0.3pl1.tar.gz) = 4f6c85a84ba42365704df359fd2aae0b
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- modules/mod_auth.c.orig Tue Nov 11 09:17:23 1997
|
||||
+++ modules/mod_auth.c Fri Feb 20 00:38:05 1998
|
||||
--- modules//mod_auth.c.orig Sun Jun 7 16:17:57 1998
|
||||
+++ modules/mod_auth.c Sun Jun 7 16:21:29 1998
|
||||
@@ -177,7 +177,7 @@
|
||||
/* Is this the proper behavior when timing out? */
|
||||
send_response_async(R_421,"Login Timeout (%d seconds): closing control connection.",
|
||||
|
@ -9,7 +9,7 @@
|
|||
(void*)0,NULL);
|
||||
remove_timer(TIMER_IDLE,ANY_MODULE);
|
||||
remove_timer(TIMER_NOXFER,ANY_MODULE);
|
||||
@@ -731,10 +731,10 @@
|
||||
@@ -763,10 +763,10 @@
|
||||
}
|
||||
|
||||
if(c)
|
||||
|
@ -22,7 +22,7 @@
|
|||
origuser,session.c->remote_name,inet_ntoa(*session.c->remote_ipaddr));
|
||||
|
||||
session.user = pstrdup(permanent_pool,auth_map_uid(pw->pw_uid));
|
||||
@@ -955,7 +955,7 @@
|
||||
@@ -987,7 +987,7 @@
|
||||
send_response(R_530,"%s",
|
||||
sreplace(cmd->tmp_pool,maxstr,"%m",maxn,NULL));
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/proftpd.8.orig Wed Oct 29 10:51:30 1997
|
||||
+++ src/proftpd.8 Fri Feb 20 00:48:52 1998
|
||||
--- src/proftpd.8.orig Sun Jun 7 16:26:39 1998
|
||||
+++ src/proftpd.8 Sun Jun 7 16:27:44 1998
|
||||
@@ -19,6 +19,12 @@
|
||||
may be invoked by the Internet "super-server" inetd(8) each time a
|
||||
connection to the FTP service is made, or alternatively it can be run as a
|
||||
|
|
Loading…
Reference in a new issue