Use a patch rather than sed magic for the <sys/soundcard.h> issue.
This commit is contained in:
parent
ae2e57a565
commit
6e94c5f703
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62266
2 changed files with 11 additions and 5 deletions
|
@ -99,9 +99,4 @@ OPT_ARCH?= i586
|
|||
MAKE_ARGS+= OPT_ARCH=${OPT_ARCH}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/audio_oss.c > ${WRKSRC}/audio_oss.c.new
|
||||
@${MV} ${WRKSRC}/audio_oss.c.new ${WRKSRC}/audio_oss.c
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
11
audio/mpg123/files/patch-af
Normal file
11
audio/mpg123/files/patch-af
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- audio_oss.c.orig Sat Jan 31 23:14:08 1998
|
||||
+++ audio_oss.c Sun May 12 15:35:49 2002
|
||||
@@ -31,7 +31,7 @@
|
||||
#elif defined(__bsdi__)
|
||||
#include <sys/soundcard.h>
|
||||
#else
|
||||
-#include <machine/soundcard.h>
|
||||
+#include <sys/soundcard.h>
|
||||
#endif
|
||||
|
||||
int audio_open(struct audio_info_struct *ai)
|
Loading…
Reference in a new issue