New Port: security/osslsigncode

Platform-independent tool for Authenticode signing of EXE/CAB files - uses
OpenSSL and libcurl. It also supports timestamping.

PR:	ports/105353
Submitted By:	Nick Barkas <snb@threerings.net>
Approved By:	flz (mentor)
This commit is contained in:
Frank J. Laszlo 2006-11-11 13:55:05 +00:00
parent a0b57d57f7
commit 6ebfbc8583
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177053
5 changed files with 53 additions and 0 deletions

View file

@ -297,6 +297,7 @@
SUBDIR += openvpn-devel
SUBDIR += opieprint
SUBDIR += osiris
SUBDIR += osslsigncode
SUBDIR += outguess
SUBDIR += p5-Authen-Captcha
SUBDIR += p5-Authen-CyrusSASL

View file

@ -0,0 +1,30 @@
# New ports collection makefile for: osslsigncode
# Date created: 9 November 2006
# Whom: snb@threerings.net
#
# $FreeBSD$
#
PORTNAME= osslsigncode
PORTVERSION= 1.2
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= snb@threerings.net
COMMENT= OpenSSL-based signcode utility
PLIST_FILES= bin/osslsigncode
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_OPENSSL= yes
.if !defined(WITHOUT_CURL)
LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (osslsigncode-1.2.tar.gz) = e97a583463feddcce524cc4067a57e04
SHA256 (osslsigncode-1.2.tar.gz) = 5cd55fa974b06bf89ee128137a969e58a8c6ea1df20b100ddb6b23a58682bec8
SIZE (osslsigncode-1.2.tar.gz) = 83752

View file

@ -0,0 +1,15 @@
--- osslsigncode.c.orig Fri Jan 21 04:23:44 2005
+++ osslsigncode.c Thu Nov 9 15:31:37 2006
@@ -610,9 +610,10 @@
BIO_write(hash, indata + i, st.st_size - i);
- /* pad (with 0's) pe file to 8 byte boundary */
+ /* pad (with 0's) pe file to 8 byte boundary, but do not pad at all if
+ already aligned on 8 byte boundary. See http://sourceforge.net/tracker/index.php?func=detail&aid=1422627&group_id=129143&atid=713906 */
len = 8 - st.st_size % 8;
- if (len > 0) {
+ if (len > 0 && len != 8) {
memset(buf, 0, len);
BIO_write(hash, buf, len);
st.st_size += len;

View file

@ -0,0 +1,4 @@
Platform-independent tool for Authenticode signing of EXE/CAB files - uses
OpenSSL and libcurl. It also supports timestamping.
WWW: http://sourceforge.net/projects/osslsigncode/