Add xxdiff-2.0, a QT interface to view/merge differences between 2 or

3 files.
This commit is contained in:
Pete Fritchman 2001-11-07 10:40:30 +00:00
parent 5e65c4e862
commit 6ec5103bc6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49729
7 changed files with 68 additions and 0 deletions

View file

@ -240,6 +240,7 @@
SUBDIR += xsl-docbook-modular
SUBDIR += xslint
SUBDIR += xt
SUBDIR += xxdiff
SUBDIR += y2l
SUBDIR += yodl

37
textproc/xxdiff/Makefile Normal file
View file

@ -0,0 +1,37 @@
# New ports collection makefile for: xxdiff
# Date created: 11 August 2001
# Whom: Pete Fritchman <petef@databits.net>
#
# $FreeBSD$
#
PORTNAME= xxdiff
PORTVERSION= 2.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= petef@FreeBSD.org
BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
USE_GMAKE= yes
USE_QT_VER= 2
TMAKEENV= TMAKEPATH=${LOCALBASE}/share/tmake/freebsd-g++ QTDIR=${X11BASE}
MAKE_ENV+= QTDIR=${X11BASE} PTHREAD_LIBS=${PTHREAD_LIBS}
WRKSRC= ${WRKDIR}/xxdiff-${PORTVERSION}/src
do-build:
(cd ${WRKSRC}; ${SETENV} ${TMAKEENV} tmake -o Makefile xxdiff.pro)
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xxdiff ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${WRKSRC}/xxdiff --help-html > ${WRKDIR}/xxdiff.html
${INSTALL_DATA} ${WRKDIR}/xxdiff.html ${DOCSDIR}
.endif
.include <bsd.port.mk>

1
textproc/xxdiff/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (xxdiff-2.0.tar.gz) = 80b3f814002c06ba3eac3470995ba0d7

View file

@ -0,0 +1,17 @@
$FreeBSD$
--- xxdiff.pro.orig Tue Nov 6 15:00:01 2001
+++ xxdiff.pro Wed Nov 7 02:22:25 2001
@@ -80,6 +80,12 @@
solaris-cc:TMAKE_CXXFLAGS += -DCOMPILER_SUNWSPRO
+#
+# FreeBSD
+#
+freebsd-g++:TMAKE_LIBS += ${PTHREAD_LIBS}
+
+
# Add diff files to link against directly
DIFFUTILS_DIR = ../diffutils-2.7

View file

@ -0,0 +1 @@
QT interface to view/merge differences between 2 or 3 files

View file

@ -0,0 +1,8 @@
xxdiff is a graphical browser for viewing the differences between
two or three files, or between two directories, and can be used to
produce a merged version.
WWW: http://xxdiff.sourceforge.net/
- Pete
petef@FreeBSD.org

View file

@ -0,0 +1,3 @@
bin/xxdiff
%%PORTDOCS%%share/doc/xxdiff/xxdiff.html
%%PORTDOCS%%@dirrm share/doc/xxdiff