- Update to 0.3.8
PR: 140370 Submitted by: Henrik Friedrichsen <hrkfdn@gmail.com> (maintainer)
This commit is contained in:
parent
181a26995c
commit
6f2d0e6d94
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244159
6 changed files with 15 additions and 38 deletions
|
@ -6,9 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= echinus
|
||||
PORTVERSION= 0.3.6
|
||||
PORTVERSION= 0.3.8
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://rootshell.be/~polachok/code/
|
||||
MASTER_SITES= http://www.rootshell.be/~polachok/code/
|
||||
|
||||
MAINTAINER= hrkfdn@gmail.com
|
||||
COMMENT= A dynamic window manager for X11 based on dwm
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (echinus-0.3.6.tar.gz) = e12e3c3dc3a9e88b93602d14f8d118e0
|
||||
SHA256 (echinus-0.3.6.tar.gz) = 71c6b159d472f80765d0ab35908055d81559313200e0dbec9031a32f4048366e
|
||||
SIZE (echinus-0.3.6.tar.gz) = 29136
|
||||
MD5 (echinus-0.3.8.tar.gz) = f2e50090c051dba4cb7b708537be5165
|
||||
SHA256 (echinus-0.3.8.tar.gz) = 5d5b3c524ec05e3536a25436f549d49bf551f56b00e790281ff7e6547de2b546
|
||||
SIZE (echinus-0.3.8.tar.gz) = 28711
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.old 2008-08-19 16:57:30.000000000 -0300
|
||||
+++ Makefile 2008-08-31 17:46:50.000000000 -0300
|
||||
@@ -8,7 +8,7 @@
|
||||
FILES = draw.c parse.c ewmh.c config.h
|
||||
SRC = echinus.c
|
||||
OBJ = ${SRC:.c=.o}
|
||||
-CONF = /share/examples/echinus
|
||||
+CONF = /usr/local/etc/echinus/
|
||||
|
||||
all: options echinus ${HEADERS}
|
||||
|
|
@ -1,8 +1,12 @@
|
|||
--- _config.mk 2008-08-04 14:08:03.000000000 +0200
|
||||
+++ config.mk 2008-08-04 14:07:48.000000000 +0200
|
||||
@@ -7,16 +7,16 @@
|
||||
PREFIX = ${HOME}
|
||||
diff -Naur ./config.mk ../echinus-0.3.8/config.mk
|
||||
--- ./config.mk 2009-11-07 22:00:00.000000000 +0100
|
||||
+++ ../echinus-0.3.8/config.mk 2009-11-07 22:01:52.000000000 +0100
|
||||
@@ -6,10 +6,10 @@
|
||||
# paths
|
||||
PREFIX = /usr/local
|
||||
MANPREFIX = ${PREFIX}/share/man
|
||||
-CONF = /share/examples/echinus
|
||||
+CONF = ${PREFIX}/etc/echinus/
|
||||
|
||||
-X11INC = /usr/X11R6/include
|
||||
-X11LIB = /usr/X11R6/lib
|
||||
|
@ -11,19 +15,3 @@
|
|||
|
||||
# includes and libs
|
||||
INCS = -I. -I/usr/include -I${X11INC} `pkg-config --cflags xft`
|
||||
LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs xft`
|
||||
|
||||
# flags
|
||||
-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
|
||||
-LDFLAGS = -s ${LIBS}
|
||||
+CFLAGS += -Os ${INCS} -DVERSION=\"${VERSION}\"
|
||||
+LDFLAGS += -s ${LIBS}
|
||||
#CFLAGS = -g3 -ggdb3 -std=c99 -pedantic -Wall -O0 ${INCS} -DVERSION=\"${VERSION}\"
|
||||
#LDFLAGS = -g3 -ggdb3 ${LIBS}
|
||||
|
||||
@@ -26,4 +26,4 @@
|
||||
#CFLAGS += -xtarget=ultra
|
||||
|
||||
# compiler and linker
|
||||
-CC = cc
|
||||
+CC? = cc
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
Echinus has been installed.
|
||||
|
||||
A standard config file with its pixmaps has been installed to:
|
||||
PREFIX/etc/echinus/
|
||||
%%PREFIX%%/etc/echinus/
|
||||
Copy this folder to ~/.echinus/ and modify the echinusrc as you wish.
|
||||
|
||||
==============================================================================
|
||||
|
|
|
@ -6,4 +6,4 @@ Echinus supports a small subset of EWMH to be compatible
|
|||
with external panels and pagers.
|
||||
It draws a border around windows and also an optional titlebar.
|
||||
|
||||
WWW: http://rootshell.be/~polachok/code/
|
||||
WWW: http://www.rootshell.be/~polachok/code/
|
||||
|
|
Loading…
Reference in a new issue