Don't chgrp the /var/gdm directory to gdm during the instal phase since the
gdm user may not exist on the system yet. Instead, let the pkg-install script do this after verifying the gdm user and group exists. Reported by: pointyhat via kris
This commit is contained in:
parent
29ce428a7c
commit
6f49bd2548
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=162656
1 changed files with 10 additions and 3 deletions
|
@ -1,6 +1,6 @@
|
|||
--- config/Makefile.in.orig Fri May 12 15:37:48 2006
|
||||
+++ config/Makefile.in Fri May 12 15:38:05 2006
|
||||
@@ -682,7 +682,7 @@ install-data-hook: gdm.conf gdm.conf-cus
|
||||
--- config/Makefile.in.orig Wed May 17 13:47:25 2006
|
||||
+++ config/Makefile.in Wed May 17 13:47:50 2006
|
||||
@@ -682,13 +682,13 @@ install-data-hook: gdm.conf gdm.conf-cus
|
||||
if test '!' -d $(DESTDIR)$(logdir); then \
|
||||
$(mkinstalldirs) $(DESTDIR)$(logdir); \
|
||||
chmod 755 $(DESTDIR)$(logdir); \
|
||||
|
@ -9,3 +9,10 @@
|
|||
fi
|
||||
|
||||
if test '!' -d $(DESTDIR)$(authdir); then \
|
||||
$(mkinstalldirs) $(DESTDIR)$(authdir); \
|
||||
chmod 1770 $(DESTDIR)$(authdir); \
|
||||
- chown root:gdm $(DESTDIR)$(authdir); \
|
||||
+ chown root:wheel $(DESTDIR)$(authdir); \
|
||||
fi
|
||||
|
||||
system=`uname`; \
|
||||
|
|
Loading…
Reference in a new issue