biology/htslib: Update to 1.12

biology/samtools: Update to 1.12
biology/bcftools: Update to 1.12

Numerous enhancements, performance improvements, and bug fixes since 1.11

Build-tested all other htslib dependents, no revbumps should be needed

Reported by:    portscout
This commit is contained in:
Jason W. Bacon 2021-03-20 17:14:32 +00:00
parent 1131956c47
commit 6f516a8acf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=568874
17 changed files with 32 additions and 148 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bcftools
PORTVERSION= 1.11
PORTVERSION= 1.12
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@ -11,14 +11,13 @@ COMMENT= Tools for manipulating next-generation sequencing data
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libhts.so.3:biology/htslib
LIB_DEPENDS= libhts.so:biology/htslib
TEST_DEPENDS= bash:shells/bash
RUN_DEPENDS= bash:shells/bash
USES= autoreconf gmake localbase perl5 python:env shebangfix
USE_GITHUB= yes
USE_LDCONFIG= ${PREFIX}/libexec/${PORTNAME}
USE_PERL5= test
GH_ACCOUNT= samtools

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1603028344
SHA256 (samtools-bcftools-1.11_GH0.tar.gz) = f2d9a09fd7920754b60948b81ec047882864213b93a0cd1ef0372b0e025cba3f
SIZE (samtools-bcftools-1.11_GH0.tar.gz) = 3004923
TIMESTAMP = 1616112968
SHA256 (samtools-bcftools-1.12_GH0.tar.gz) = b29e6d41ca0bb3f1761bee81be0c423329928a724a75501641c1ac5065d65526
SIZE (samtools-bcftools-1.12_GH0.tar.gz) = 3048508

View file

@ -1,16 +1,6 @@
--- Makefile.orig 2020-10-18 13:31:52 UTC
--- Makefile.orig 2021-03-17 09:16:18 UTC
+++ Makefile
@@ -45,7 +45,8 @@ OBJS = main.o vcfindex.o tabix.o \
ccall.o em.o prob1.o kmin.o # the original samtools calling
PLUGIN_OBJS = vcfplugin.o
-prefix = /usr/local
+PREFIX ?= /usr/local
+prefix = $(PREFIX)
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
libdir = $(exec_prefix)/lib
@@ -58,13 +59,14 @@ pluginpath = $(plugindir)
@@ -58,13 +58,14 @@ pluginpath = $(plugindir)
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
misc_bindir = $(bindir)
@ -32,7 +22,7 @@
PROGRAMS = bcftools
MISC_SCRIPTS = \
@@ -142,7 +144,7 @@ print-version:
@@ -142,7 +143,7 @@ print-version:
ifdef USE_GPL
main.o : EXTRA_CPPFLAGS += -DUSE_GPL
OBJS += polysomy.o peakfit.o

View file

@ -1,20 +0,0 @@
--- test/test.pl.orig 2020-10-18 13:36:42 UTC
+++ test/test.pl
@@ -1236,7 +1236,7 @@ sub test_usage
my $command = $args{cmd};
my $commandpath = $$opts{bin}."/".$command;
my ($ret,$out) = _cmd("$commandpath $args{redirection} 2>&1");
- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
@@ -1291,7 +1291,7 @@ sub test_usage_subcommand
my $subcommand = $args{subcmd};
my $commandpath = $$opts{bin}."/".$command;
my ($ret,$out) = _cmd("$commandpath $subcommand $args{redirection} 2>&1");
- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);

View file

@ -1,13 +0,0 @@
[
{ type: install
message: <<EOM
The miscellaneous tools included with Bcftools have been installed to
%%PREFIX%%/bin/samtools_misc
Add that directory to your path if you want to use these tools.
Some of these tools depend on Perl5/Python, and it will need to be installed to
use them.
EOM
}
]

View file

@ -40,7 +40,7 @@ libexec/bcftools/smpl-stats.so
libexec/bcftools/split-vep.so
libexec/bcftools/split.so
libexec/bcftools/tag2tag.so
libexec/bcftools/trio-dnm.so
libexec/bcftools/trio-dnm2.so
libexec/bcftools/trio-stats.so
libexec/bcftools/trio-switch-rate.so
libexec/bcftools/variantkey-hex.so

View file

@ -2,8 +2,10 @@
# $FreeBSD$
PORTNAME= htslib
DISTVERSION= 1.11.0
DISTVERSION= 1.12
CATEGORIES= biology devel
# Github generated distfiles are incomplete, so use custom tarball
MASTER_SITES= https://github.com/samtools/htslib/releases/download/${DISTVERSION}/
MAINTAINER= jwb@FreeBSD.org
COMMENT= C library for high-throughput sequencing data formats
@ -15,12 +17,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libdeflate.so:archivers/libdeflate
TEST_DEPENDS= bash:shells/bash
USES= autoreconf gmake localbase pathfix perl5 shebangfix
USE_GITHUB= yes
USES= autoreconf gmake localbase pathfix perl5 shebangfix tar:bzip2
USE_PERL5= test
USE_LDCONFIG= yes
GH_ACCOUNT= samtools
GNU_CONFIGURE= yes
PATHFIX_MAKEFILEIN= Makefile
SHEBANG_FILES= test/*.pl

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1602982298
SHA256 (samtools-htslib-1.11.0_GH0.tar.gz) = 55356e78f25a20194488d94308335f409c3757101398961388caf38d3cce12dd
SIZE (samtools-htslib-1.11.0_GH0.tar.gz) = 1485848
TIMESTAMP = 1616112272
SHA256 (htslib-1.12.tar.bz2) = 2280141b46e953ba4ae01b98335a84f8e6ccbdb6d5cdbab7f70ee4f7e3b6f4ca
SIZE (htslib-1.12.tar.bz2) = 4094458

View file

@ -1,16 +1,6 @@
--- Makefile.orig 2020-10-18 00:44:56 UTC
--- Makefile.orig 2021-03-20 15:53:14 UTC
+++ Makefile
@@ -40,7 +40,8 @@ EXTRA_CFLAGS_PIC = -fpic
LDFLAGS = -fvisibility=hidden
LIBS = $(htslib_default_libs)
-prefix = /usr/local
+PREFIX ?= /usr/local
+prefix = $(PREFIX)
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
includedir = $(prefix)/include
@@ -53,13 +54,14 @@ man5dir = $(mandir)/man5
@@ -53,13 +53,14 @@ man5dir = $(mandir)/man5
man7dir = $(mandir)/man7
pkgconfigdir= $(prefix)/libdata/pkgconfig
@ -32,7 +22,7 @@
# Set by config.mk if plugins are enabled
plugindir =
@@ -100,7 +102,7 @@ BUILT_THRASH_PROGRAMS = \
@@ -102,7 +103,7 @@ BUILT_THRASH_PROGRAMS = \
test/thrash_threads6 \
test/thrash_threads7
@ -40,4 +30,4 @@
+all: lib-static lib-shared $(BUILT_PROGRAMS) plugins \
htslib_static.mk htslib-uninstalled.pc
HTSPREFIX =
ALL_CPPFLAGS = -I. $(CPPFLAGS)

View file

@ -1,24 +0,0 @@
--- hfile_libcurl.c.orig 2020-09-22 12:15:49 UTC
+++ hfile_libcurl.c
@@ -22,6 +22,10 @@ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR O
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE. */
+#ifndef ENOTRECOVERABLE
+#define ENOTRECOVERABLE EIO
+#endif
+
#define HTS_BUILDING_LIBRARY // Enables HTSLIB_EXPORT, see htslib/hts_defs.h
#include <config.h>
@@ -73,6 +77,10 @@ typedef struct {
unsigned int num;
unsigned int size;
} hdrlist;
+
+#ifndef ENOTRECOVERABLE
+#define ENOTRECOVERABLE EIO
+#endif
typedef struct {
hdrlist fixed; // List of headers supplied at hopen()

View file

@ -1,10 +0,0 @@
--- sam.c.orig 2020-10-18 00:50:46 UTC
+++ sam.c
@@ -35,6 +35,7 @@ DEALINGS IN THE SOFTWARE. */
#include <assert.h>
#include <signal.h>
#include <inttypes.h>
+#include <unistd.h> // usleep()
// Suppress deprecation message for cigar_tab, which we initialise
#include "htslib/hts_defs.h"

View file

@ -8,6 +8,7 @@ include/htslib/hfile.h
include/htslib/hts.h
include/htslib/hts_defs.h
include/htslib/hts_endian.h
include/htslib/hts_expr.h
include/htslib/hts_log.h
include/htslib/hts_os.h
include/htslib/kbitset.h
@ -30,7 +31,7 @@ include/htslib/vcf_sweep.h
include/htslib/vcfutils.h
lib/libhts.a
lib/libhts.so
lib/libhts.so.1.11
lib/libhts.so.%%PORTVERSION%%
lib/libhts.so.3
libdata/pkgconfig/htslib.pc
man/man1/bgzip.1.gz

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= samtools
DISTVERSION= 1.11
DISTVERSION= 1.12
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@ -11,7 +11,7 @@ COMMENT= Tools for manipulating next-generation sequencing data
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libhts.so.3:biology/htslib
LIB_DEPENDS= libhts.so:biology/htslib
TEST_DEPENDS= bash:shells/bash
USES= autoreconf gmake localbase ncurses perl5 python:env shebangfix

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1602982679
SHA256 (samtools-samtools-1.11_GH0.tar.gz) = 80a54e93c5d111c15c005ee96a578bcd7e1bde34dba2242d981c539ff32f1738
SIZE (samtools-samtools-1.11_GH0.tar.gz) = 4516328
TIMESTAMP = 1616112844
SHA256 (samtools-samtools-1.12_GH0.tar.gz) = a31695aca88b6acf52e1b579d84edb6b54f7b1b22227aad1ef6c6ccdd10314cf
SIZE (samtools-samtools-1.12_GH0.tar.gz) = 4528460

View file

@ -1,16 +1,6 @@
--- Makefile.orig 2020-10-18 00:55:50 UTC
--- Makefile.orig 2021-03-17 09:14:26 UTC
+++ Makefile
@@ -49,7 +49,8 @@ AOBJS= bam_index.o bam_plcmd.o sam_view.o bam_fas
bam_ampliconclip.o amplicon_stats.o
LZ4OBJS = $(LZ4DIR)/lz4.o
-prefix = /usr/local
+PREFIX ?= /usr/local
+prefix = $(PREFIX)
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
datarootdir = $(prefix)/share
@@ -59,14 +60,14 @@ man1dir = $(mandir)/man1
@@ -59,14 +59,14 @@ man1dir = $(mandir)/man1
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
misc_bindir = $(bindir)
@ -23,8 +13,8 @@
-INSTALL_SCRIPT = $(INSTALL_PROGRAM)
-
+# Use BSD_INSTALL_PROGRAM to strip when WITH_DEBUG not set
+MKDIR_P = mkdir -p
+INSTALL = install -p
+MKDIR_P = mkdir -p
+INSTALL = install -p
+INSTALL_DATA = ${BSD_INSTALL_DATA}
+INSTALL_DIR = $(MKDIR_P)
+INSTALL_MAN = ${BSD_INSTALL_MAN}

View file

@ -1,20 +0,0 @@
--- test/test.pl.orig 2020-07-21 20:48:50 UTC
+++ test/test.pl
@@ -907,7 +907,7 @@ sub test_usage
my $command = $args{cmd};
my $commandpath = $$opts{bin}."/".$command;
my ($ret,$out,$err) = _cmd("$commandpath $args{redirection}");
- if ( $err =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath: $out"); return; }
+ if ( $err =~ m/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath: $out"); return; }
my @sections = ($err =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
@@ -965,7 +965,7 @@ sub test_usage_subcommand
my $commandpath = $$opts{bin}."/".$command;
my ($ret,$out,$err) = _cmd("$commandpath $subcommand $args{redirection}");
- if ( $err =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath $subcommand: $out"); return; }
+ if ( $err =~ m/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath $subcommand: $out"); return; }
if ( $err =~ m/not.*implemented/is ) { failed($opts,msg=>$test,reason=>"subcommand indicates it is not implemented",expect_fail=>1); return; }

View file

@ -2,6 +2,7 @@ bin/ace2sam
bin/blast2sam.pl
bin/bowtie2sam.pl
bin/export2sam.pl
bin/fasta-sanitize.pl
bin/interpolate_sam.pl
bin/maq2sam-long
bin/maq2sam-short