-Update to 0.8.5.

-Add a new knob, WITH_CAMPAIGN (a new campaign server).
-GCC 3.4 is now required, any patch(es) to remove USE_GCC=3.4 is welcome.
-files/patch-configure was created by Ulrich Spoerlein <q@uni.de>. [1]

PR:		ports/71111 [1]
Submitted by:	Ulrich Spoerlein <q@uni.de>
This commit is contained in:
Jeremy Messenger 2004-10-11 22:42:04 +00:00
parent e31c15dd63
commit 6f7b0b4124
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118642
14 changed files with 2322 additions and 534 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
PORTVERSION= 0.8
PORTVERSION= 0.8.5
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wesnoth
@ -18,12 +18,21 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
USE_GCC= 3.4
USE_SDL= image mixer net ttf
USE_GNOME= gnometarget
USE_GMAKE= yes
WANT_GNOME= yes
USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-sdltest \
--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--with-localedir=${PREFIX}/share/locale
CONFIGURE_ENV= CPPFLAGS="-ftemplate-depth-45" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN6= wesnoth.6 wesnoth_editor.6 wesnothd.6
@ -34,6 +43,13 @@ PLIST_SUB+= LITE:="@comment "
PLIST_SUB+= LITE:=""
.endif
.if defined(WITH_CAMPAIGN) || defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --enable-campaign-server
PLIST_SUB+= CAMPAIGN:=""
.else
PLIST_SUB+= CAMPAIGN:="@comment "
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@ -62,38 +78,41 @@ PLIST_SUB+= TOOLS:="@comment "
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomehier}!=""
CONFIGURE_ARGS+= --enable-gnome
CONFIGURE_ARGS+= --with-gnome
PLIST_SUB+= GNOME:=""
.else
PLIST_SUB+= GNOME:="@comment "
.endif
.if exists(${LOCALBASE}/bin/kde-config)
CONFIGURE_ARGS+= --enable-kde
CONFIGURE_ARGS+= --with-kde
PLIST_SUB+= KDE:=""
.else
PLIST_SUB+= KDE:="@comment "
.endif
pre-everything::
.if !defined(LITE) || !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
.if !defined(LITE) || !defined(WITH_CAMPAIGN) || !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} " "
.endif
.if !defined(LITE)
@${ECHO_MSG} "LITE=yes for lite version of Wesnoth (without music)."
.endif
.if !defined(WITH_CAMPAIGN)
@${ECHO_MSG} "WITH_CAMPAIGN=yes to enable compilation of campaign server."
.endif
.if !defined(WITH_DEBUG)
@${ECHO_MSG} "WITH_DEBUG=yes to enable debugging in Wesnoth."
.endif
.if !defined(WITH_EDITOR)
@${ECHO_MSG} "WITH_EDITOR=yes for enable compilation editor."
@${ECHO_MSG} "WITH_EDITOR=yes to enable compilation of map editor."
.endif
.if !defined(WITH_SERVER)
@${ECHO_MSG} "WITH_SERVER=yes for enable compilation of server."
@${ECHO_MSG} "WITH_SERVER=yes to enable compilation of server."
.endif
.if !defined(WITH_TOOLS)
@${ECHO_MSG} "WITH_TOOLS=yes for enable compilation of translation tools."
@${ECHO_MSG} "WITH_TOOLS=yes to enable compilation of tools for translators and artists."
.endif
post-patch:

View file

@ -1,4 +1,4 @@
MD5 (wesnoth-0.8.tar.gz) = c6258d08645a97c311c9538128f5af6e
SIZE (wesnoth-0.8.tar.gz) = 22171378
MD5 (wesnoth-lite-0.8.tar.gz) = 81d25853f528c13886f083a2585719c3
SIZE (wesnoth-lite-0.8.tar.gz) = 8872249
MD5 (wesnoth-0.8.5.tar.gz) = 2b7cee60a6a37662f628e8971f18b5fc
SIZE (wesnoth-0.8.5.tar.gz) = 31763952
MD5 (wesnoth-lite-0.8.5.tar.gz) = e3e12fbf733b28d54d91274f56f636b7
SIZE (wesnoth-lite-0.8.5.tar.gz) = 17669038

View file

@ -0,0 +1,74 @@
--- configure.orig Tue Oct 5 23:42:20 2004
+++ configure Tue Oct 5 23:43:44 2004
@@ -10043,36 +10043,6 @@
-if test x$kde = xyes && test x$kdefound = xyes; then
- KDE_TRUE=
- KDE_FALSE='#'
-else
- KDE_TRUE='#'
- KDE_FALSE=
-fi
-
-
-
-if test x$gnome = xyes && test x$gnome1found = xyes; then
- GNOME1_TRUE=
- GNOME1_FALSE='#'
-else
- GNOME1_TRUE='#'
- GNOME1_FALSE=
-fi
-
-
-
-if test x$gnome = xyes && test x$gnome1found = xno; then
- GNOME2_TRUE=
- GNOME2_FALSE='#'
-else
- GNOME2_TRUE='#'
- GNOME2_FALSE=
-fi
-
-
-
if test x$GXX = xyes; then
GCC_TRUE=
GCC_FALSE='#'
@@ -13259,6 +13229,34 @@
fi
+
+if test x$kde = xyes && test x$kdefound = xyes; then
+ KDE_TRUE=
+ KDE_FALSE='#'
+else
+ KDE_TRUE='#'
+ KDE_FALSE=
+fi
+
+
+
+if test x$gnome = xyes && test x$gnome1found = xyes; then
+ GNOME1_TRUE=
+ GNOME1_FALSE='#'
+else
+ GNOME1_TRUE='#'
+ GNOME1_FALSE=
+fi
+
+
+
+if test x$gnome = xyes && test x$gnome1found = xno; then
+ GNOME2_TRUE=
+ GNOME2_FALSE='#'
+else
+ GNOME2_TRUE='#'
+ GNOME2_FALSE=
+fi

View file

@ -0,0 +1,12 @@
--- src/Makefile.in.orig Tue Oct 5 23:45:33 2004
+++ src/Makefile.in Tue Oct 5 23:45:59 2004
@@ -660,8 +660,7 @@
wesconfig.h
AM_CXXFLAGS = @SDL_CFLAGS@ -DWESNOTH_PATH=\"$(pkgdatadir)\" \
- -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR) \
- -I../intl -I$(top_srcdir)/intl
+ -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR)
CXXLD = $(LDPREFIX) $(CXX)
all: all-recursive

View file

@ -1,10 +1,11 @@
--- src/help.cpp.orig Sat Jul 3 20:44:17 2004
+++ src/help.cpp Sat Jul 3 20:44:25 2004
@@ -27,7 +27,6 @@
--- src/help.cpp.orig Tue Oct 5 23:47:06 2004
+++ src/help.cpp Tue Oct 5 23:47:19 2004
@@ -29,7 +29,7 @@
#include <cassert>
#include <algorithm>
#include <iostream>
-#include <locale>
+#include <locale.h>
#include <queue>
#include <set>
#include <stack>

View file

@ -1,11 +0,0 @@
--- src/scoped_resource.hpp.orig Sat Jul 3 16:23:45 2004
+++ src/scoped_resource.hpp Sat Jul 3 16:24:35 2004
@@ -13,6 +13,8 @@
#ifndef SCOPED_RESOURCE_H_INCLUDED
#define SCOPED_RESOURCE_H_INCLUDED
+#include <cstdio>
+
/**
* The util namespace should take all classes which are of a generic type,
* used to perform common tasks which are not BibleTime-specific. See

File diff suppressed because it is too large Load diff

View file

@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
PORTVERSION= 0.8
PORTVERSION= 0.8.5
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wesnoth
@ -18,12 +18,21 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
USE_GCC= 3.4
USE_SDL= image mixer net ttf
USE_GNOME= gnometarget
USE_GMAKE= yes
WANT_GNOME= yes
USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-sdltest \
--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--with-localedir=${PREFIX}/share/locale
CONFIGURE_ENV= CPPFLAGS="-ftemplate-depth-45" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN6= wesnoth.6 wesnoth_editor.6 wesnothd.6
@ -34,6 +43,13 @@ PLIST_SUB+= LITE:="@comment "
PLIST_SUB+= LITE:=""
.endif
.if defined(WITH_CAMPAIGN) || defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --enable-campaign-server
PLIST_SUB+= CAMPAIGN:=""
.else
PLIST_SUB+= CAMPAIGN:="@comment "
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@ -62,38 +78,41 @@ PLIST_SUB+= TOOLS:="@comment "
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomehier}!=""
CONFIGURE_ARGS+= --enable-gnome
CONFIGURE_ARGS+= --with-gnome
PLIST_SUB+= GNOME:=""
.else
PLIST_SUB+= GNOME:="@comment "
.endif
.if exists(${LOCALBASE}/bin/kde-config)
CONFIGURE_ARGS+= --enable-kde
CONFIGURE_ARGS+= --with-kde
PLIST_SUB+= KDE:=""
.else
PLIST_SUB+= KDE:="@comment "
.endif
pre-everything::
.if !defined(LITE) || !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
.if !defined(LITE) || !defined(WITH_CAMPAIGN) || !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} " "
.endif
.if !defined(LITE)
@${ECHO_MSG} "LITE=yes for lite version of Wesnoth (without music)."
.endif
.if !defined(WITH_CAMPAIGN)
@${ECHO_MSG} "WITH_CAMPAIGN=yes to enable compilation of campaign server."
.endif
.if !defined(WITH_DEBUG)
@${ECHO_MSG} "WITH_DEBUG=yes to enable debugging in Wesnoth."
.endif
.if !defined(WITH_EDITOR)
@${ECHO_MSG} "WITH_EDITOR=yes for enable compilation editor."
@${ECHO_MSG} "WITH_EDITOR=yes to enable compilation of map editor."
.endif
.if !defined(WITH_SERVER)
@${ECHO_MSG} "WITH_SERVER=yes for enable compilation of server."
@${ECHO_MSG} "WITH_SERVER=yes to enable compilation of server."
.endif
.if !defined(WITH_TOOLS)
@${ECHO_MSG} "WITH_TOOLS=yes for enable compilation of translation tools."
@${ECHO_MSG} "WITH_TOOLS=yes to enable compilation of tools for translators and artists."
.endif
post-patch:

View file

@ -1,4 +1,4 @@
MD5 (wesnoth-0.8.tar.gz) = c6258d08645a97c311c9538128f5af6e
SIZE (wesnoth-0.8.tar.gz) = 22171378
MD5 (wesnoth-lite-0.8.tar.gz) = 81d25853f528c13886f083a2585719c3
SIZE (wesnoth-lite-0.8.tar.gz) = 8872249
MD5 (wesnoth-0.8.5.tar.gz) = 2b7cee60a6a37662f628e8971f18b5fc
SIZE (wesnoth-0.8.5.tar.gz) = 31763952
MD5 (wesnoth-lite-0.8.5.tar.gz) = e3e12fbf733b28d54d91274f56f636b7
SIZE (wesnoth-lite-0.8.5.tar.gz) = 17669038

View file

@ -0,0 +1,74 @@
--- configure.orig Tue Oct 5 23:42:20 2004
+++ configure Tue Oct 5 23:43:44 2004
@@ -10043,36 +10043,6 @@
-if test x$kde = xyes && test x$kdefound = xyes; then
- KDE_TRUE=
- KDE_FALSE='#'
-else
- KDE_TRUE='#'
- KDE_FALSE=
-fi
-
-
-
-if test x$gnome = xyes && test x$gnome1found = xyes; then
- GNOME1_TRUE=
- GNOME1_FALSE='#'
-else
- GNOME1_TRUE='#'
- GNOME1_FALSE=
-fi
-
-
-
-if test x$gnome = xyes && test x$gnome1found = xno; then
- GNOME2_TRUE=
- GNOME2_FALSE='#'
-else
- GNOME2_TRUE='#'
- GNOME2_FALSE=
-fi
-
-
-
if test x$GXX = xyes; then
GCC_TRUE=
GCC_FALSE='#'
@@ -13259,6 +13229,34 @@
fi
+
+if test x$kde = xyes && test x$kdefound = xyes; then
+ KDE_TRUE=
+ KDE_FALSE='#'
+else
+ KDE_TRUE='#'
+ KDE_FALSE=
+fi
+
+
+
+if test x$gnome = xyes && test x$gnome1found = xyes; then
+ GNOME1_TRUE=
+ GNOME1_FALSE='#'
+else
+ GNOME1_TRUE='#'
+ GNOME1_FALSE=
+fi
+
+
+
+if test x$gnome = xyes && test x$gnome1found = xno; then
+ GNOME2_TRUE=
+ GNOME2_FALSE='#'
+else
+ GNOME2_TRUE='#'
+ GNOME2_FALSE=
+fi

View file

@ -0,0 +1,12 @@
--- src/Makefile.in.orig Tue Oct 5 23:45:33 2004
+++ src/Makefile.in Tue Oct 5 23:45:59 2004
@@ -660,8 +660,7 @@
wesconfig.h
AM_CXXFLAGS = @SDL_CFLAGS@ -DWESNOTH_PATH=\"$(pkgdatadir)\" \
- -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR) \
- -I../intl -I$(top_srcdir)/intl
+ -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR)
CXXLD = $(LDPREFIX) $(CXX)
all: all-recursive

View file

@ -1,10 +1,11 @@
--- src/help.cpp.orig Sat Jul 3 20:44:17 2004
+++ src/help.cpp Sat Jul 3 20:44:25 2004
@@ -27,7 +27,6 @@
--- src/help.cpp.orig Tue Oct 5 23:47:06 2004
+++ src/help.cpp Tue Oct 5 23:47:19 2004
@@ -29,7 +29,7 @@
#include <cassert>
#include <algorithm>
#include <iostream>
-#include <locale>
+#include <locale.h>
#include <queue>
#include <set>
#include <stack>

View file

@ -1,11 +0,0 @@
--- src/scoped_resource.hpp.orig Sat Jul 3 16:23:45 2004
+++ src/scoped_resource.hpp Sat Jul 3 16:24:35 2004
@@ -13,6 +13,8 @@
#ifndef SCOPED_RESOURCE_H_INCLUDED
#define SCOPED_RESOURCE_H_INCLUDED
+#include <cstdio>
+
/**
* The util namespace should take all classes which are of a generic type,
* used to perform common tasks which are not BibleTime-specific. See

File diff suppressed because it is too large Load diff