upgrade to 0.9.2
add WWW utilize PORTDOCS, DOCSDIR, DATADIR
This commit is contained in:
parent
b60d2dcc1e
commit
6f7c2f0282
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73927
10 changed files with 1518 additions and 882 deletions
|
@ -6,9 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= osg
|
||||
PORTVERSION= 0.8.45
|
||||
PORTVERSION= 0.9.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.openscenegraph.org/download/snapshots/
|
||||
DISTNAME= OpenSceneGraph-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
|
@ -18,8 +19,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
|||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
freetype.9:${PORTSDIR}/print/freetype2
|
||||
|
||||
DISTNAME= OpenSceneGraph-${PORTVERSION}
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_MESA= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
@ -29,10 +29,16 @@ MAKE_ENV= OSGHOME=${WRKSRC}
|
|||
# opt = optimized ($OPTF added); debug = debug ($DBGF added); opt is default
|
||||
ALL_TARGET= opt
|
||||
|
||||
post-patch:
|
||||
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e "s|malloc\.h|stdlib.h|"
|
||||
|
||||
post-install:
|
||||
${LN} -sf ${PREFIX}/share/osg/bin/sgv ${PREFIX}/bin
|
||||
${LN} -sf ${PREFIX}/share/osg/bin/osgconv ${PREFIX}/bin
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
|
||||
${LN} -sf ${DATADIR}/bin/sgv ${PREFIX}/bin
|
||||
${LN} -sf ${DATADIR}/bin/osgconv ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (OpenSceneGraph-0.8.45.tar.gz) = 2d325c9222ebd55dfb18c13591c82201
|
||||
MD5 (OpenSceneGraph-0.9.2.tar.gz) = 11f597bc4e1b1486343eaca2a4bfe940
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/osgDB/ORIG/FileUtils_Unix.cpp Wed Apr 24 10:52:53 2002
|
||||
+++ src/osgDB/FileUtils_Unix.cpp Fri May 24 19:19:14 2002
|
||||
@@ -30,7 +30,7 @@
|
||||
#if defined(__CYGWIN__)
|
||||
static const char *s_default_dso_path = "/usr/lib/:/usr/local/lib/:";
|
||||
#else
|
||||
-static const char *s_default_dso_path = "/usr/lib/:/usr/local/lib/:";
|
||||
+static const char *s_default_dso_path = "/usr/lib/:/usr/X11R6/lib/:";
|
||||
#endif // __CYGWIN__
|
||||
static char *s_filePath = ".:";
|
||||
#endif
|
|
@ -3,4 +3,4 @@ real-time, photo-realistic rendering of large 3D models. Uses range from
|
|||
visual simulation, to scientific modelling, to games, to whatever you can
|
||||
think of!
|
||||
|
||||
http://www.openscenegraph.org/
|
||||
WWW: http://www.openscenegraph.org/
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -6,9 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= osg
|
||||
PORTVERSION= 0.8.45
|
||||
PORTVERSION= 0.9.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.openscenegraph.org/download/snapshots/
|
||||
DISTNAME= OpenSceneGraph-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
|
@ -18,8 +19,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
|||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
freetype.9:${PORTSDIR}/print/freetype2
|
||||
|
||||
DISTNAME= OpenSceneGraph-${PORTVERSION}
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_MESA= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
@ -29,10 +29,16 @@ MAKE_ENV= OSGHOME=${WRKSRC}
|
|||
# opt = optimized ($OPTF added); debug = debug ($DBGF added); opt is default
|
||||
ALL_TARGET= opt
|
||||
|
||||
post-patch:
|
||||
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e "s|malloc\.h|stdlib.h|"
|
||||
|
||||
post-install:
|
||||
${LN} -sf ${PREFIX}/share/osg/bin/sgv ${PREFIX}/bin
|
||||
${LN} -sf ${PREFIX}/share/osg/bin/osgconv ${PREFIX}/bin
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
|
||||
${LN} -sf ${DATADIR}/bin/sgv ${PREFIX}/bin
|
||||
${LN} -sf ${DATADIR}/bin/osgconv ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (OpenSceneGraph-0.8.45.tar.gz) = 2d325c9222ebd55dfb18c13591c82201
|
||||
MD5 (OpenSceneGraph-0.9.2.tar.gz) = 11f597bc4e1b1486343eaca2a4bfe940
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/osgDB/ORIG/FileUtils_Unix.cpp Wed Apr 24 10:52:53 2002
|
||||
+++ src/osgDB/FileUtils_Unix.cpp Fri May 24 19:19:14 2002
|
||||
@@ -30,7 +30,7 @@
|
||||
#if defined(__CYGWIN__)
|
||||
static const char *s_default_dso_path = "/usr/lib/:/usr/local/lib/:";
|
||||
#else
|
||||
-static const char *s_default_dso_path = "/usr/lib/:/usr/local/lib/:";
|
||||
+static const char *s_default_dso_path = "/usr/lib/:/usr/X11R6/lib/:";
|
||||
#endif // __CYGWIN__
|
||||
static char *s_filePath = ".:";
|
||||
#endif
|
|
@ -3,4 +3,4 @@ real-time, photo-realistic rendering of large 3D models. Uses range from
|
|||
visual simulation, to scientific modelling, to games, to whatever you can
|
||||
think of!
|
||||
|
||||
http://www.openscenegraph.org/
|
||||
WWW: http://www.openscenegraph.org/
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue