- Add missing depend on libxml [1]
- Fix build on < 5.4 (5.3, 4.x). Unbreak on 4.x Submitted by: maintainer Reported by: kris via pointyhat [1]
This commit is contained in:
parent
1dbe97a96c
commit
6f823f4166
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139964
3 changed files with 37 additions and 1 deletions
|
@ -20,6 +20,8 @@ LIB_DEPENDS= physfs-1.0.0:${PORTSDIR}/devel/physfs
|
|||
USE_BZIP2= yes
|
||||
USE_GCC= 3.2+
|
||||
USE_SDL= sdl mixer image ttf gfx
|
||||
USE_GNOME= libxml2
|
||||
USE_REINPLACE= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-libphysfs=${PREFIX}
|
||||
|
@ -30,7 +32,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= "Does not build on 4.x"
|
||||
pre-configure::
|
||||
@${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
|
||||
${WRKSRC}/src/gui/Filter.cpp ${WRKSRC}/src/gui/Gradient.hpp \
|
||||
${WRKSRC}/src/gui/Color.hpp
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 504000
|
||||
pre-configure::
|
||||
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-src-gui-Gradient.cpp
|
||||
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-src-gui-PainterSDL-PainterSDL.cpp
|
||||
.endif
|
||||
|
||||
do-build:
|
||||
|
|
12
games/lincity-ng/files/extra-src-gui-Gradient.cpp
Normal file
12
games/lincity-ng/files/extra-src-gui-Gradient.cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/gui/Gradient.cpp.orig Fri Jul 15 19:47:11 2005
|
||||
+++ src/gui/Gradient.cpp Sat Jul 23 12:40:46 2005
|
||||
@@ -28,9 +28,7 @@
|
||||
#include "Painter.hpp"
|
||||
#include "ComponentFactory.hpp"
|
||||
|
||||
-#ifdef _MSC_VER
|
||||
#define lrintf(x) (long int)x
|
||||
-#endif
|
||||
|
||||
Gradient::Gradient()
|
||||
: direction(LEFT_RIGHT)
|
|
@ -0,0 +1,13 @@
|
|||
--- src/gui/PainterSDL/PainterSDL.cpp.orig Fri Jul 15 19:47:12 2005
|
||||
+++ src/gui/PainterSDL/PainterSDL.cpp Sat Jul 23 12:41:09 2005
|
||||
@@ -30,10 +30,8 @@
|
||||
|
||||
#include "TextureSDL.hpp"
|
||||
|
||||
-#ifdef _MSC_VER
|
||||
#define lrint(x) (long int)x
|
||||
#define lroundf(x) (long int)(x + .5)
|
||||
-#endif
|
||||
|
||||
PainterSDL::PainterSDL(SDL_Surface* _target)
|
||||
: target(_target)
|
Loading…
Reference in a new issue