Rather than try to hack up the GNU strsignal (and psignal) to play nice

on 5-CURRENT, just use our native one.
This commit is contained in:
David E. O'Brien 2002-11-25 19:02:28 +00:00
parent aee1245fca
commit 6fb4483d59
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71092
3 changed files with 22 additions and 15 deletions

View file

@ -0,0 +1,8 @@
--- libiberty/Makefile.in.orig Sat May 23 15:32:53 1998
+++ libiberty/Makefile.in Sun Nov 24 14:17:03 2002
@@ -120 +120 @@
- strrchr.c strsignal.c strstr.c strtod.c strtol.c strtoul.c \
+ strrchr.c strstr.c strtod.c strtol.c strtoul.c \
@@ -128 +128 @@
- strsignal.o xatexit.o xexit.o xmalloc.o xstrdup.o xstrerror.o
+ xatexit.o xexit.o xmalloc.o xstrdup.o xstrerror.o

View file

@ -1,11 +0,0 @@
--- libiberty/strsignal.c.orig Sun Nov 3 21:38:47 2002
+++ libiberty/strsignal.c Sun Nov 3 21:39:31 2002
@@ -244,7 +244,7 @@
#else
#ifdef NSIG
-static int sys_nsig = NSIG;
+static __const int sys_nsig = NSIG;
#else
#ifdef _NSIG
static int sys_nsig = _NSIG;

View file

@ -1,6 +1,6 @@
--- gcc/Makefile.in.orig Thu Feb 25 12:40:16 1999
+++ gcc/Makefile.in Mon Mar 1 04:36:40 1999
@@ -793,7 +793,7 @@
--- gcc/Makefile.in.orig Sun Mar 7 16:22:20 1999
+++ gcc/Makefile.in Sun Nov 24 23:51:04 2002
@@ -768,7 +768,7 @@
rm -f config.run
$(srcdir)/configure: $(srcdir)/configure.in
@ -9,7 +9,7 @@
# cstamp-h.in controls rebuilding of config.in.
# It is named cstamp-h.in and not stamp-h.in so the mostlyclean rule doesn't
@@ -806,7 +806,7 @@
@@ -781,7 +781,7 @@
# ??? Newer versions have a maintainer mode that may be useful here.
$(srcdir)/config.in: $(srcdir)/cstamp-h.in
$(srcdir)/cstamp-h.in: $(srcdir)/configure.in $(srcdir)/acconfig.h
@ -18,3 +18,13 @@
@rm -f $(srcdir)/cstamp-h.in
echo timestamp > $(srcdir)/cstamp-h.in
auto-host.h: cstamp-h ; @true
@@ -1914,7 +1914,8 @@
SYSCALLS.c.X: $(srcdir)/sys-types.h $(srcdir)/sys-protos.h $(GCC_PASSES) \
stmp-int-hdrs
-rm -f SYSCALLS.c tmp-SYSCALLS.s
- cat $(srcdir)/sys-types.h $(srcdir)/sys-protos.h > SYSCALLS.c
+ echo "#define __NO_GNUC_VA_LIST 1" > SYSCALLS.c
+ cat $(srcdir)/sys-types.h $(srcdir)/sys-protos.h >> SYSCALLS.c
$(GCC_FOR_TARGET) $(GCC_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) \
-aux-info $@ -S -o tmp-SYSCALLS.s SYSCALLS.c
-rm -f SYSCALLS.c tmp-SYSCALLS.s