- Upgrade to the latest release;

- Utilize umfpack

PR:             61180
Submitter by:   Thierry Thomas <thierry@pompo.net>
Approved by:    erwin (mentor) (implicitly)
This commit is contained in:
Clement Laforet 2004-01-11 17:23:36 +00:00
parent 29594d743c
commit 6ffd726c9d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97934
4 changed files with 29 additions and 14 deletions

View file

@ -6,9 +6,10 @@
#
PORTNAME= freefem++
PORTVERSION= 1.36
PORTVERSION= 1.37
CATEGORIES= math science
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/freefem/
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/freefem/ \
http://mule.ann.jussieu.fr/~hecht/ftp/freefem/
DISTNAME= FreeFem++v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@ -42,7 +43,7 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.for direx in "" -bug -eigen -tutorial
.for direx in "" -bug -eigen -load -mpi -tutorial
@${MKDIR} ${EXAMPLESDIR}/${direx:S/-//}
@for sample in `${LS} ${WRKSRC}/examples++${direx}` ; do \
${INSTALL_DATA} ${WRKSRC}/examples++${direx}/$$sample \

View file

@ -1 +1 @@
MD5 (FreeFem++v1.36.tar.gz) = ca98127c028251bdf32fb2aa228bd89b
MD5 (FreeFem++v1.37.tar.gz) = 89414fed9fd5f0ced3c1790702214dec

View file

@ -1,30 +1,35 @@
--- src/Makefile-linux.orig Thu Jan 2 14:30:30 2003
+++ src/Makefile-linux Thu Oct 23 23:42:32 2003
@@ -1,16 +1,15 @@
--- src/Makefile-linux.orig Fri Jan 9 09:17:19 2004
+++ src/Makefile-linux Sat Jan 10 17:52:42 2004
@@ -1,18 +1,18 @@
-LIBLOCAL = -ldl # for dlopen (see load.cpp and man dlopen)
-LIBX11= -L/usr/X11R6/lib -lX11 -lm
-INCLUDEX11 = /usr/X11R6/include
-CXX=g++ #C++ compiler
-CXXMPI=mpiCC # compilation with mpi
-OOPTFLAGS= -O # compilation with optimisation
+# $FreeBSD$
+LIBX11= -L$(X11BASE)/lib -lX11 -lm
+#LIBLOCAL = -ldl # for dlopen (see load.cpp and man dlopen)
+LIBX11= -L$(X11BASE)/lib -lX11 -lm
+INCLUDEX11 = $(X11BASE)/include
+OOPTFLAGS= -Wno-deprecated
GOPTFLAGS= -g # compilation with debugging
#--------------------------------------------------
# the flag of eigen value part with arpack++ tools
#-------------------------------------------------
-ARPACKDIR=../../arpack/ARPACK # here the arpack dir is at same level of FreeFem++v... dir
EIGEN= eigenvalue.o
-LIBARPACK= -L../../arpack/ARPACK -larpack_linux -llapack -lblas
-LIBARPACK= -L$(ARPACKDIR) -larpack_linux -llapack -lblas
-LIBF77= -lg2c
-INCARPACKPP = -DEIGENVALUE -I../../arpack/arpack++/include
-INCARPACKPP = -DEIGENVALUE -I../arpack/include # the FreeFem++ arpack++ files (in freefem tree)
+LIBARPACK= -L$(LOCALBASE)/lib ${LOCALBASE}/lib/libarpack.a -lalapack -lf77blas -lcblas -latlas
+LIBF77= -lg2c -lm
+INCARPACKPP = -DEIGENVALUE -I$(LOCALBASE)/include/ARPACK++
+INCARPACKPP = -DEIGENVALUE -I$(LOCALBASE)/include/ARPACK++
+IUMFPACK= -DUMFPACK -I$(LOCALBASE)/include/UMFPACK -I$(LOCALBASE)/include/AMD
+LIBUMFPACK= -L$(LOCALBASE)/lib -lumfpack -lamd
# ------------------------------
# compilation flags of FreeFem++
# ------------------------------
@@ -29,7 +28,7 @@
@@ -31,7 +31,7 @@
# ---------------------------
# install and compile dir.
# ----------------------

View file

@ -9,7 +9,6 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/NSP1P1.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/NSP1P1b.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/NSP1P2.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/NSP1P2-1.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/Richard.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/aaRT.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/aaa-adp.edp
@ -34,17 +33,26 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/BeamEigenValueperio.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/LapEigenValue.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/LapnosymEigenValue.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/Stokes-eigen.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/all.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/eigen/neuman.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/funct.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/include.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/lap_mat.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/lapacienprecon.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/load/load.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/load/load.link
%%PORTDOCS%%%%EXAMPLESDIR%%/load/myfunction.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/essai.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/schwarz-b.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/schwarz-c.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/schwarz.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/parareal.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/testFE.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/testadp.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/teste.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/FE.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/LapDG.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/LaplaceP1.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/LaplaceP1P2h.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/LaplaceP1bis.edp
@ -90,11 +98,12 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-no-overlap.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-overlap.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/tablefunction.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/truncmesh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/xyf
%%PORTDOCS%%%%EXAMPLESDIR%%/wafer-heating-laser-axi.edp
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/bug
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/eigen
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/load
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/mpi
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/tutorial
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%