Update to 1.12.7
Don't use custom install target Add desktop entry Sort plist PR: ports/150711 Approved by: maintainer timeout (two weeks)
This commit is contained in:
parent
7875a9022b
commit
704df912de
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=262290
4 changed files with 91 additions and 95 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= vym
|
||||
PORTVERSION= 1.12.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.12.7
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -17,26 +16,30 @@ COMMENT= VYM (View Your Mind) is a tool to generate and manipulate maps
|
|||
USE_BZIP2= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= qmake_build uic_build moc_build qt3support network xml
|
||||
QMAKE_ARGS= PREFIX=${PREFIX} \
|
||||
DATADIR=${DATADIR:S,/vym,,} \
|
||||
DOCDIR=${DOCSDIR}
|
||||
|
||||
MAKE_JOBS_SAFE= yes
|
||||
STRIP_FILES= bin/vym
|
||||
|
||||
DESKTOP_ENTRIES= "VYM" \
|
||||
"Put the things you have got in your mind into a map" \
|
||||
"${DATADIR}/icons/vym.png" \
|
||||
"vym" \
|
||||
"" \
|
||||
false
|
||||
|
||||
post-patch:
|
||||
.if defined(NOPORTDOCS)
|
||||
${REINPLACE_CMD} -e '/INSTALLS += doc/d' ${WRKSRC}/vym.pro
|
||||
.endif
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
|
||||
-spec ${QMAKESPEC} vym.pro
|
||||
${QMAKEFLAGS} ${QMAKE_ARGS} vym.pro
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
@${MKDIR} ${DATADIR}
|
||||
.for dir in exports flags icons lang macros scripts styles
|
||||
@cd ${WRKSRC} && \
|
||||
${FIND} ${dir} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
|
||||
${FIND} ${dir} -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/demos/* ${EXAMPLESDIR}
|
||||
.endif
|
||||
post-install:
|
||||
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (vym-1.12.2.tar.bz2) = ff2dc8f2dad9bda128753ed94aed302d
|
||||
SHA256 (vym-1.12.2.tar.bz2) = 02585b7e823df3cb42de616456934ae041780f1045efcd04b0bd58177b65e605
|
||||
SIZE (vym-1.12.2.tar.bz2) = 4198516
|
||||
MD5 (vym-1.12.7.tar.bz2) = f0187669c3381499983a1918dc5495df
|
||||
SHA256 (vym-1.12.7.tar.bz2) = ad1c90ca66d407c90407a54fc96d56655856d3d8c3202ec2e4acd08dd982a0ad
|
||||
SIZE (vym-1.12.7.tar.bz2) = 4231782
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- mainwindow.cpp.orig 2008-05-05 15:46:42.000000000 +0200
|
||||
+++ mainwindow.cpp 2008-08-03 20:13:53.000000000 +0200
|
||||
@@ -3715,6 +3715,7 @@
|
||||
searchList << "doc/tex"; // Easy testing working on vym.tex
|
||||
searchList << "/usr/share/doc/vym"; // Debian
|
||||
searchList << "/usr/share/doc/packages";// Knoppix
|
||||
+ searchList << "/usr/local/share/doc/vym";// FreeBSD
|
||||
|
||||
bool found=false;
|
||||
QFile docfile;
|
|
@ -1,45 +1,21 @@
|
|||
bin/vym
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vym.pdf
|
||||
%%DATADIR%%/demos/lifeforms.vym
|
||||
%%DATADIR%%/demos/math.vym
|
||||
%%DATADIR%%/demos/time-management.vym
|
||||
%%DATADIR%%/demos/vym-projectplan.vym
|
||||
%%DATADIR%%/exports/orange-blue.conf
|
||||
%%DATADIR%%/exports/template-orange-blue/META-INF/manifest.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/Pictures/1000000000000040000000400142E835.png
|
||||
%%DATADIR%%/exports/template-orange-blue/Thumbnails/thumbnail.png
|
||||
%%DATADIR%%/exports/template-orange-blue/content-template.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/content.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/meta.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/styles.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/settings.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/page-template.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/mimetype
|
||||
%%DATADIR%%/exports/orange-blue.conf
|
||||
%%DATADIR%%/flags/freemind/attach.png
|
||||
%%DATADIR%%/flags/freemind/back.png
|
||||
%%DATADIR%%/flags/freemind/bell.png
|
||||
%%DATADIR%%/flags/freemind/bookmark.png
|
||||
%%DATADIR%%/flags/freemind/clanbomber.png
|
||||
%%DATADIR%%/flags/freemind/desktopnew.png
|
||||
%%DATADIR%%/flags/freemind/flag.png
|
||||
%%DATADIR%%/flags/freemind/forward.png
|
||||
%%DATADIR%%/flags/freemind/gohome.png
|
||||
%%DATADIR%%/flags/freemind/help.png
|
||||
%%DATADIR%%/flags/freemind/idea.png
|
||||
%%DATADIR%%/flags/freemind/kaddressbook.png
|
||||
%%DATADIR%%/flags/freemind/knotify.png
|
||||
%%DATADIR%%/flags/freemind/korn.png
|
||||
%%DATADIR%%/flags/freemind/mail.png
|
||||
%%DATADIR%%/flags/freemind/licq.png
|
||||
%%DATADIR%%/flags/freemind/password.png
|
||||
%%DATADIR%%/flags/freemind/pencil.png
|
||||
%%DATADIR%%/flags/freemind/penguin.png
|
||||
%%DATADIR%%/flags/freemind/priority-1.png
|
||||
%%DATADIR%%/flags/freemind/priority-2.png
|
||||
%%DATADIR%%/flags/freemind/priority-3.png
|
||||
%%DATADIR%%/flags/freemind/priority-4.png
|
||||
%%DATADIR%%/flags/freemind/priority-5.png
|
||||
%%DATADIR%%/flags/freemind/priority-6.png
|
||||
%%DATADIR%%/flags/freemind/priority-7.png
|
||||
%%DATADIR%%/flags/freemind/stop.png
|
||||
%%DATADIR%%/flags/freemind/warning.png
|
||||
%%DATADIR%%/flags/freemind/wizard.png
|
||||
%%DATADIR%%/flags/freemind/xmag.png
|
||||
%%DATADIR%%/exports/template-orange-blue/page-template.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/section-template.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/settings.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/styles.xml
|
||||
%%DATADIR%%/flags/flag-arrow-2down.png
|
||||
%%DATADIR%%/flags/flag-arrow-2up.png
|
||||
%%DATADIR%%/flags/flag-arrow-down.png
|
||||
|
@ -71,6 +47,36 @@ bin/vym
|
|||
%%DATADIR%%/flags/flag-url.png
|
||||
%%DATADIR%%/flags/flag-vymlink.png
|
||||
%%DATADIR%%/flags/flags.xcf
|
||||
%%DATADIR%%/flags/freemind/attach.png
|
||||
%%DATADIR%%/flags/freemind/back.png
|
||||
%%DATADIR%%/flags/freemind/bell.png
|
||||
%%DATADIR%%/flags/freemind/bookmark.png
|
||||
%%DATADIR%%/flags/freemind/clanbomber.png
|
||||
%%DATADIR%%/flags/freemind/desktopnew.png
|
||||
%%DATADIR%%/flags/freemind/flag.png
|
||||
%%DATADIR%%/flags/freemind/forward.png
|
||||
%%DATADIR%%/flags/freemind/gohome.png
|
||||
%%DATADIR%%/flags/freemind/help.png
|
||||
%%DATADIR%%/flags/freemind/idea.png
|
||||
%%DATADIR%%/flags/freemind/kaddressbook.png
|
||||
%%DATADIR%%/flags/freemind/knotify.png
|
||||
%%DATADIR%%/flags/freemind/korn.png
|
||||
%%DATADIR%%/flags/freemind/licq.png
|
||||
%%DATADIR%%/flags/freemind/mail.png
|
||||
%%DATADIR%%/flags/freemind/password.png
|
||||
%%DATADIR%%/flags/freemind/pencil.png
|
||||
%%DATADIR%%/flags/freemind/penguin.png
|
||||
%%DATADIR%%/flags/freemind/priority-1.png
|
||||
%%DATADIR%%/flags/freemind/priority-2.png
|
||||
%%DATADIR%%/flags/freemind/priority-3.png
|
||||
%%DATADIR%%/flags/freemind/priority-4.png
|
||||
%%DATADIR%%/flags/freemind/priority-5.png
|
||||
%%DATADIR%%/flags/freemind/priority-6.png
|
||||
%%DATADIR%%/flags/freemind/priority-7.png
|
||||
%%DATADIR%%/flags/freemind/stop.png
|
||||
%%DATADIR%%/flags/freemind/warning.png
|
||||
%%DATADIR%%/flags/freemind/wizard.png
|
||||
%%DATADIR%%/flags/freemind/xmag.png
|
||||
%%DATADIR%%/icons/cursor.xcf
|
||||
%%DATADIR%%/icons/cursor16.xcf
|
||||
%%DATADIR%%/icons/cursorcolorpicker.png
|
||||
|
@ -145,20 +151,24 @@ bin/vym
|
|||
%%DATADIR%%/lang/vym_pt_BR.ts
|
||||
%%DATADIR%%/lang/vym_ru.qm
|
||||
%%DATADIR%%/lang/vym_ru.ts
|
||||
%%DATADIR%%/lang/vym_sv.qm
|
||||
%%DATADIR%%/lang/vym_sv.ts
|
||||
%%DATADIR%%/lang/vym_zh_CN.qm
|
||||
%%DATADIR%%/lang/vym_zh_CN.ts
|
||||
%%DATADIR%%/macros/macro-3.vys
|
||||
%%DATADIR%%/lang/vym_zh_TW.qm
|
||||
%%DATADIR%%/lang/vym_zh_TW.ts
|
||||
%%DATADIR%%/macros/macro-1.vys
|
||||
%%DATADIR%%/macros/macro-7.vys
|
||||
%%DATADIR%%/macros/macro-12.vys
|
||||
%%DATADIR%%/macros/macro-9.vys
|
||||
%%DATADIR%%/macros/macro-4.vys
|
||||
%%DATADIR%%/macros/macro-2.vys
|
||||
%%DATADIR%%/macros/macro-6.vys
|
||||
%%DATADIR%%/macros/macro-11.vys
|
||||
%%DATADIR%%/macros/macro-8.vys
|
||||
%%DATADIR%%/macros/macro-5.vys
|
||||
%%DATADIR%%/macros/macro-10.vys
|
||||
%%DATADIR%%/macros/macro-11.vys
|
||||
%%DATADIR%%/macros/macro-12.vys
|
||||
%%DATADIR%%/macros/macro-2.vys
|
||||
%%DATADIR%%/macros/macro-3.vys
|
||||
%%DATADIR%%/macros/macro-4.vys
|
||||
%%DATADIR%%/macros/macro-5.vys
|
||||
%%DATADIR%%/macros/macro-6.vys
|
||||
%%DATADIR%%/macros/macro-7.vys
|
||||
%%DATADIR%%/macros/macro-8.vys
|
||||
%%DATADIR%%/macros/macro-9.vys
|
||||
%%DATADIR%%/scripts/exportvym
|
||||
%%DATADIR%%/scripts/niceXML
|
||||
%%DATADIR%%/scripts/release-mac
|
||||
|
@ -173,25 +183,18 @@ bin/vym
|
|||
%%DATADIR%%/styles/vym2taskjuggler.xsl
|
||||
%%DATADIR%%/styles/vym2txt.xsl
|
||||
%%DATADIR%%/styles/vym2xhtml.xsl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vym_es.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vym_fr.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vym.pdf
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lifeforms.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/math.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/time-management.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vym-projectplan.vym
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Pictures
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/META-INF
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Thumbnails
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue
|
||||
@dirrm %%DATADIR%%/exports
|
||||
@dirrm %%DATADIR%%/styles
|
||||
@dirrm %%DATADIR%%/scripts
|
||||
@dirrm %%DATADIR%%/macros
|
||||
@dirrm %%DATADIR%%/lang
|
||||
@dirrm %%DATADIR%%/icons
|
||||
@dirrm %%DATADIR%%/flags/freemind
|
||||
@dirrm %%DATADIR%%/flags
|
||||
@dirrm %%DATADIR%%/icons
|
||||
@dirrm %%DATADIR%%/lang
|
||||
@dirrm %%DATADIR%%/macros
|
||||
@dirrm %%DATADIR%%/scripts
|
||||
@dirrm %%DATADIR%%/styles
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Thumbnails
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Pictures
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/META-INF
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue
|
||||
@dirrm %%DATADIR%%/exports
|
||||
@dirrm %%DATADIR%%/demos
|
||||
@dirrm %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue