- Bump PORTREVISION
- Change master sites and icon - Support STAGEDIR - Add DOCS Option - Add Desktop entry file - Simplify Makefile - Add patches, fix bad C++ code Approved by: pawel / wg (mentors, implicit)
This commit is contained in:
parent
8238bf7aa3
commit
7073c9751c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337322
5 changed files with 41 additions and 24 deletions
|
@ -3,43 +3,40 @@
|
|||
|
||||
PORTNAME= icbm3d
|
||||
PORTVERSION= 0.4
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/icbm3d/ \
|
||||
ftp://ftp.billsgames.com/unix/x/icbm3d/ \
|
||||
http://www.newbreedsoftware.com/images/prodicons/:icons
|
||||
SF/nemysisfreebsdp/games/${PORTNAME}/:icons
|
||||
DISTFILES= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX} \
|
||||
${PORTNAME}.gif:icons
|
||||
${PORTNAME}.png:icons
|
||||
EXTRACT_ONLY= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= nemysis@FreeBSD.org
|
||||
COMMENT= Inter-Continental Ballistic Missiles, 3D
|
||||
|
||||
WRKSRC= ${WRKDIR}/icbm3d
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USE_XORG= x11
|
||||
MAKEFILE= makefile
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
share/pixmaps/${PORTNAME}.gif
|
||||
share/pixmaps/${PORTNAME}.png
|
||||
|
||||
PORTDOCS= README.txt
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
DESKTOP_ENTRIES="ICBM3D" "" "${PORTNAME}" \
|
||||
"${PORTNAME}" "Game;ArcadeGame;" ""
|
||||
|
||||
do-install:
|
||||
# Executable
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/
|
||||
|
||||
# Pixmaps
|
||||
${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.gif ${PREFIX}/share/pixmaps/
|
||||
|
||||
# Documentation
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
|
||||
.endif
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
SHA256 (icbm3d.0.4.tar.gz) = 9ad41c154ef47695771a26875d5415bcedcb139352b1e2175f386d206b0038fd
|
||||
SIZE (icbm3d.0.4.tar.gz) = 31187
|
||||
SHA256 (icbm3d.gif) = e5d6d45ee11ff669414ac2e22943a0786b62b72035884a06abd5f12dcd0d5f15
|
||||
SIZE (icbm3d.gif) = 1024
|
||||
SHA256 (icbm3d.png) = 993ef04425b4211a699437076386f27368abf5a3d660194c1d800e20fcd1517c
|
||||
SIZE (icbm3d.png) = 877
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
--- makefile.orig 1998-07-31 06:41:20.000000000 +0200
|
||||
+++ makefile 2012-09-02 23:21:36.000000000 +0200
|
||||
--- ./makefile.orig 1998-07-31 06:41:20.000000000 +0200
|
||||
+++ ./makefile 2013-12-24 08:28:45.000000000 +0100
|
||||
@@ -9,14 +9,16 @@
|
||||
|
||||
# Makefile user-definable variables------------------------------------------
|
||||
|
||||
-CC=gcc
|
||||
+CC?=g++
|
||||
+PREFIX?=/usr/local
|
||||
+LOCALBASE?=/usr/local
|
||||
+CC?=${CC}
|
||||
+PREFIX?=${PREFIX}
|
||||
+LOCALBASE?=${PREFIX}
|
||||
MATHLIB=-lm
|
||||
|
||||
INSTALLROOT=$(PREFIX)
|
||||
|
|
10
games/icbm3d/files/patch-randnum.c
Normal file
10
games/icbm3d/files/patch-randnum.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./randnum.c.orig 1998-07-29 23:25:59.000000000 +0200
|
||||
+++ ./randnum.c 2013-12-24 08:33:46.000000000 +0100
|
||||
@@ -11,6 +11,7 @@
|
||||
#include <stdio.h>
|
||||
#include <sys/time.h>
|
||||
#include "randnum.h"
|
||||
+#include <stdlib.h>
|
||||
|
||||
void randinit()
|
||||
{
|
10
games/icbm3d/files/patch-text.c
Normal file
10
games/icbm3d/files/patch-text.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./text.c.orig 1998-07-29 23:25:59.000000000 +0200
|
||||
+++ ./text.c 2013-12-24 08:28:45.000000000 +0100
|
||||
@@ -7,6 +7,7 @@
|
||||
|
||||
#include <X11/Xlib.h>
|
||||
#include "text.h"
|
||||
+#include <string.h>
|
||||
|
||||
int FontHeight(XFontStruct *font_struct)
|
||||
{
|
Loading…
Reference in a new issue