Add new port of glean, a suite of OpenGL conformance tests. Very useful for
those of us who occasionally have to diagnose DRI driver issues.
This commit is contained in:
parent
a289327ceb
commit
70cd7e885b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95705
8 changed files with 153 additions and 0 deletions
|
@ -103,6 +103,7 @@
|
|||
SUBDIR += gkrellkam
|
||||
SUBDIR += gkrellkam2
|
||||
SUBDIR += gle
|
||||
SUBDIR += glean
|
||||
SUBDIR += glide3
|
||||
SUBDIR += gliv
|
||||
SUBDIR += gltk
|
||||
|
|
32
graphics/glean/Makefile
Normal file
32
graphics/glean/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: glean
|
||||
# Date created: 12 Dec 2003
|
||||
# Whom: Eric Anholt <anholt@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= glean
|
||||
PORTVERSION= 1.0.20030925
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= anholt
|
||||
DISTNAME= glean-20030925-snap
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= anholt@FreeBSD.org
|
||||
COMMENT= Suite of OpenGL conformance tests
|
||||
|
||||
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
|
||||
|
||||
WRKSRC= ${WRKDIR}/glean/src
|
||||
USE_BZIP2= yes
|
||||
USE_GL= yes
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV+= GLEAN_ROOT="${WRKDIR}/glean" \
|
||||
CXX="${CXX}"
|
||||
ALL_TARGET= install
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKDIR}/glean/bin/glean ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/glean/distinfo
Normal file
1
graphics/glean/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (glean-20030925-snap.tar.bz2) = 02be32985d02f72de42fbb016040ef2c
|
59
graphics/glean/files/patch-common.mak
Normal file
59
graphics/glean/files/patch-common.mak
Normal file
|
@ -0,0 +1,59 @@
|
|||
--- ../make/common.mak.orig Wed Nov 6 19:13:23 2002
|
||||
+++ ../make/common.mak Thu Sep 25 16:22:58 2003
|
||||
@@ -39,11 +39,11 @@
|
||||
# Locations of common commands:
|
||||
ifeq ($(PLATFORM), Unix)
|
||||
AR:=/usr/bin/ar
|
||||
- CC:=/usr/bin/g++
|
||||
+ CC:=${CXX}
|
||||
INSTALL:=/usr/bin/install -c
|
||||
RANLIB:=/usr/bin/ranlib
|
||||
RM:=/bin/rm
|
||||
- SED:=/bin/sed
|
||||
+ SED:=/usr/bin/sed
|
||||
SHELL:=/bin/sh
|
||||
MKDIR:=/bin/mkdir
|
||||
endif # Unix
|
||||
@@ -72,14 +72,14 @@
|
||||
ifeq ($(PLATFORM), Unix)
|
||||
# Note: Do *not* list standard system #include directories here,
|
||||
# because some compilers complain about them.
|
||||
- XINC:=-I/usr/include/X11
|
||||
- XLIB:=/usr/X11R6/lib
|
||||
- GLINC:=#-I/usr/include
|
||||
- GLLIB:=/usr/lib
|
||||
- GLUTINC:=#-I/usr/include
|
||||
- GLUTLIB:=/usr/lib
|
||||
- TIFFINC:=#-I/usr/include
|
||||
- TIFFLIB:=/usr/lib
|
||||
+ XINC:=-I${X11BASE}/include
|
||||
+ XLIB:=${X11BASE}/lib
|
||||
+ GLINC:=-I${X11BASE}/include
|
||||
+ GLLIB:=${X11BASE}/lib
|
||||
+ GLUTINC:=-I${X11BASE}/include
|
||||
+ GLUTLIB:=${X11BASE}/lib
|
||||
+ TIFFINC:=-I${LOCALBASE}/include
|
||||
+ TIFFLIB:=${LOCALBASE}/lib
|
||||
EXTRALIBS:=
|
||||
endif # Unix
|
||||
ifeq ($(PLATFORM), BeOS)
|
||||
@@ -166,10 +162,7 @@
|
||||
$(TIFFINC)
|
||||
OPT:= # Optimization options
|
||||
ifeq ($(PLATFORM), Unix)
|
||||
-_OPT=\
|
||||
- -march=pentiumpro \
|
||||
- -O -fno-unroll-all-loops \
|
||||
- $(OPT)
|
||||
+_OPT= ${CFLAGS}
|
||||
endif # Unix
|
||||
ifeq ($(PLATFORM), BeOS)
|
||||
_OPT=\
|
||||
@@ -183,7 +176,6 @@
|
||||
WARN:= # warning options
|
||||
ifeq ($(PLATFORM), Unix)
|
||||
_WARN=\
|
||||
- -Wall \
|
||||
-W \
|
||||
$(WARN)
|
||||
endif # Unix
|
10
graphics/glean/files/patch-ttexcombine.cpp
Normal file
10
graphics/glean/files/patch-ttexcombine.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- glean/ttexcombine.cpp.orig Thu Sep 25 16:17:52 2003
|
||||
+++ glean/ttexcombine.cpp Thu Sep 25 16:17:53 2003
|
||||
@@ -75,6 +75,7 @@
|
||||
#include "ttexcombine.h"
|
||||
#include <stdio.h>
|
||||
#include <cmath>
|
||||
+#include <cassert>
|
||||
|
||||
#define CLAMP(VAL, MIN, MAX) \
|
||||
((VAL) < (MIN) ? (MIN) : ((VAL) > (MAX) ? (MAX) : (VAL)))
|
41
graphics/glean/files/patch-ttexenv.cpp
Normal file
41
graphics/glean/files/patch-ttexenv.cpp
Normal file
|
@ -0,0 +1,41 @@
|
|||
Index: glean/ttexenv.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/glean/glean/src/glean/ttexenv.cpp,v
|
||||
retrieving revision 1.7
|
||||
retrieving revision 1.6
|
||||
diff -u -u -r1.7 -r1.6
|
||||
--- glean/ttexenv.cpp 24 Sep 2003 16:28:08 -0000 1.7
|
||||
+++ glean/ttexenv.cpp 31 May 2001 16:05:35 -0000 1.6
|
||||
@@ -614,8 +614,6 @@
|
||||
else
|
||||
numModes = 4;
|
||||
|
||||
- r.pass = true;
|
||||
-
|
||||
for (int fmt = 0; fmt < 6; fmt++) {
|
||||
const GLenum format = FormatEnums[fmt];
|
||||
const char *formatName = FormatNames[fmt];
|
||||
@@ -632,7 +630,7 @@
|
||||
envName, formatName,
|
||||
COLORS, colors, envColor, w)) {
|
||||
r.pass = false;
|
||||
- break;
|
||||
+ return;
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -642,10 +640,14 @@
|
||||
envName, formatName,
|
||||
COLORS, colors, colors[0], w)) {
|
||||
r.pass = false;
|
||||
+ return;
|
||||
}
|
||||
}
|
||||
}
|
||||
}
|
||||
+
|
||||
+ r.pass = true;
|
||||
+
|
||||
} // TexEnvTest::runOne
|
||||
|
||||
|
8
graphics/glean/pkg-descr
Normal file
8
graphics/glean/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
glean is a suite of tools for evaluating the quality of an OpenGL implementation
|
||||
and diagnosing any problems that are discovered. glean also has the ability to
|
||||
compare two OpenGL implementations and highlight the differences between them.
|
||||
|
||||
WWW: http://glean.sourceforge.net/
|
||||
|
||||
- Eric Anholt
|
||||
anholt@FreeBSD.org
|
1
graphics/glean/pkg-plist
Normal file
1
graphics/glean/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/glean
|
Loading…
Reference in a new issue