- Update to 1.2.3

- Assume maintainership

Changes:	https://raw.github.com/polarssl/polarssl/fb1ba781b398d39f4444515381babcc9e5a8dcd2/ChangeLog

Feature safe:	yes
This commit is contained in:
Jase Thew 2012-11-26 19:49:22 +00:00
parent fbdcc0802c
commit 70dc19873f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=307794
5 changed files with 38 additions and 33 deletions

View file

@ -1,18 +1,21 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= polarssl PORTNAME= polarssl
PORTVERSION= 1.1.4 PORTVERSION= 1.2.3
DISTVERSIONSUFFIX= -gpl DISTVERSIONSUFFIX= -gpl
CATEGORIES= security devel CATEGORIES= security devel
MASTER_SITES= http://polarssl.org/code/download/ MASTER_SITES= http://polarssl.org/download/
EXTRACT_SUFX= .tgz EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org MAINTAINER= jase@FreeBSD.org
COMMENT= Open Source embedded SSL/TLS cryptographic library COMMENT= Open Source embedded SSL/TLS cryptographic library
LICENSE= GPLv2 LICENSE= GPLv2
USE_PERL5_BUILD= yes FETCH_ARGS= -pRr
ALL_TARGET= no_test
USE_GMAKE= yes
USE_LDCONFIG= yes USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION} WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@ -33,8 +36,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i} ${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i}
.endfor .endfor
.include <bsd.port.options.mk>
post-install: post-install:
.if !defined(NOPORTDOCS) .if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR} ${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS} .for i in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/

View file

@ -1,2 +1,2 @@
SHA256 (polarssl-1.1.4-gpl.tgz) = 2d29fd04a0d0ba29dae6bd29fb418944c08d3916665dcca74afb297ef37584b6 SHA256 (polarssl-1.2.3-gpl.tgz) = 5cd3bc6aa85e1de809c3b4c76932794c60a8d05faf2cf8f62933ab97ef52e4ae
SIZE (polarssl-1.1.4-gpl.tgz) = 611340 SIZE (polarssl-1.2.3-gpl.tgz) = 978269

View file

@ -1,11 +0,0 @@
--- Makefile.orig 2011-06-21 10:59:00.000000000 +0200
+++ Makefile 2011-08-13 16:25:23.000000000 +0200
@@ -7,7 +7,7 @@
all:
cd library && $(MAKE) all && cd ..
cd programs && $(MAKE) all && cd ..
- cd tests && $(MAKE) all && cd ..
+# cd tests && $(MAKE) all && cd ..
install:
mkdir -p $(DESTDIR)/include/polarssl

View file

@ -1,20 +1,25 @@
--- library/Makefile.orig 2010-03-24 15:57:15.000000000 +0900 --- library/Makefile.orig 2012-11-26 19:20:30.821850410 +0000
+++ library/Makefile 2010-07-15 14:33:59.000000000 +0900 +++ library/Makefile 2012-11-26 19:21:01.534380354 +0000
@@ -11,7 +11,7 @@ @@ -18,9 +18,7 @@
# CFLAGS += -D_BSD_EXTENSION # CFLAGS += -D_BSD_EXTENSION
# To compile as a shared library: # To compile as a shared library:
-# CFLAGS += -fPIC -ifdef SHARED
+CFLAGS += -fPIC CFLAGS += -fPIC
-endif
DLEXT=so
# OSX shared library extension: SONAME=libpolarssl.so.0
@@ -29,7 +29,7 @@
@@ -53,11 +51,7 @@
.SILENT: .SILENT:
-ifndef SHARED
-all: static -all: static
+all: static shared -else
-all: shared
-endif
+all: shared static
static: libpolarssl.a static: libpolarssl.a

View file

@ -20,8 +20,10 @@ bin/polarssl_ssl_test
include/polarssl/aes.h include/polarssl/aes.h
include/polarssl/arc4.h include/polarssl/arc4.h
include/polarssl/asn1.h include/polarssl/asn1.h
include/polarssl/asn1write.h
include/polarssl/base64.h include/polarssl/base64.h
include/polarssl/bignum.h include/polarssl/bignum.h
include/polarssl/blowfish.h
include/polarssl/bn_mul.h include/polarssl/bn_mul.h
include/polarssl/camellia.h include/polarssl/camellia.h
include/polarssl/certs.h include/polarssl/certs.h
@ -35,6 +37,7 @@ include/polarssl/dhm.h
include/polarssl/entropy.h include/polarssl/entropy.h
include/polarssl/entropy_poll.h include/polarssl/entropy_poll.h
include/polarssl/error.h include/polarssl/error.h
include/polarssl/gcm.h
include/polarssl/havege.h include/polarssl/havege.h
include/polarssl/md.h include/polarssl/md.h
include/polarssl/md2.h include/polarssl/md2.h
@ -45,15 +48,18 @@ include/polarssl/net.h
include/polarssl/openssl.h include/polarssl/openssl.h
include/polarssl/padlock.h include/polarssl/padlock.h
include/polarssl/pem.h include/polarssl/pem.h
include/polarssl/pbkdf2.h
include/polarssl/pkcs11.h include/polarssl/pkcs11.h
include/polarssl/rsa.h include/polarssl/rsa.h
include/polarssl/sha1.h include/polarssl/sha1.h
include/polarssl/sha2.h include/polarssl/sha2.h
include/polarssl/sha4.h include/polarssl/sha4.h
include/polarssl/ssl.h include/polarssl/ssl.h
include/polarssl/ssl_cache.h
include/polarssl/timing.h include/polarssl/timing.h
include/polarssl/version.h include/polarssl/version.h
include/polarssl/x509.h include/polarssl/x509.h
include/polarssl/x509write.h
include/polarssl/xtea.h include/polarssl/xtea.h
lib/libpolarssl.a lib/libpolarssl.a
lib/libpolarssl.so lib/libpolarssl.so