archivers/py-borgbackup: Allow build with py-msgpack 1.0.8

- Bump PORTREVISION for package change

Reference:	a507a2cb3b
This commit is contained in:
Po-Chuan Hsieh 2024-03-09 21:57:18 +08:00
parent 2fd2b822fa
commit 70fc1370fd
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
2 changed files with 26 additions and 2 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= borgbackup
DISTVERSION= 1.2.7
PORTREVISION= 0
PORTREVISION= 1
CATEGORIES= archivers python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
# note that borgbackup pins the msgpack version range per patchlevel version!
_BB_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=1.0.2<1.0.7_99:devel/py-msgpack@${PY_FLAVOR}
_BB_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=1.0.2<1.0.8_99:devel/py-msgpack@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=1.7:devel/py-setuptools-scm@${PY_FLAVOR} \
${_BB_DEPENDS}
LIB_DEPENDS= liblz4.so:archivers/liblz4 \

View File

@ -0,0 +1,24 @@
Reference: https://github.com/borgbackup/borg/commit/a507a2cb3b9fed025743e80971ce1615887a47e4
--- setup.py.orig 2023-12-02 13:05:57 UTC
+++ setup.py
@@ -70,7 +70,7 @@ install_requires = [
# Please note:
# using any other msgpack version is not supported by borg development and
# any feedback related to issues caused by this will be ignored.
- 'msgpack >=0.5.6, <=1.0.7, !=1.0.1',
+ 'msgpack >=0.5.6, <=1.0.8, !=1.0.1',
'packaging',
]
--- src/borg/helpers/msgpack.py.orig 2023-12-02 13:05:57 UTC
+++ src/borg/helpers/msgpack.py
@@ -182,7 +182,7 @@ def is_supported_msgpack():
def is_supported_msgpack():
# DO NOT CHANGE OR REMOVE! See also requirements and comments in setup.py.
import msgpack
- return (0, 5, 6) <= msgpack.version <= (1, 0, 7) and \
+ return (0, 5, 6) <= msgpack.version <= (1, 0, 8) and \
msgpack.version not in [(1, 0, 1), ] # < add bad releases here to deny list