- Update to 0.97

PR:		ports/92482
Submitted by:	Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> (maintainer)
This commit is contained in:
Pav Lucistnik 2006-01-29 11:49:22 +00:00
parent df3d5bf6bf
commit 71267055e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154711
4 changed files with 75 additions and 46 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= ceferino
PORTVERSION= 0.96
PORTVERSION= 0.97
CATEGORIES= games
MASTER_SITES= http://www.losersjuegos.com.ar/juegos/ceferino/descargas/
@ -22,7 +22,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CEFEDIRS= ima musicas niveles sonidos
CEFEDIRS= ima music levels sounds
OPTIONS= NLS "Native Language Support" on
@ -37,17 +37,22 @@ PLIST_SUB+= NLS=""
FLAG_NLS= true
.endif
.if ${OSVERSION} < 500000
BROKEN= Does not compile
.endif
post-extract:
@${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(cpp|h)" \
@${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(cc|h)" \
-print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/<SDL/<SDL11/'
@${REINPLACE_CMD} -e 's/-lSDL /`sdl11-config --libs`/g' ${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e 's/LIBS = -lSDL -lSDL_image -lSDL_mixer/LIBS = \
-lSDL-1.1 -lSDL_image -lSDL_mixer -pthread -lintl/g' ${WRKSRC}/src/Makefile
@${REINPLACE_CMD} -e 's/-pthread/-pthread -lintl/g' ${WRKSRC}/src/Makefile
do-install:
@cd ${WRKSRC}/src && \
${INSTALL_PROGRAM} ceferino ceferinoeditor ceferinosetup ${PREFIX}/bin && \
${INSTALL_PROGRAM} ceferino ceferinoeditor ceferinosetup ${PREFIX}/bin
@cd ${WRKSRC}/data && \
${FIND} ${CEFEDIRS} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E ${CEFEDIRS} -type f -iregex ".*\.(png|jpg|xm|map|wav)" -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
.if defined(FLAG_NLS)
@ -61,7 +66,7 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && \
${INSTALL_DATA} AUTHORS ChangeLog README README_ES ${DOCSDIR}
${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (ceferino-0.96.tar.gz) = 7c1b797858e08e97d62b83b5b1e44981
SHA256 (ceferino-0.96.tar.gz) = 68f15eaaff7d183c4d2eaa5b06f8eaa4981db27bff94f674341bc0ac20a218f4
SIZE (ceferino-0.96.tar.gz) = 1671608
MD5 (ceferino-0.97.tar.gz) = 6479cd63c90ddf725ec1ad215a03d4f8
SHA256 (ceferino-0.97.tar.gz) = e10b7ea2d85db03197824ad6b48d2efd50b3c51ca0a0b7ef4c89d70bc5c754bc
SIZE (ceferino-0.97.tar.gz) = 2091309

View file

@ -0,0 +1,26 @@
--- src/nivel.cc Sat Jan 28 19:31:44 2006
+++ src/nivel.cc Sat Jan 28 19:32:49 2006
@@ -166,7 +166,7 @@
char tmp[1024];
#ifdef WIN32
- strcpy(tmp, SRC_DIR "/niveles/base.map");
+ strcpy(tmp, SRC_DIR "/levels/base.map");
#else
strcpy(tmp, getenv("HOME"));
strcat(tmp, "/");
@@ -175,12 +175,12 @@
arch = fopen(tmp, "rb");
if (!arch)
- arch = fopen (DATADIR "/niveles/base.map", "rb");
+ arch = fopen (DATADIR "/levels/base.map", "rb");
if (!arch)
{
printf(_("Can't open the file '%s'"), DATADIR\
- "/niveles/base.map'\n");
+ "/levels/base.map'\n");
exit(-1);
}

View file

@ -1,69 +1,67 @@
bin/ceferino
bin/ceferinosetup
bin/ceferinoeditor
bin/ceferinosetup
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/README
%%DOCSDIR%%/README_ES
%%NLS%%share/locale/ca/LC_MESSAGES/ceferino.mo
%%NLS%%share/locale/es/LC_MESSAGES/ceferino.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ceferino.mo
%%DATADIR%%/ima/barra.png
%%DATADIR%%/ima/cargando.png
%%DATADIR%%/ima/editor.png
%%DATADIR%%/ima/final_1.jpg
%%DATADIR%%/ima/final_2.jpg
%%DATADIR%%/ima/final_3.jpg
%%DATADIR%%/ima/final_4.jpg
%%DATADIR%%/ima/final_5.jpg
%%DATADIR%%/ima/final_6.jpg
%%DATADIR%%/ima/final_7.jpg
%%DATADIR%%/ima/fondo.jpg
%%DATADIR%%/ima/fondos.jpg
%%DATADIR%%/ima/fuente1.png
%%DATADIR%%/ima/fuente2.png
%%DATADIR%%/ima/fuente.png
%%DATADIR%%/ima/gaucho.png
%%DATADIR%%/ima/how_to_play.png
%%DATADIR%%/ima/icono.png
%%DATADIR%%/ima/items.png
%%DATADIR%%/ima/mate.png
%%DATADIR%%/ima/menu.jpg
%%DATADIR%%/ima/menu_oscuro.jpg
%%DATADIR%%/ima/niveles.png
%%DATADIR%%/ima/op_items.png
%%DATADIR%%/ima/pelota_1.png
%%DATADIR%%/ima/pelota_2.png
%%DATADIR%%/ima/pelota_3.png
%%DATADIR%%/ima/pelota_4.png
%%DATADIR%%/ima/tiros.png
%%DATADIR%%/ima/tit_1.png
%%DATADIR%%/ima/tit_2.png
%%DATADIR%%/ima/tit_3.png
%%DATADIR%%/ima/final1.jpg
%%DATADIR%%/ima/final2.jpg
%%DATADIR%%/ima/final3.jpg
%%DATADIR%%/ima/final4.jpg
%%DATADIR%%/ima/final5.jpg
%%DATADIR%%/ima/final6.jpg
%%DATADIR%%/ima/fondo.jpg
%%DATADIR%%/ima/fondos.jpg
%%DATADIR%%/ima/menu.jpg
%%DATADIR%%/ima/pres_casa.jpg
%%DATADIR%%/ima/pres_lee.jpg
%%DATADIR%%/ima/pres_losers.jpg
%%DATADIR%%/ima/pres_rapto.jpg
%%DATADIR%%/ima/pres_sentado.jpg
%%DATADIR%%/ima/pres_vs.jpg
%%DATADIR%%/ima/tiros.png
%%DATADIR%%/ima/tit_1.png
%%DATADIR%%/ima/tit_2.png
%%DATADIR%%/ima/tit_3.png
%%DATADIR%%/ima/how_to_play.png
%%DATADIR%%/sonidos/alarma.wav
%%DATADIR%%/sonidos/explo.wav
%%DATADIR%%/sonidos/gancho.wav
%%DATADIR%%/sonidos/item.wav
%%DATADIR%%/sonidos/mata.wav
%%DATADIR%%/sonidos/pierde.wav
%%DATADIR%%/sonidos/romper.wav
%%DATADIR%%/sonidos/tecla1.wav
%%DATADIR%%/sonidos/tecla2.wav
%%DATADIR%%/sonidos/tic.wav
%%DATADIR%%/sonidos/tiro.wav
%%DATADIR%%/sonidos/toc.wav
%%DATADIR%%/sonidos/boom.wav
%%DATADIR%%/niveles/base.map
%%DATADIR%%/musicas/menu.xm
%%DATADIR%%/ima/fuente_2.png
%%DATADIR%%/music/menu.xm
%%DATADIR%%/levels/base.map
%%DATADIR%%/sounds/alarma.wav
%%DATADIR%%/sounds/boom.wav
%%DATADIR%%/sounds/explo.wav
%%DATADIR%%/sounds/gancho.wav
%%DATADIR%%/sounds/item.wav
%%DATADIR%%/sounds/mata.wav
%%DATADIR%%/sounds/pierde.wav
%%DATADIR%%/sounds/romper.wav
%%DATADIR%%/sounds/tecla1.wav
%%DATADIR%%/sounds/tecla2.wav
%%DATADIR%%/sounds/tic.wav
%%DATADIR%%/sounds/tiro.wav
%%DATADIR%%/sounds/toc.wav
@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/ima
@dirrm %%DATADIR%%/sonidos
@dirrm %%DATADIR%%/niveles
@dirrm %%DATADIR%%/musicas
@dirrm %%DATADIR%%/music
@dirrm %%DATADIR%%/levels
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%