- Update to 1.10.8
- maintain it for a while
This commit is contained in:
parent
ac5c6c5000
commit
7138638c96
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=189736
8 changed files with 7 additions and 97 deletions
|
@ -7,12 +7,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= dictd
|
||||
PORTVERSION= 1.10.4
|
||||
PORTVERSION= 1.10.8
|
||||
CATEGORIES+= net textproc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= dict
|
||||
|
||||
MAINTAINER?= ports@FreeBSD.org
|
||||
MAINTAINER?= clsung@FreeBSD.org
|
||||
COMMENT= Dict protocol (RFC 2229) server
|
||||
|
||||
MAN1= dictzip.1
|
||||
|
@ -20,9 +20,10 @@ MAN8= dictd.8
|
|||
|
||||
USE_RC_SUBR= ${PORTNAME}.sh
|
||||
USE_BISON= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
|
||||
--without-local-zlib
|
||||
--without-local-zlib --mandir="${PREFIX}/man"
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
|
@ -43,7 +44,6 @@ post-patch:
|
|||
post-install:
|
||||
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/${PORTNAME}.conf > ${PREFIX}/etc/${PORTNAME}.conf.sample
|
||||
@[ -f ${PREFIX}/etc/${PORTNAME}.conf ] || ${CP} ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf
|
||||
#@${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (dictd-1.10.4.tar.gz) = 1c0b7583e6fa25fd27fca5fca9ddb91f
|
||||
SHA256 (dictd-1.10.4.tar.gz) = 8ba2be616099724b0f66f58c71b7cec3b3ec5691fd12b338405deace46713a11
|
||||
SIZE (dictd-1.10.4.tar.gz) = 647901
|
||||
MD5 (dictd-1.10.8.tar.gz) = 927405c8fda1b3883d0dfcfe8a141f7f
|
||||
SHA256 (dictd-1.10.8.tar.gz) = fd659e351248bef18ac8b529d29591f7228bed1db96a5b4d36485fc8edc4dc8c
|
||||
SIZE (dictd-1.10.8.tar.gz) = 688539
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
--- index.c.orig Mon Jan 26 02:52:14 2004
|
||||
+++ index.c Mon Jan 26 03:02:18 2004
|
||||
@@ -144,9 +144,12 @@
|
||||
p[i] = &s[2 * i];
|
||||
}
|
||||
/* Sort those strings in the locale */
|
||||
+#include <osreldate.h>
|
||||
+#if __FreeBSD_version > 499999
|
||||
if (utf8_mode)
|
||||
qsort(p, UCHAR_MAX + 1, sizeof(p[0]), dict_table_init_compare_utf8);
|
||||
else
|
||||
+#endif
|
||||
qsort(p, UCHAR_MAX + 1, sizeof(p[0]), dict_table_init_compare_strcoll);
|
||||
|
||||
/* Extract our unordered arrays */
|
||||
@@ -1245,6 +1248,9 @@
|
||||
*/
|
||||
static int stranagram_utf8 (char *str)
|
||||
{
|
||||
+#if __FreeBSD_version < 500000
|
||||
+ abort();
|
||||
+#else
|
||||
size_t len;
|
||||
char *p;
|
||||
|
||||
@@ -1267,6 +1273,7 @@
|
||||
|
||||
stranagram_8bit (str, -1);
|
||||
return 1;
|
||||
+#endif
|
||||
}
|
||||
#endif
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- decl.h.orig Sat Jan 11 18:39:08 2003
|
||||
+++ decl.h Sat Jan 11 18:38:58 2003
|
||||
@@ -28,7 +28,7 @@
|
||||
declarations for standard library calls. We provide them here for
|
||||
situations that we know about. */
|
||||
|
||||
-#if defined(__sparc__) && !defined(__linux__)
|
||||
+#if defined(__sparc__) && !(defined(__linux__) || defined(__FreeBSD__))
|
||||
/* Both SunOS and Solaris */
|
||||
extern int getrusage( int who, struct rusage * );
|
||||
extern void bcopy( const void *, void *, int );
|
|
@ -1,13 +0,0 @@
|
|||
--- libmaa/configure.orig Mon Mar 10 01:22:39 2003
|
||||
+++ libmaa/configure Thu Oct 9 22:16:29 2003
|
||||
@@ -1859,10 +1859,7 @@
|
||||
# Check whether --with-cflags or --without-cflags was given.
|
||||
if test "${with_cflags+set}" = set; then
|
||||
withval="$with_cflags"
|
||||
-
|
||||
-if test "x${withval}" = xyes; then
|
||||
CFLAGS="$withval"
|
||||
-fi
|
||||
|
||||
fi;
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- libmaa/getopt.c.orig Sat Jan 11 18:40:00 2003
|
||||
+++ libmaa/getopt.c Sat Jan 11 18:40:12 2003
|
||||
@@ -44,7 +44,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc__) && !defined(__FreeBSD__)
|
||||
extern int fprintf( FILE *, const char *, ... );
|
||||
extern int strncmp( const char *, const char *, int n );
|
||||
#endif
|
|
@ -1,11 +0,0 @@
|
|||
--- libmaa/memtest.c.orig Sat Jan 11 18:40:21 2003
|
||||
+++ libmaa/memtest.c Sat Jan 11 18:40:45 2003
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc__) && !defined(__FreeBSD__)
|
||||
extern int printf( const char *, ... );
|
||||
#endif
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- libmaa/strtol.c.orig Sat Jan 11 18:40:34 2003
|
||||
+++ libmaa/strtol.c Thu Aug 24 21:59:08 1995
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc__) && !defined(__FreeBSD__)
|
||||
extern int errno;
|
||||
extern int toupper(int);
|
||||
#endif
|
Loading…
Reference in a new issue