As announced on May 6, remove the broken devel/silc-toolkit port.
This commit is contained in:
parent
c160ab03b1
commit
718d29dc1e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86548
8 changed files with 0 additions and 395 deletions
|
@ -946,7 +946,6 @@
|
|||
SUBDIR += showgrammar
|
||||
SUBDIR += shtool
|
||||
SUBDIR += sigslot
|
||||
SUBDIR += silc-toolkit
|
||||
SUBDIR += simgear
|
||||
SUBDIR += simulavr
|
||||
SUBDIR += sip
|
||||
|
|
|
@ -1,80 +0,0 @@
|
|||
# New ports collection makefile for: silc toolkit
|
||||
# Date created: Thu Nov 8 01:50:05 BRST 2001
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= silc
|
||||
PORTVERSION= 0.9.3
|
||||
CATEGORIES= devel ipv6 net security
|
||||
MASTER_SITES= http://www.silcnet.org/download/toolkit/sources/ \
|
||||
ftp://ftp.silcnet.org/silc/toolkit/sources/ \
|
||||
http://public.www.planetmirror.com/pub/silcnet/toolkit/sources/ \
|
||||
ftp://ftp.au.silcnet.org/pub/silcnet/toolkit/sources/ \
|
||||
http://www.mirrors.wiretapped.net/security/network-security/silc/toolkit/sources/ \
|
||||
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/silc/toolkit/sources/
|
||||
PKGNAMESUFFIX= -toolkit
|
||||
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= Secure Internet Live Conferencing (SILC) development toolkit
|
||||
|
||||
BROKEN= "Does not link"
|
||||
|
||||
RUN_DEPENDS= silc:${PORTSDIR}/net/silc-client
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_PERL5= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= glib12
|
||||
CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME} \
|
||||
--with-docdir=${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX} \
|
||||
--with-etcdir=${PREFIX}/etc/${PORTNAME} \
|
||||
--with-helpdir=${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}/help \
|
||||
--with-logsdir=${PORTNAME}/logs \
|
||||
--with-simdir=libexec/${PORTNAME}/modules \
|
||||
--includedir=${PREFIX}/include/${PORTNAME}
|
||||
PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
|
||||
|
||||
INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
|
||||
|
||||
.ifndef(WITH_PTHREADS)
|
||||
CONFIGURE_ARGS+= --disable-threads
|
||||
.else
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.ifndef(WITHOUT_OPTIMIZED_ASM)
|
||||
@${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
|
||||
.endif
|
||||
.ifndef(WITH_PTHREADS)
|
||||
@${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.ifdef(NOPORTDOCS)
|
||||
@${PERL} -pi -ne 's|doc includes|includes|;s| doc-install| |; \
|
||||
s|^.*-mkdir -p \$$\(docdir\).*$$||' ${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
@${PERL} -pi -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
pre-install:
|
||||
@${RM} -Rf ${WRKSRC}/doc/examples/CVS
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} != "i386"
|
||||
WITHOUT_OPTIMIZED_ASM= yes
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 400014
|
||||
CONFIGURE_ARGS+= --enable-ipv6
|
||||
.endif
|
||||
|
||||
.ifdef(WITHOUT_OPTIMIZED_ASM)
|
||||
CONFIGURE_ARGS+= --disable-asm
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (silc-toolkit-0.9.3.tar.bz2) = f4e63a9c6455e91323482a3b840a8361
|
|
@ -1,46 +0,0 @@
|
|||
--- Makefile.in.orig Wed Jul 17 19:19:16 2002
|
||||
+++ Makefile.in Wed Jul 17 19:21:10 2002
|
||||
@@ -151,7 +151,7 @@
|
||||
|
||||
AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
|
||||
|
||||
-COMMONDIRS = lib irssi silc silcd doc includes
|
||||
+COMMONDIRS = lib irssi doc includes
|
||||
|
||||
# Sub directories defined by "distributions" file, and can be overridden
|
||||
# with ./configure, which substitutes these variables.
|
||||
@@ -530,11 +530,8 @@
|
||||
-rm -rf $(distdir)
|
||||
|
||||
install-dirs:
|
||||
- -mkdir -p $(etcdir)
|
||||
- -mkdir -p $(modulesdir)
|
||||
-mkdir -p $(helpdir)
|
||||
-mkdir -p $(docdir)
|
||||
- -mkdir -p $(logsdir)
|
||||
|
||||
generate-server-key:
|
||||
-@if test '!' -f $(etcdir)/silcd.pub ; then \
|
||||
@@ -547,7 +544,8 @@
|
||||
doc-install:
|
||||
$(INSTALL_DATA) $(srcdir)/doc/CodingStyle $(docdir)/
|
||||
$(INSTALL_DATA) $(srcdir)/doc/FAQ $(docdir)/
|
||||
- $(INSTALL_DATA) $(srcdir)/doc/example_* $(docdir)/
|
||||
+ $(INSTALL_DATA) $(srcdir)/doc/examples/* $(docdir)/
|
||||
+ $(INSTALL_DATA) $(srcdir)/doc/example*.conf $(docdir)/
|
||||
$(INSTALL_DATA) $(srcdir)/doc/*.txt $(docdir)/
|
||||
$(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/
|
||||
$(INSTALL_DATA) $(srcdir)/CHANGES $(docdir)/
|
||||
@@ -580,9 +578,9 @@
|
||||
$(etcdir)/silc.conf; \
|
||||
fi
|
||||
|
||||
-@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs sim-install doc-install etc-install
|
||||
-@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_TRUE@install-data-hook: install-dirs generate-server-key sim-install doc-install toolkit-install examples-install etc-install
|
||||
-@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_FALSE@install-data-hook: install-dirs generate-server-key sim-install doc-install examples-install etc-install
|
||||
+@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs doc-install
|
||||
+@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_TRUE@install-data-hook: install-dirs doc-install
|
||||
+@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_FALSE@install-data-hook: install-dirs doc-install
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
|
@ -1,20 +0,0 @@
|
|||
--- configure.orig Wed Jul 17 19:21:52 2002
|
||||
+++ configure Wed Jul 17 19:23:28 2002
|
||||
@@ -2623,7 +2623,7 @@
|
||||
# Distribution definition. ./prepare will automatically add here a correct
|
||||
# value. Do not edit!
|
||||
silc_dist=silc-toolkit
|
||||
-SILC_DIST_SUBDIRS="lib irssi silc silcd doc includes win32"
|
||||
+SILC_DIST_SUBDIRS="lib irssi doc includes"
|
||||
cat >>confdefs.h <<\EOF
|
||||
#define SILC_DIST_TOOLKIT 1
|
||||
EOF
|
||||
@@ -11313,7 +11313,7 @@
|
||||
fi
|
||||
;;
|
||||
*-freebsd2.2*)
|
||||
- CFLAGS="$CFLAGS -D_THREAD_SAFE"
|
||||
+ CFLAGS="$CFLAGS"
|
||||
;;
|
||||
*-sysv5uw7*) # UnixWare 7
|
||||
if test "$GCC" != "yes"; then
|
|
@ -1,11 +0,0 @@
|
|||
--- irssi/Makefile.in.orig Wed Jul 17 19:24:11 2002
|
||||
+++ irssi/Makefile.in Wed Jul 17 19:24:37 2002
|
||||
@@ -543,7 +543,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-confDATA install-themeDATA
|
||||
+install-data-am: install-themeDATA
|
||||
|
||||
install-exec-am:
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
[ from developer's site FAQ ]
|
||||
|
||||
This is a SILC development toolkit
|
||||
|
||||
Q: What is SILC?
|
||||
|
||||
A: SILC (Secure Internet Live Conferencing) is a protocol which
|
||||
provides secure conferencing services in the Internet over insecure
|
||||
channel. SILC is IRC like although internally they are very different.
|
||||
Biggest similarity between SILC and IRC is that they both provide
|
||||
conferencing services and that SILC has almost same commands as
|
||||
IRC. Other than that they are nothing alike.
|
||||
|
||||
Biggest differences are that SILC is secure what IRC is not in any
|
||||
way. The network model is also entirely different compared to IRC.
|
||||
|
||||
WWW: http://www.silcnet.org/
|
|
@ -1,219 +0,0 @@
|
|||
bin/silc
|
||||
include/silc/aes.h
|
||||
include/silc/blowfish.h
|
||||
include/silc/cast.h
|
||||
include/silc/ciphers.h
|
||||
include/silc/ciphers_def.h
|
||||
include/silc/client.h
|
||||
include/silc/command.h
|
||||
include/silc/command_reply.h
|
||||
include/silc/getopt.h
|
||||
include/silc/idlist.h
|
||||
include/silc/mars.h
|
||||
include/silc/md5.h
|
||||
include/silc/mp_gmp.h
|
||||
include/silc/mp_mpi.h
|
||||
include/silc/mpi-config.h
|
||||
include/silc/mpi.h
|
||||
include/silc/mplogic.h
|
||||
include/silc/mpprime.h
|
||||
include/silc/none.h
|
||||
include/silc/pkcs1.h
|
||||
include/silc/protocol.h
|
||||
include/silc/rc5.h
|
||||
include/silc/rc6.h
|
||||
include/silc/regex.h
|
||||
include/silc/rsa.h
|
||||
include/silc/sha1.h
|
||||
include/silc/silcargument.h
|
||||
include/silc/silcauth.h
|
||||
include/silc/silcbeos.h
|
||||
include/silc/silcbuffer.h
|
||||
include/silc/silcbuffmt.h
|
||||
include/silc/silcchannel.h
|
||||
include/silc/silccipher.h
|
||||
include/silc/silcclient.h
|
||||
include/silc/silccommand.h
|
||||
include/silc/silcconfig.h
|
||||
include/silc/silcdefs.h
|
||||
include/silc/silcdh.h
|
||||
include/silc/silcdlist.h
|
||||
include/silc/silcepoc.h
|
||||
include/silc/silcfileutil.h
|
||||
include/silc/silchash.h
|
||||
include/silc/silchashtable.h
|
||||
include/silc/silchmac.h
|
||||
include/silc/silcid.h
|
||||
include/silc/silcidcache.h
|
||||
include/silc/silcincludes.h
|
||||
include/silc/silclist.h
|
||||
include/silc/silclog.h
|
||||
include/silc/silcmath.h
|
||||
include/silc/silcmemory.h
|
||||
include/silc/silcmode.h
|
||||
include/silc/silcmp.h
|
||||
include/silc/silcmutex.h
|
||||
include/silc/silcnet.h
|
||||
include/silc/silcnotify.h
|
||||
include/silc/silcos2.h
|
||||
include/silc/silcpacket.h
|
||||
include/silc/silcpkcs.h
|
||||
include/silc/silcprivate.h
|
||||
include/silc/silcprotocol.h
|
||||
include/silc/silcrng.h
|
||||
include/silc/silcschedule.h
|
||||
include/silc/silcsftp.h
|
||||
include/silc/silcsftp_fs.h
|
||||
include/silc/silcsim.h
|
||||
include/silc/silcsimutil.h
|
||||
include/silc/silcske.h
|
||||
include/silc/silcske_groups.h
|
||||
include/silc/silcske_payload.h
|
||||
include/silc/silcske_status.h
|
||||
include/silc/silcsockconn.h
|
||||
include/silc/silcstatus.h
|
||||
include/silc/silcstrutil.h
|
||||
include/silc/silcthread.h
|
||||
include/silc/silctypes.h
|
||||
include/silc/silcutil.h
|
||||
include/silc/silcversion.h
|
||||
include/silc/silcwin32.h
|
||||
include/silc/stacktrace.h
|
||||
include/silc/twofish.h
|
||||
include/silc/version_internal.h
|
||||
lib/libsilc.a
|
||||
lib/libsilcclient.a
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/CHANGES
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/COPYING
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/CREDITS
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/CodingStyle
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/FAQ
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/INSTALL
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/README
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/README.CVS
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/README.MACOSX
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/README.WIN32
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/TODO
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell1_backup.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell1_router.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell1_server1.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell1_server2.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell2_router.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell2_server1.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell2_server2.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell3_router.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell3_server1.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell3_server2.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/cell_router.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-presence-attrs-00.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-commands-03.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-flags-payloads-00.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-ke-auth-05.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-pp-05.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/draft-riikonen-silc-spec-05.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/example_silcd.conf
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/formats.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/manual.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/signals.txt
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/silcd.prv
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/silcd.pub
|
||||
%%PORTDOCS%%share/doc/silc-toolkit/startup-HOWTO.html
|
||||
share/silc-toolkit/help/action
|
||||
share/silc-toolkit/help/admin
|
||||
share/silc-toolkit/help/alias
|
||||
share/silc-toolkit/help/away
|
||||
share/silc-toolkit/help/ban
|
||||
share/silc-toolkit/help/beep
|
||||
share/silc-toolkit/help/bind
|
||||
share/silc-toolkit/help/cat
|
||||
share/silc-toolkit/help/cd
|
||||
share/silc-toolkit/help/channel
|
||||
share/silc-toolkit/help/clear
|
||||
share/silc-toolkit/help/close
|
||||
share/silc-toolkit/help/cmode
|
||||
share/silc-toolkit/help/connect
|
||||
share/silc-toolkit/help/cumode
|
||||
share/silc-toolkit/help/cycle
|
||||
share/silc-toolkit/help/date
|
||||
share/silc-toolkit/help/dehilight
|
||||
share/silc-toolkit/help/detach
|
||||
share/silc-toolkit/help/disconnect
|
||||
share/silc-toolkit/help/echo
|
||||
share/silc-toolkit/help/eval
|
||||
share/silc-toolkit/help/exec
|
||||
share/silc-toolkit/help/file
|
||||
share/silc-toolkit/help/format
|
||||
share/silc-toolkit/help/getkey
|
||||
share/silc-toolkit/help/help
|
||||
share/silc-toolkit/help/hilight
|
||||
share/silc-toolkit/help/ignore
|
||||
share/silc-toolkit/help/info
|
||||
share/silc-toolkit/help/invite
|
||||
share/silc-toolkit/help/invitelist
|
||||
share/silc-toolkit/help/join
|
||||
share/silc-toolkit/help/key
|
||||
share/silc-toolkit/help/kick
|
||||
share/silc-toolkit/help/kickban
|
||||
share/silc-toolkit/help/kill
|
||||
share/silc-toolkit/help/knockout
|
||||
share/silc-toolkit/help/lastlog
|
||||
share/silc-toolkit/help/layout
|
||||
share/silc-toolkit/help/levels
|
||||
share/silc-toolkit/help/list
|
||||
share/silc-toolkit/help/load
|
||||
share/silc-toolkit/help/log
|
||||
share/silc-toolkit/help/me
|
||||
share/silc-toolkit/help/motd
|
||||
share/silc-toolkit/help/msg
|
||||
share/silc-toolkit/help/names
|
||||
share/silc-toolkit/help/nick
|
||||
share/silc-toolkit/help/note
|
||||
share/silc-toolkit/help/notice
|
||||
share/silc-toolkit/help/oper
|
||||
share/silc-toolkit/help/part
|
||||
share/silc-toolkit/help/perlflush
|
||||
share/silc-toolkit/help/ping
|
||||
share/silc-toolkit/help/query
|
||||
share/silc-toolkit/help/quit
|
||||
share/silc-toolkit/help/reconnect
|
||||
share/silc-toolkit/help/reload
|
||||
share/silc-toolkit/help/rmreconns
|
||||
share/silc-toolkit/help/rmrejoins
|
||||
share/silc-toolkit/help/save
|
||||
share/silc-toolkit/help/sconnect
|
||||
share/silc-toolkit/help/script
|
||||
share/silc-toolkit/help/scrollback
|
||||
share/silc-toolkit/help/server
|
||||
share/silc-toolkit/help/set
|
||||
share/silc-toolkit/help/shutdown
|
||||
share/silc-toolkit/help/silcoper
|
||||
share/silc-toolkit/help/statusbar
|
||||
share/silc-toolkit/help/toggle
|
||||
share/silc-toolkit/help/topic
|
||||
share/silc-toolkit/help/umode
|
||||
share/silc-toolkit/help/unalias
|
||||
share/silc-toolkit/help/unignore
|
||||
share/silc-toolkit/help/unload
|
||||
share/silc-toolkit/help/unquery
|
||||
share/silc-toolkit/help/upgrade
|
||||
share/silc-toolkit/help/users
|
||||
share/silc-toolkit/help/version
|
||||
share/silc-toolkit/help/watch
|
||||
share/silc-toolkit/help/whois
|
||||
share/silc-toolkit/help/whowas
|
||||
share/silc-toolkit/help/window
|
||||
share/silc/scripts/autoop.pl
|
||||
share/silc/scripts/beep.pl
|
||||
share/silc/scripts/clones.pl
|
||||
share/silc/scripts/dns.pl
|
||||
share/silc/scripts/hello.pl
|
||||
share/silc/scripts/mail-maildir.pl
|
||||
share/silc/scripts/mail.pl
|
||||
share/silc/themes/default.theme
|
||||
@dirrm share/silc/themes
|
||||
@dirrm share/silc/scripts
|
||||
@dirrm share/silc-toolkit/help
|
||||
@dirrm share/silc-toolkit
|
||||
@dirrm share/silc
|
||||
%%PORTDOCS%%@dirrm share/doc/silc-toolkit
|
||||
@dirrm include/silc
|
Loading…
Reference in a new issue