graphics/py-willow: Update to 1.6.2

- Update WWW
- Convert to USE_PYTHON=pep517
- Add HEIF option

Changes:	https://github.com/wagtail/Willow/releases
This commit is contained in:
Po-Chuan Hsieh 2023-10-01 07:30:02 +08:00
parent b088c22676
commit 719ca800aa
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
4 changed files with 23 additions and 19 deletions

View file

@ -1,32 +1,36 @@
PORTNAME= willow
PORTVERSION= 1.5
PORTVERSION= 1.6.2
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Willow-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Wrapper that combines multiple Python image libraries into one API
WWW= https://github.com/wagtail/Willow
WWW= https://willow.readthedocs.io/en/latest/ \
https://github.com/wagtail/Willow
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.2<4:devel/py-flit-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>=0.7<1.0:devel/py-defusedxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}filetype>=1.0.7:devel/py-filetype@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
OPTIONS_DEFINE= HEIF
OPTIONS_MULTI= BACKEND
OPTIONS_MULTI_BACKEND= PILLOW WAND OPENCV
OPTIONS_DEFAULT=PILLOW
OPTIONS_DEFAULT=HEIF PILLOW
HEIF_DESC= HEIF support
OPENCV_DESC= Use OpenCV as backend
PILLOW_DESC= Use Pillow as backend
WAND_DESC= Use Wand as backend
HEIF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow-heif>=0.10.0<1.0.0:graphics/py-pillow-heif@${PY_FLAVOR}
OPENCV_RUN_DEPENDS= opencv>=0:graphics/opencv
PILLOW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
WAND_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wand>=0:graphics/py-wand@${PY_FLAVOR}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1684104498
SHA256 (Willow-1.5.tar.gz) = 3fe42cda9872d8e4f64df301e58a1d8be5b9e66944eb83aadcc50128d3ae658a
SIZE (Willow-1.5.tar.gz) = 119748
TIMESTAMP = 1696048440
SHA256 (willow-1.6.2.tar.gz) = e2d0450fd78ab19052d0478b888ef163e3264e8dcd1af002dd691458db98056f
SIZE (willow-1.6.2.tar.gz) = 112181

View file

@ -0,0 +1,11 @@
--- pyproject.toml.orig 2023-09-06 10:32:49 UTC
+++ pyproject.toml
@@ -25,7 +25,7 @@ classifiers = [
dynamic = ["version"] # will read __version__ from willow/__init__.py
requires-python = ">=3.8"
dependencies = [
- "filetype>=1.0.10,!=1.1.0",
+ "filetype>=1.0.7,!=1.1.0",
"defusedxml>=0.7,<1.0",
]

View file

@ -1,11 +0,0 @@
--- setup.py.orig 2023-03-29 19:16:29 UTC
+++ setup.py
@@ -46,7 +46,7 @@ setup(
],
python_requires='>=3.7',
install_requires=[
- "filetype>=1.0.10,!=1.1.0",
+ "filetype>=1.0.7,!=1.1.0",
"defusedxml>=0.7,<1.0",
],
extras_require={"testing": [