removal of games/tetris

This commit is contained in:
Edwin Groothuis 2003-04-02 13:05:07 +00:00
parent 9651572ef5
commit 71a3a16372
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77990
7 changed files with 0 additions and 86 deletions

View file

@ -1,28 +0,0 @@
# Ports collection makefile for: hspell
# Date created: 01 Apr 2003
# Whom: Yonatan <Yonatan@xpert.com>
#
# $FreeBSD$
#
PORTNAME= tetris
PORTVERSION= 1
CATEGORIES= games
MASTER_SITES= http://www.mavetju.org/download/adopted/
DISTNAME= ${PORTNAME}-01042003
MAINTAINER= yonatan@xpert.com
COMMENT= Text-based tetris game
NO_WRKSUBDIR= yes
USE_REINPLACE= yes
MAN6= tetris.6
post-patch:
${REINPLACE_CMD} -E "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/pathnames.h
post-install:
${INSTALL_MAN} ${WRKSRC}/tetris.6 ${PREFIX}/man/man6/tetris.6
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (tetris-01042003.tar.gz) = 48447120fc2b371b91184fe1cc61dd47

View file

@ -1,12 +0,0 @@
#!/bin/sh
touch test || exit 1 # i need write perms
rm test || exit 1 # if this fails - you'r in limbo
export CVSROOT=:pserver:anoncvs@anoncvs1.usa.openbsd.org:/cvs
echo enter "anoncvs"
cvs login || exit 1 # please login again
cvs get src/games/tetris || exit 1 # it's important this succeeds
cvs logout # don't care if this fails
rm -rf ./src/games/tetris/CVS/ || exit 1
rm -rf ./src/games/tetris/Makefile || exit 1
tar -czpf tetris-`date "+%d%m%Y"`.tar.gz -C ./src/games/tetris/ . || exit 1
rm -rf ./src

View file

@ -1,29 +0,0 @@
--- Makefile.orig Tue Apr 1 23:23:08 2003
+++ Makefile Tue Apr 1 23:23:43 2003
@@ -0,0 +1,26 @@
+# Makefile for Tetris
+# $FreeBSD$
+
+TMPLDFLAGS+= -lcurses -ltermcap
+SRCS= screen.c shapes.c input.c tetris.c scores.c
+
+PREFIX?=/usr/local
+MKDIR?=mkdir -p
+
+all:
+. for files in ${SRCS}
+ ${CC} ${CFLAGS} ${LDFLAGS} -c ${files}
+. endfor
+ ${CC} ${CFLAGS} ${LDFLAGS} ${TMPLDFLAGS} -o tetris input.o scores.o \
+ screen.o shapes.o tetris.o
+
+install:
+ ${INSTALL} -g games -m 2555 tetris ${PREFIX}/bin
+. if !exists(${PREFIX}/var/games/tetris.scores)
+ ${MKDIR} ${PREFIX}/var/games
+ ${INSTALL} -g games -m 664 /dev/null \
+ ${PREFIX}/var/games/tetris.scores
+.endif
+
+clean:
+ rm -f *.o *.core

View file

@ -1,8 +0,0 @@
--- pathnames.h.orig Tue Apr 1 23:06:45 2003
+++ pathnames.h Tue Apr 1 23:07:14 2003
@@ -39,4 +39,4 @@
* @(#)pathnames.h 8.1 (Berkeley) 5/31/93
*/
-#define _PATH_SCOREFILE "/var/games/tetris.scores"
+#define _PATH_SCOREFILE "%%PREFIX%%/var/games/tetris.scores"

View file

@ -1,6 +0,0 @@
The tetris command runs a display-based game. The object is to fit
shapes together to form complete rows, which then vanish. When the
shapes fill up to the top, the game ends. You can optionally select a
level of play or custom-select control keys.
This port is made of OpenBSD's tetris games. It got there from NetBSD...

View file

@ -1,2 +0,0 @@
@comment $FreeBSD$
bin/tetris