irc/hexchat: update to 2.16.0
This commit is contained in:
parent
ad5a911fe8
commit
71c19b1917
7 changed files with 64 additions and 65 deletions
|
@ -1,8 +1,7 @@
|
|||
# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
|
||||
|
||||
PORTNAME= hexchat
|
||||
PORTVERSION= 2.14.3
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.16.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= irc gnome
|
||||
|
||||
|
@ -12,7 +11,8 @@ COMMENT= IRC chat program with GTK and Text Frontend
|
|||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
|
||||
${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR}
|
||||
LIB_DEPENDS= libproxy.so:net/libproxy \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libdbus-1.so:devel/dbus \
|
||||
|
@ -26,7 +26,7 @@ USE_GNOME= cairo gtk20 intltool libxml2
|
|||
USE_XORG= x11
|
||||
USE_GITHUB= yes
|
||||
|
||||
MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true -Dwith-python=python-${PYTHON_VER}
|
||||
MESON_ARGS= -Dtls=enabled -Dgtk-frontend=true -Dwith-python=python-${PYTHON_VER}
|
||||
INSTALLS_ICONS= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
|
@ -36,8 +36,8 @@ SUB_FILES= pkg-message
|
|||
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NOTIFY \
|
||||
PERL TEXTFE SYSINFO
|
||||
OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA PERL TEXTFE \
|
||||
SYSINFO
|
||||
|
||||
OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL
|
||||
|
||||
|
@ -53,9 +53,11 @@ CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root
|
|||
CA_BUNDLE_VARS= CA_BUNDLE="${LOCALBASE}/share/certs/ca-root-nss.crt"
|
||||
CA_BUNDLE_VARS_OFF= CA_BUNDLE=NULL
|
||||
CANBERRA_LIB_DEPENDS= libcanberra.so:audio/libcanberra
|
||||
CANBERRA_MESON_TRUE= with-libcanberra
|
||||
CANBERRA_MESON_ON= -Dlibcanberra=enabled
|
||||
CANBERRA_MESON_OFF= -Dlibcanberra=disabled
|
||||
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
|
||||
DBUS_MESON_TRUE= with-dbus
|
||||
DBUS_MESON_ON= -Ddbus=enabled
|
||||
DBUS_MESON_OFF= -Ddbus=disabled
|
||||
FISHLIM_MESON_TRUE= with-fishlim
|
||||
LUA_MESON_ON= -Dwith-lua=lua-${LUA_VER}
|
||||
LUA_MESON_OFF= -Dwith-lua=false
|
||||
|
@ -65,16 +67,16 @@ NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
|
|||
NOTIFY_MESON_TRUE= with-libnotify
|
||||
PERL_MESON_TRUE= with-perl
|
||||
PERL_USES= perl5
|
||||
TEXTFE_MESON_TRUE= with-text
|
||||
TEXTFE_MESON_TRUE= text-frontend
|
||||
SYSINFO_MESON_TRUE= with-sysinfo
|
||||
|
||||
BINARY_ALIAS= python3=${PYTHON_CMD}
|
||||
|
||||
SHEBANG_FILES= meson_post_install.py \
|
||||
plugins/perl/generate_header.py \
|
||||
src/common/make-te.py
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
|
||||
${WRKSRC}/src/common/server.c
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
|
||||
-e 's|%%PERL_VER%%|${PERL_VER}|g' \
|
||||
${WRKSRC}/plugins/perl/meson.build
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1577021248
|
||||
SHA256 (hexchat-hexchat-v2.14.3_GH0.tar.gz) = 3e32b120a0fde6a3949cc9d2b87b00534e11c150b3249830736e7f86b050343a
|
||||
SIZE (hexchat-hexchat-v2.14.3_GH0.tar.gz) = 2759502
|
||||
TIMESTAMP = 1633136688
|
||||
SHA256 (hexchat-hexchat-v2.16.0_GH0.tar.gz) = 5c7f35317bb3bc437fc5fb57392ddc13ba11c173718cdfe4de89d69c30a40b06
|
||||
SIZE (hexchat-hexchat-v2.16.0_GH0.tar.gz) = 2769078
|
||||
|
|
|
@ -1,20 +1,24 @@
|
|||
--- meson.build.orig 2019-12-21 06:38:06 UTC
|
||||
+++ meson.build
|
||||
@@ -16,11 +16,21 @@ cc = meson.get_compiler('c')
|
||||
--- meson.build.orig 2021-10-01 21:52:09.000000000 +0200
|
||||
+++ meson.build 2021-10-07 10:35:49.739120000 +0200
|
||||
@@ -15,7 +15,7 @@
|
||||
|
||||
libgio_dep = dependency('gio-2.0', version: '>= 2.34.0')
|
||||
libgmodule_dep = dependency('gmodule-2.0')
|
||||
global_deps = []
|
||||
-
|
||||
+libssl_dep_found = false
|
||||
if cc.get_id() == 'msvc'
|
||||
libssl_dep = cc.find_library('libeay32')
|
||||
libcanberra_dep = dependency('libcanberra', version: '>= 0.22',
|
||||
required: get_option('libcanberra'))
|
||||
dbus_glib_dep = dependency('dbus-glib-1', required: get_option('dbus'))
|
||||
@@ -25,7 +25,16 @@
|
||||
libssl_dep = cc.find_library('libssl')
|
||||
else
|
||||
libssl_dep = dependency('openssl', version: '>= 0.9.8',
|
||||
- required: get_option('with-ssl'))
|
||||
- required: get_option('tls'))
|
||||
+ required: false)
|
||||
+ if not libssl_dep.found()
|
||||
+ libssl_dep = [
|
||||
+ cc.find_library('ssl', required: get_option('with-ssl')),
|
||||
+ cc.find_library('crypto', required: get_option('with-ssl'))
|
||||
+ cc.find_library('ssl', required: get_option('tls')),
|
||||
+ cc.find_library('crypto', required: get_option('tls'))
|
||||
+ ]
|
||||
+ libssl_dep_found = libssl_dep[0].found()
|
||||
+ else
|
||||
|
@ -23,22 +27,30 @@
|
|||
endif
|
||||
|
||||
config_h = configuration_data()
|
||||
@@ -49,7 +59,7 @@ config_h.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSIO
|
||||
config_h.set('HAVE_MEMRCHR', cc.has_function('memrchr'))
|
||||
config_h.set('HAVE_STRINGS_H', cc.has_header('strings.h'))
|
||||
@@ -37,7 +46,7 @@
|
||||
config_h.set10('ENABLE_NLS', true)
|
||||
|
||||
# Optional features
|
||||
-config_h.set('USE_OPENSSL', libssl_dep.found())
|
||||
+config_h.set('USE_OPENSSL', libssl_dep_found)
|
||||
config_h.set('USE_LIBCANBERRA', libcanberra_dep.found())
|
||||
config_h.set('USE_DBUS', dbus_glib_dep.found())
|
||||
config_h.set('USE_PLUGIN', get_option('plugin'))
|
||||
@@ -57,7 +66,7 @@
|
||||
join_paths(get_option('prefix'), get_option('libdir'), 'hexchat/plugins')
|
||||
)
|
||||
|
||||
-if libssl_dep.found()
|
||||
+if libssl_dep_found
|
||||
config_h.set('HAVE_X509_GET_SIGNATURE_NID',
|
||||
cc.has_function('X509_get_signature_nid', dependencies: libssl_dep)
|
||||
)
|
||||
@@ -129,9 +139,6 @@ global_ldflags = []
|
||||
test_ldflags = [
|
||||
'-Wl,-z,relro',
|
||||
'-Wl,-z,now',
|
||||
- # mingw
|
||||
- '-Wl,--dynamicbase',
|
||||
- '-Wl,--nxcompat',
|
||||
]
|
||||
foreach ldflag : test_ldflags
|
||||
if meson.version().version_compare('>= 0.46.0')
|
||||
@@ -178,7 +187,7 @@
|
||||
}, section: 'Directories')
|
||||
|
||||
summary({
|
||||
- 'TLS (openssl)': libssl_dep.found(),
|
||||
+ 'TLS (openssl)': libssl_dep_found,
|
||||
'Plugin Support': get_option('plugin'),
|
||||
'DBus Support': dbus_glib_dep.found(),
|
||||
'libcanberra': libcanberra_dep.found(),
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- plugins/sysinfo/meson.build.orig 2019-12-22 13:48:33 UTC
|
||||
+++ plugins/sysinfo/meson.build
|
||||
@@ -13,13 +13,13 @@ sysinfo_includes = []
|
||||
sysinfo_cargs = []
|
||||
|
||||
system = host_machine.system()
|
||||
-if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin'
|
||||
+if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin' or system == 'freebsd'
|
||||
sysinfo_includes += 'shared'
|
||||
sysinfo_sources += [
|
||||
'shared/df.c'
|
||||
]
|
||||
|
||||
- if system == 'linux' or system == 'gnu' or system.startswith('gnu/')
|
||||
+ if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'freebsd'
|
||||
libpci = dependency('libpci', required: false, method: 'pkg-config')
|
||||
if libpci.found()
|
||||
sysinfo_deps += libpci
|
|
@ -1,11 +0,0 @@
|
|||
--- src/common/server.c.orig 2018-08-29 16:41:08 UTC
|
||||
+++ src/common/server.c
|
||||
@@ -748,7 +748,7 @@ server_connect_success (server *serv)
|
||||
|
||||
/* it'll be a memory leak, if connection isn't terminated by
|
||||
server_cleanup() */
|
||||
- if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, NULL)))
|
||||
+ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, "%%CA_BUNDLE%%")))
|
||||
{
|
||||
EMIT_SIGNAL (XP_TE_CONNFAIL, serv->server_session, err, NULL,
|
||||
NULL, NULL, 0);
|
11
irc/hexchat/files/patch-src_common_meson.build
Normal file
11
irc/hexchat/files/patch-src_common_meson.build
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/common/meson.build.orig 2021-10-07 15:54:34.995639000 +0200
|
||||
+++ src/common/meson.build 2021-10-07 15:54:46.304819000 +0200
|
||||
@@ -73,7 +73,7 @@
|
||||
# SIGACTION
|
||||
# HAVE_GTK_MAC
|
||||
|
||||
-if libssl_dep.found()
|
||||
+if libssl_dep_found
|
||||
common_sources += 'ssl.c'
|
||||
common_deps += libssl_dep
|
||||
endif
|
|
@ -7,6 +7,9 @@ lib/hexchat/plugins/checksum.so
|
|||
lib/hexchat/plugins/python.so
|
||||
%%LUA%%lib/hexchat/plugins/lua.so
|
||||
%%SYSINFO%%lib/hexchat/plugins/sysinfo.so
|
||||
lib/hexchat/python/_hexchat.py
|
||||
lib/hexchat/python/hexchat.py
|
||||
lib/hexchat/python/xchat.py
|
||||
libdata/pkgconfig/hexchat-plugin.pc
|
||||
man/man1/hexchat.1.gz
|
||||
share/metainfo/io.github.Hexchat.appdata.xml
|
||||
|
|
Loading…
Reference in a new issue