Upgrade to 0.6.10.
This commit is contained in:
parent
9c5376b8eb
commit
71f9ddf14a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42701
6 changed files with 40 additions and 64 deletions
|
@ -6,14 +6,15 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= sketch
|
PORTNAME= sketch
|
||||||
PORTVERSION= 0.6.9
|
PORTVERSION= 0.6.10
|
||||||
CATEGORIES= graphics
|
CATEGORIES= graphics
|
||||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/Imaging.h:${PORTSDIR}/graphics/py-imaging
|
BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/Imaging.h:${PORTSDIR}/graphics/py-imaging \
|
||||||
|
${PYDISTUTILS}
|
||||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
|
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
|
||||||
${PYTHON_SITELIBDIR}/_imaging.so:${PORTSDIR}/graphics/py-imaging \
|
${PYTHON_SITELIBDIR}/_imaging.so:${PORTSDIR}/graphics/py-imaging \
|
||||||
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab \
|
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab \
|
||||||
|
@ -21,17 +22,18 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinte
|
||||||
|
|
||||||
USE_PYTHON= yes
|
USE_PYTHON= yes
|
||||||
|
|
||||||
|
CONFFLAGS= --tk-autoconf --tk-flags="-I${X11BASE}/include -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 -L${LOCALBASE}/lib -ltk83 -ltcl83 -L${X11BASE}/lib -lX11"
|
||||||
|
|
||||||
SKETCHDIR= ${PREFIX}/share/sketch
|
SKETCHDIR= ${PREFIX}/share/sketch
|
||||||
SKETCHDOCDIR= ${PREFIX}/share/doc/sketch
|
SKETCHDOCDIR= ${PREFIX}/share/doc/sketch
|
||||||
SKETCHDOCS= BUGS Doc NEWS PROJECTS README TODO
|
SKETCHDOCS= BUGS Doc NEWS PROJECTS README TODO
|
||||||
SKETCHEXDIR= ${PREFIX}/share/examples/sketch
|
SKETCHEXDIR= ${PREFIX}/share/examples/sketch
|
||||||
SKETCHSCRIPTS= finishinst.py sk2ps.py sketch.py skshow.py
|
SKETCHSCRIPTS= finishinst.py sk2ps.py sketch.py skshow.py
|
||||||
|
|
||||||
post-patch:
|
|
||||||
@${PERL} -pi -e "s;%%PORTSDIR%%;${PORTSDIR};" ${WRKSRC}/setup.py
|
|
||||||
|
|
||||||
do-configure:
|
do-configure:
|
||||||
@(cd ${WRKSRC} && ${PYTHON_CMD} setup.py configure)
|
@(cd ${WRKSRC} && \
|
||||||
|
${SETENV} ${CONFIGURE_ENV} \
|
||||||
|
${PYTHON_CMD} setup.py configure ${CONFFLAGS})
|
||||||
|
|
||||||
do-build:
|
do-build:
|
||||||
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build)
|
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build)
|
||||||
|
|
|
@ -1 +1 @@
|
||||||
MD5 (sketch-0.6.9.tar.gz) = ed7e06a681a8d8befc0df230f3cbcd9f
|
MD5 (sketch-0.6.10.tar.gz) = 784e61354d0af63aaccbd3212559e66c
|
||||||
|
|
|
@ -1,25 +1,11 @@
|
||||||
--- setup.py.orig Tue Jun 27 01:06:41 2000
|
--- setup.py.orig Sat May 12 21:20:07 2001
|
||||||
+++ setup.py Thu Aug 17 19:16:43 2000
|
+++ setup.py Tue May 15 15:21:20 2001
|
||||||
@@ -238,8 +238,10 @@
|
@@ -224,7 +224,7 @@
|
||||||
'python' + sys.version[:3], 'config')
|
def configure_tkinter(configs, flags):
|
||||||
setup = os.path.join(configdir, 'Setup')
|
# If --tk-flags was given on the command line, use those.
|
||||||
setup_local = os.path.join(configdir, 'Setup.local')
|
if flags['tk']['flags']:
|
||||||
+ setup_tkinter = '%%PORTSDIR%%/x11-toolkits/py-tkinter/files/Setup'
|
- configs['_tkinter'] = read_target(flags['tk']['flags'])
|
||||||
else:
|
+ configs['_tkinter'] = read_target(flags['tk']['flags'], '')
|
||||||
setup_local = ''
|
return
|
||||||
+ setup_tkinter = ''
|
# For python < 2.1 just use the tkconfig from python's Setup, unless
|
||||||
print 'reading configuration from', setup, '...',
|
# the user explicitly requests auto-configure
|
||||||
configs = extract_config(setup)
|
|
||||||
print 'done'
|
|
||||||
@@ -247,6 +249,11 @@
|
|
||||||
if setup_local:
|
|
||||||
print 'reading additional configuration from', setup_local, '...',
|
|
||||||
configs = extract_config(setup_local, configs)
|
|
||||||
+ print 'done'
|
|
||||||
+
|
|
||||||
+ if setup_tkinter:
|
|
||||||
+ print 'reading additional configuration from', setup_tkinter, '...',
|
|
||||||
+ configs = extract_config(setup_tkinter, configs)
|
|
||||||
print 'done'
|
|
||||||
|
|
||||||
if not configs.has_key('_tkinter'):
|
|
||||||
|
|
|
@ -6,14 +6,15 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= sketch
|
PORTNAME= sketch
|
||||||
PORTVERSION= 0.6.9
|
PORTVERSION= 0.6.10
|
||||||
CATEGORIES= graphics
|
CATEGORIES= graphics
|
||||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/Imaging.h:${PORTSDIR}/graphics/py-imaging
|
BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/Imaging.h:${PORTSDIR}/graphics/py-imaging \
|
||||||
|
${PYDISTUTILS}
|
||||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
|
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
|
||||||
${PYTHON_SITELIBDIR}/_imaging.so:${PORTSDIR}/graphics/py-imaging \
|
${PYTHON_SITELIBDIR}/_imaging.so:${PORTSDIR}/graphics/py-imaging \
|
||||||
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab \
|
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab \
|
||||||
|
@ -21,17 +22,18 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinte
|
||||||
|
|
||||||
USE_PYTHON= yes
|
USE_PYTHON= yes
|
||||||
|
|
||||||
|
CONFFLAGS= --tk-autoconf --tk-flags="-I${X11BASE}/include -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 -L${LOCALBASE}/lib -ltk83 -ltcl83 -L${X11BASE}/lib -lX11"
|
||||||
|
|
||||||
SKETCHDIR= ${PREFIX}/share/sketch
|
SKETCHDIR= ${PREFIX}/share/sketch
|
||||||
SKETCHDOCDIR= ${PREFIX}/share/doc/sketch
|
SKETCHDOCDIR= ${PREFIX}/share/doc/sketch
|
||||||
SKETCHDOCS= BUGS Doc NEWS PROJECTS README TODO
|
SKETCHDOCS= BUGS Doc NEWS PROJECTS README TODO
|
||||||
SKETCHEXDIR= ${PREFIX}/share/examples/sketch
|
SKETCHEXDIR= ${PREFIX}/share/examples/sketch
|
||||||
SKETCHSCRIPTS= finishinst.py sk2ps.py sketch.py skshow.py
|
SKETCHSCRIPTS= finishinst.py sk2ps.py sketch.py skshow.py
|
||||||
|
|
||||||
post-patch:
|
|
||||||
@${PERL} -pi -e "s;%%PORTSDIR%%;${PORTSDIR};" ${WRKSRC}/setup.py
|
|
||||||
|
|
||||||
do-configure:
|
do-configure:
|
||||||
@(cd ${WRKSRC} && ${PYTHON_CMD} setup.py configure)
|
@(cd ${WRKSRC} && \
|
||||||
|
${SETENV} ${CONFIGURE_ENV} \
|
||||||
|
${PYTHON_CMD} setup.py configure ${CONFFLAGS})
|
||||||
|
|
||||||
do-build:
|
do-build:
|
||||||
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build)
|
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build)
|
||||||
|
|
|
@ -1 +1 @@
|
||||||
MD5 (sketch-0.6.9.tar.gz) = ed7e06a681a8d8befc0df230f3cbcd9f
|
MD5 (sketch-0.6.10.tar.gz) = 784e61354d0af63aaccbd3212559e66c
|
||||||
|
|
|
@ -1,25 +1,11 @@
|
||||||
--- setup.py.orig Tue Jun 27 01:06:41 2000
|
--- setup.py.orig Sat May 12 21:20:07 2001
|
||||||
+++ setup.py Thu Aug 17 19:16:43 2000
|
+++ setup.py Tue May 15 15:21:20 2001
|
||||||
@@ -238,8 +238,10 @@
|
@@ -224,7 +224,7 @@
|
||||||
'python' + sys.version[:3], 'config')
|
def configure_tkinter(configs, flags):
|
||||||
setup = os.path.join(configdir, 'Setup')
|
# If --tk-flags was given on the command line, use those.
|
||||||
setup_local = os.path.join(configdir, 'Setup.local')
|
if flags['tk']['flags']:
|
||||||
+ setup_tkinter = '%%PORTSDIR%%/x11-toolkits/py-tkinter/files/Setup'
|
- configs['_tkinter'] = read_target(flags['tk']['flags'])
|
||||||
else:
|
+ configs['_tkinter'] = read_target(flags['tk']['flags'], '')
|
||||||
setup_local = ''
|
return
|
||||||
+ setup_tkinter = ''
|
# For python < 2.1 just use the tkconfig from python's Setup, unless
|
||||||
print 'reading configuration from', setup, '...',
|
# the user explicitly requests auto-configure
|
||||||
configs = extract_config(setup)
|
|
||||||
print 'done'
|
|
||||||
@@ -247,6 +249,11 @@
|
|
||||||
if setup_local:
|
|
||||||
print 'reading additional configuration from', setup_local, '...',
|
|
||||||
configs = extract_config(setup_local, configs)
|
|
||||||
+ print 'done'
|
|
||||||
+
|
|
||||||
+ if setup_tkinter:
|
|
||||||
+ print 'reading additional configuration from', setup_tkinter, '...',
|
|
||||||
+ configs = extract_config(setup_tkinter, configs)
|
|
||||||
print 'done'
|
|
||||||
|
|
||||||
if not configs.has_key('_tkinter'):
|
|
||||||
|
|
Loading…
Reference in a new issue