- Update MASTER_SITES
- Support CC properly - Add MAKE_JOBS_SAFE PR: ports fury
This commit is contained in:
parent
53b2192224
commit
71f9effc4c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311615
2 changed files with 14 additions and 24 deletions
|
@ -1,17 +1,11 @@
|
|||
# New ports collection makefile for: interGif
|
||||
# Date created: 31 August 2005
|
||||
# Whom: jamie
|
||||
#
|
||||
# Created by: jamie
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= interGif
|
||||
PORTVERSION= 6.15
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://utter.chaos.org.uk/~pdh/software/arc/ \
|
||||
http://ftp.bishopston.net/freebsd/distfiles/ \
|
||||
ftp://ftp.bishopston.net/freebsd/distfiles/
|
||||
DISTNAME= ig615src
|
||||
MASTER_SITES= http://utter.chaos.org.uk/~pdh/software/arc/
|
||||
DISTNAME= ig${PORTVERSION:S,.,,}src
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -19,13 +13,20 @@ COMMENT= Efficient animated GIF optimiser
|
|||
|
||||
WRKSRC= ${WRKDIR}/igsrc
|
||||
|
||||
PLIST_FILES= bin/intergif
|
||||
MAKEFILE= makefile.ix
|
||||
ALL_TARGET= intergif
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
pre-patch:
|
||||
${CP} -f ${WRKSRC}/makefile.ix ${WRKSRC}/Makefile
|
||||
PLIST_FILES= bin/intergif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|=.*cc|= $$(CC)| ; \
|
||||
s|-O6|$$(CFLAGS)| ; \
|
||||
s|@echo|@true| ; \
|
||||
s|@$$(cc)|$$(cc)|' ${WRKSRC}/src/makefile.ix
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/intergif ${PREFIX}/bin/intergif
|
||||
(cd ${WRKSRC} && ${INSTALL_PROGRAM} intergif ${PREFIX}/bin)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/makefile.ix.orig 2012-11-30 16:05:40.000000000 +0100
|
||||
+++ src/makefile.ix 2012-11-30 16:06:20.000000000 +0100
|
||||
@@ -10,7 +10,7 @@
|
||||
Link=cc
|
||||
LinkFlags = -o $@
|
||||
cc = cc
|
||||
-CCflags = -O6 --unsigned-char -c -Wall -Wno-unused
|
||||
+CCflags = -O6 --unsigned-char -c -Wall -Wno-unused ${CFLAGS}
|
||||
|
||||
.SUFFIXES: .c .o
|
||||
|
Loading…
Reference in a new issue