New port: net/qoauth-qt5.

This is the Qt5 version of net/qoauth. The port was originally created by
fluffy@ in our area51 repository, and later worked on by tcberner@.

QOAuth is an attempt to support interaction with OAuth-powered network services
in a Qt way.

WWW: https://github.com/ayoy/qoauth
This commit is contained in:
Raphael Kubo da Costa 2017-03-28 10:49:48 +00:00
parent e809727415
commit 726a3dff29
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437115
8 changed files with 106 additions and 0 deletions

View file

@ -1076,6 +1076,7 @@
SUBDIR += qadsl
SUBDIR += qjsonrpc
SUBDIR += qoauth
SUBDIR += qoauth-qt5
SUBDIR += qt4-network
SUBDIR += qt5-network
SUBDIR += qtweetlib

25
net/qoauth-qt5/Makefile Normal file
View file

@ -0,0 +1,25 @@
# Created by: Dima Panov <fluffy@FreeBSD.org>
# $FreeBSD$
PORTNAME= qoauth
PORTVERSION= 2.0.0
DISTVERSIONPREFIX= v
CATEGORIES= net devel security
PKGNAMESUFFIX= -qt5
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt5 support for OAuth-powered network services
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libqca-qt5.so:devel/qca-qt5
USES= qmake:outsource
USE_LDCONFIG= yes
USE_QT5= core network testlib buildtools_build qmake_build
USE_GITHUB= yes
GH_ACCOUNT= ayoy
.include <bsd.port.mk>

3
net/qoauth-qt5/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1483780221
SHA256 (ayoy-qoauth-v2.0.0_GH0.tar.gz) = a28005986410d333e03d077679cdf6c504ec5a33342867dc0f9fb0b74285e333
SIZE (ayoy-qoauth-v2.0.0_GH0.tar.gz) = 53207

View file

@ -0,0 +1,14 @@
--- oauth.prf.orig 2016-11-28 17:52:39 UTC
+++ oauth.prf
@@ -31,9 +31,9 @@ mac: {
# else, link normally
isEmpty(LINKAGE) {
exists($$PWD/qoauth.pro): INCLUDEPATH += $$QOAUTH_INCDIR
- else: INCLUDEPATH += $$QOAUTH_INCDIR/QtOAuth
+ else: INCLUDEPATH += $$QOAUTH_INCDIR/QtOAuth-qt5
LIBS += -L$$QOAUTH_LIBDIR
- LINKAGE = -lqoauth
+ LINKAGE = -lqoauth-qt5
CONFIG(debug, debug|release) {
windows:LINKAGE = -lqoauthd1
mac:LINKAGE = -lqoauth_debug

View file

@ -0,0 +1,19 @@
--- src/pcfile.sh.orig 2016-11-28 17:52:39 UTC
+++ src/pcfile.sh
@@ -5,11 +5,11 @@
echo "prefix=$1
exec_prefix=\${prefix}
libdir=\${prefix}/lib
-includedir=\${prefix}/include/QtOAuth
+includedir=\${prefix}/include/QtOAuth-qt5
-Name: QOAuth
+Name: QOAuth-qt5
Description: Qt OAuth support library
Version: $2
-Requires: QtCore QtNetwork qca2
-Libs: -L\${libdir} -lqoauth
-Cflags: -I\${includedir}" > qoauth.pc
+Requires: Qt5Core Qt5Network qca2-qt5
+Libs: -L\${libdir} -lqoauth-qt5
+Cflags: -I\${includedir}" > qoauth-qt5.pc

View file

@ -0,0 +1,29 @@
--- src/src.pro.orig 2016-11-28 17:52:39 UTC
+++ src/src.pro
@@ -1,4 +1,4 @@
-TARGET = qoauth
+TARGET = qoauth-qt5
DESTDIR = ../lib
win32:DLLDESTDIR = $${DESTDIR}
@@ -78,7 +78,7 @@ else:unix {
# this creates a pkgconfig file
system( ./pcfile.sh $${INSTALL_PREFIX} $${VERSION} )
- pkgconfig.files = qoauth.pc
+ pkgconfig.files = qoauth-qt5.pc
contains(QMAKE_HOST.arch, x86_64) {
target.path = $${INSTALL_PREFIX}/lib64
@@ -86,9 +86,9 @@ else:unix {
target.path = $${INSTALL_PREFIX}/lib
}
- headers.path = $${INSTALL_PREFIX}/include/QtOAuth
+ headers.path = $${INSTALL_PREFIX}/include/QtOAuth-qt5/QtOAuth
docs.path = $${INSTALL_PREFIX}/share/doc/$${TARGET}-$${VERSION}/html
- pkgconfig.path = $${target.path}/pkgconfig
+ pkgconfig.path = $${INSTALL_PREFIX}/libdata/pkgconfig
INSTALLS += \
target \
headers \

4
net/qoauth-qt5/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
QOAuth is an attempt to support interaction with OAuth-powered network services
in a Qt way
WWW: https://github.com/ayoy/qoauth

11
net/qoauth-qt5/pkg-plist Normal file
View file

@ -0,0 +1,11 @@
include/QtOAuth-qt5/QtOAuth/QtOAuth
include/QtOAuth-qt5/QtOAuth/interface.h
include/QtOAuth-qt5/QtOAuth/qoauth_global.h
include/QtOAuth-qt5/QtOAuth/qoauth_namespace.h
lib/libqoauth-qt5.prl
lib/libqoauth-qt5.so
lib/libqoauth-qt5.so.2
lib/libqoauth-qt5.so.2.0
lib/libqoauth-qt5.so.2.0.0
%%QT_MKSPECDIR%%/features/oauth.prf
libdata/pkgconfig/qoauth-qt5.pc