New port: databases/ldb

ldb is a LDAP-like embedded database.

ldb provides a fast database with an LDAP-like API
designed to be used within an application.

In some ways it can be seen as a intermediate solution
between key-value pair databases and a real LDAP database.

WWW: http://ldb.samba.org/

PR:		ports/161266
Submitted by:	Andrew Elble <aweits@rit.edu>
This commit is contained in:
Ryan Steinmetz 2011-10-04 16:04:07 +00:00
parent 1e14aedb1d
commit 726cc4a068
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282922
6 changed files with 101 additions and 0 deletions

View file

@ -142,6 +142,7 @@
SUBDIR += ksqlshell
SUBDIR += kumofs
SUBDIR += kyotocabinet
SUBDIR += ldb
SUBDIR += libdbi
SUBDIR += libdbi-drivers
SUBDIR += libdrizzle

39
databases/ldb/Makefile Normal file
View file

@ -0,0 +1,39 @@
# New ports collection makefile for: ldb
# Date created: Sep 6 2011
# Whom: Ryan Steinmetz <zi@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ldb
DISTVERSION= 1.1.0
CATEGORIES= databases
MASTER_SITES= SAMBA
MASTER_SITE_SUBDIR= ../../ftp/pub/${PORTNAME}
MAINTAINER= aweits@rit.edu
COMMENT= An LDAP-like embedded database
LICENSE= LGPL3
LIB_DEPENDS= talloc.2:${PORTSDIR}/devel/talloc \
tevent.0:${PORTSDIR}/devel/tevent \
tdb.1:${PORTSDIR}/databases/tdb \
popt.0:${PORTSDIR}/devel/popt \
xslt.2:${PORTSDIR}/textproc/libxslt
CONFLICTS= samba4-devel-4*
CONFIGURE_ARGS= --with-modulesdir=${PREFIX}/lib \
--builtin-libraries=replace \
--bundled-libraries=NONE
CFLAGS+= -L${LOCALBASE}/lib
HAS_CONFIGURE= yes
USE_PYTHON= yes
USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|..LIBDIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g' ${WRKSRC}/wscript
.include <bsd.port.mk>

2
databases/ldb/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (ldb-1.1.0.tar.gz) = 84f3841a69f8b3bba30b70f6d548b145a0b87cfef13c21f8c776f4aec490347e
SIZE (ldb-1.1.0.tar.gz) = 839912

View file

@ -0,0 +1,19 @@
--- ./wscript.orig 2011-10-04 07:47:27.000000000 -0400
+++ ./wscript 2011-10-04 07:47:35.000000000 -0400
@@ -220,16 +220,6 @@
deps='ldb',
subsystem='ldb')
- bld.SAMBA_MODULE('ldb_tdb',
- bld.SUBDIR('ldb_tdb',
- '''ldb_tdb.c ldb_pack.c ldb_search.c ldb_index.c
- ldb_cache.c ldb_tdb_wrap.c'''),
- init_function='ldb_tdb_init',
- module_init_name='ldb_init_module',
- internal_module=False,
- deps='tdb ldb',
- subsystem='ldb')
-
# have a separate subsystem for common/ldb.c, so it can rebuild
# for install with a different -DLDB_MODULESDIR=
bld.SAMBA_SUBSYSTEM('LIBLDB_MAIN',

9
databases/ldb/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
ldb is a LDAP-like embedded database.
ldb provides a fast database with an LDAP-like API
designed to be used within an application.
In some ways it can be seen as a intermediate solution
between key-value pair databases and a real LDAP database.
WWW: http://ldb.samba.org/

31
databases/ldb/pkg-plist Normal file
View file

@ -0,0 +1,31 @@
bin/ldbadd
bin/ldbdel
bin/ldbedit
bin/ldbmodify
bin/ldbrename
bin/ldbsearch
include/ldb.h
include/ldb_errors.h
include/ldb_handlers.h
include/ldb_module.h
include/ldb_version.h
include/pyldb.h
lib/ldb/libldb-cmdline.so
lib/ldb/paged_results.so
lib/ldb/asq.so
lib/ldb/server_sort.so
lib/ldb/paged_searches.so
lib/ldb/rdn_name.so
lib/ldb/sample.so
lib/ldb/skel.so
lib/libldb.so
lib/libldb.so.1
lib/libldb.so.1.1.0
lib/libpyldb-util.so
lib/libpyldb-util.so.1
lib/libpyldb-util.so.1.1.0
libdata/pkgconfig/pyldb-util.pc
libdata/pkgconfig/ldb.pc
@dirrmtry libdata/pkgconfig
lib/%%PYTHON_VERSION%%/site-packages/ldb.so
@dirrmtry lib/ldb