- Add missed gconf into USE_GNOME and bump PORTREVISION;
- remove redundant patch, whose functionality is replaced by gnomehack; - use USE_LIBTOOL, while I here and don't waste time building included tests; - fix pkg-plist.
This commit is contained in:
parent
ce72aa3487
commit
727d728cbc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62747
6 changed files with 25 additions and 54 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= bonobo-conf
|
||||
PORTVERSION= 0.14
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= unstable/sources/bonobo-conf
|
||||
|
@ -17,9 +18,9 @@ USE_X_PREFIX= yes
|
|||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gnomeprefix gnomehack bonobo
|
||||
USE_GNOME= gnomeprefix gnomehack bonobo gconf
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
|
|
@ -1,9 +1,15 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in 2001/08/03 07:37:16 1.1
|
||||
+++ Makefile.in 2001/08/03 07:38:38
|
||||
@@ -144,7 +144,7 @@
|
||||
--- Makefile.in.orig Wed Jul 10 10:43:21 2002
|
||||
+++ Makefile.in Wed Jul 10 10:51:01 2002
|
||||
@@ -145,12 +145,12 @@
|
||||
XML_I18N_UPDATE = @XML_I18N_UPDATE@
|
||||
ZVT_LIBS = @ZVT_LIBS@
|
||||
|
||||
-SUBDIRS = po intl bonobo-conf monikers examples cedit idl macros doc tests
|
||||
+SUBDIRS = po intl bonobo-conf monikers examples cedit idl macros doc
|
||||
|
||||
EXTRA_DIST = xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in bonobo_confConf.sh.in bonobo-conf.spec
|
||||
|
||||
|
||||
|
|
|
@ -1,6 +0,0 @@
|
|||
--- macros/Makefile.in.orig Fri Feb 9 04:08:41 2001
|
||||
+++ macros/Makefile.in Fri Feb 9 16:43:29 2001
|
||||
@@ -99,2 +99,2 @@
|
||||
|
||||
-@INSIDE_GNOME_COMMON_TRUE@gnome_aclocaldir = $(datadir)/aclocal/gnome-macros
|
||||
+@INSIDE_GNOME_COMMON_TRUE@gnome_aclocaldir = $(prefix)/share/aclocal/gnome-macros
|
|
@ -1,9 +1,17 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Wed Nov 7 17:26:45 2001
|
||||
+++ configure Wed Nov 7 17:38:11 2001
|
||||
@@ -8717,7 +8717,7 @@
|
||||
--- configure.orig Thu Nov 1 13:25:50 2001
|
||||
+++ configure Wed Jul 10 10:40:37 2002
|
||||
@@ -5694,6 +5694,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -8717,7 +8718,7 @@
|
||||
fi
|
||||
|
||||
|
||||
|
@ -12,7 +20,7 @@ $FreeBSD$
|
|||
fi
|
||||
|
||||
else
|
||||
@@ -8924,7 +8924,7 @@
|
||||
@@ -8924,7 +8925,7 @@
|
||||
fi
|
||||
|
||||
for lang in $ALL_LINGUAS; do
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh.orig Sun Jan 20 16:11:07 2002
|
||||
+++ ltmain.sh Tue Jan 22 13:34:20 2002
|
||||
@@ -1060,6 +1060,7 @@
|
||||
|
||||
-module)
|
||||
module=yes
|
||||
+ build_old_libs=no
|
||||
continue
|
||||
;;
|
||||
|
||||
@@ -2442,6 +2443,9 @@
|
||||
*-*-openbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4208,10 +4212,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -30,7 +30,5 @@ share/locale/pl/LC_MESSAGES/bonobo-conf.mo
|
|||
share/locale/sv/LC_MESSAGES/bonobo-conf.mo
|
||||
share/locale/tr/LC_MESSAGES/bonobo-conf.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/bonobo-conf.mo
|
||||
@dirrm share/gnome/bonobo-conf/html/bonobo-conf
|
||||
@dirrm share/gnome/bonobo-conf/html
|
||||
@dirrm share/gnome/bonobo-conf
|
||||
@dirrm share/doc/bonobo-conf
|
||||
@dirrm include/bonobo-conf
|
||||
|
|
Loading…
Reference in a new issue