lang/sdcc-devel: update to version 2.5.6.2006.06.29

- Update of lang/sdcc-devel which mainly brings in support
    for more PIC microcontrollers.

PR:		lang/sdcc-devel
Submitted by:	maintainer
This commit is contained in:
Daichi GOTO 2006-06-30 05:02:43 +00:00
parent 60f12f0750
commit 728459f0a5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=166645
12 changed files with 2480 additions and 1976 deletions

View file

@ -6,11 +6,11 @@
#
PORTNAME= sdcc
PORTVERSION= 2.5.4.2005.11.15
PORTVERSION= 2.5.6.2006.06.29
CATEGORIES= lang
MASTER_SITES= http://sdcc.sourceforge.net/snapshots/sdcc-src/ \
http://www.kalimero.be/mirror/
DISTNAME= ${PORTNAME}-src-20051115
DISTNAME= ${PORTNAME}-src-20060629-4251
MAINTAINER= tijl@ulyssis.org
COMMENT= Small Device C Compiler
@ -29,11 +29,20 @@ OPTIONS= MCS51 "Intel mcs51 port" on \
PIC16 "PIC16 port" on \
XA51 "XA51 port" on \
HC08 "HC08 port" on \
DEVLIB "Device libraries" on \
UCSIM "The ucSim simulator" on \
PACKIHX "A tool to pack (compress) Intel hex files" on
.include <bsd.port.pre.mk>
.if defined(WITHOUT_MCS51) && defined(WITHOUT_DS390)
CONFIGURE_ARGS+= --disable-51
PLIST_SUB+= MCS51DS390="@comment "
.else
USE_AUTOTOOLS+= autoconf:259
PLIST_SUB+= MCS51DS390=""
.endif
.if defined(WITHOUT_MCS51)
CONFIGURE_ARGS+= --disable-mcs51-port
PLIST_SUB+= MCS51="@comment "
@ -42,14 +51,17 @@ PLIST_SUB+= MCS51=""
.endif
.if defined(WITHOUT_Z80)
CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port
CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port --disable-z80
PLIST_SUB+= Z80="@comment "
.else
PLIST_SUB+= Z80=""
.endif
.if defined(WITHOUT_AVR)
CONFIGURE_ARGS+= --disable-avr-port
CONFIGURE_ARGS+= --disable-avr-port --disable-avr
PLIST_SUB+= AVR="@comment "
.else
PLIST_SUB+= AVR=""
.endif
.if defined(WITHOUT_DS390)
@ -63,6 +75,7 @@ PLIST_SUB+= DS390=""
CONFIGURE_ARGS+= --disable-pic-port
PLIST_SUB+= PIC="@comment "
.else
BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC=""
.endif
@ -79,18 +92,25 @@ CONFIGURE_ARGS+= --disable-xa51-port
.endif
.if defined(WITHOUT_HC08)
CONFIGURE_ARGS+= --disable-hc08-port
CONFIGURE_ARGS+= --disable-hc08-port --disable-hc08
PLIST_SUB+= HC08="@comment "
.else
PLIST_SUB+= HC08=""
.endif
.if defined(WITHOUT_DEVLIB)
CONFIGURE_ARGS+= --disable-device-lib
PLIST_SUB+= DEVLIB="@comment "
.else
PLIST_SUB+= DEVLIB=""
.endif
.if defined(WITHOUT_UCSIM)
CONFIGURE_ARGS+= --disable-ucsim
PLIST_SUB+= UCSIM="@comment "
.else
USE_AUTOTOOLS= libtool:15
LIBTOOLFILES= sim/ucsim/aclocal.m4
USE_AUTOTOOLS+= libtool:15
LIBTOOLFILES= sim/ucsim/configure
PLIST_SUB+= UCSIM=""
.endif

View file

@ -1,3 +1,3 @@
MD5 (sdcc-src-20051115.tar.gz) = d50ad3171e1cb6810689022695b1d6e7
SHA256 (sdcc-src-20051115.tar.gz) = f0fb8b8bcb488c92cb7d86d140e9bd8ce615d8e754b0d1cc628ff1f192e57485
SIZE (sdcc-src-20051115.tar.gz) = 3848259
MD5 (sdcc-src-20060629-4251.tar.gz) = 6262c501bc2c3936a1a52e7bfb33436c
SHA256 (sdcc-src-20060629-4251.tar.gz) = da190d2b26aa4c84d1cdb281d2c8e1ef3707d7d037a76d7f2178dc653a2b6ded
SIZE (sdcc-src-20060629-4251.tar.gz) = 4211397

View file

@ -0,0 +1,13 @@
--- Makefile.in.orig Thu May 11 22:06:55 2006
+++ Makefile.in Thu Jun 29 16:05:04 2006
@@ -27,6 +27,10 @@
ifeq ($(OPT_DISABLE_MCS51), 0)
SDCC_ASLINK += as/mcs51
SDCC_MISC += debugger/mcs51
+else
+ifeq ($(OPT_DISABLE_DS390), 0)
+SDCC_ASLINK += as/mcs51
+endif
endif
ifeq ($(OPT_DISABLE_Z80), 0)

View file

@ -0,0 +1,21 @@
--- configure.in.orig Thu May 11 22:06:55 2006
+++ configure.in Wed Jun 28 22:22:07 2006
@@ -634,6 +634,10 @@
test $OPT_DISABLE_AVR = 0 && AC_CONFIG_FILES([src/avr/Makefile])
+if test $OPT_DISABLE_DS390 = 0 -o $OPT_DISABLE_MCS51 = 0; then
+ AC_CONFIG_FILES([as/mcs51/Makefile])
+fi
+
if test $OPT_DISABLE_DS390 = 0; then
AC_CONFIG_FILES([src/ds390/Makefile])
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_FILES([device/lib/ds390/Makefile])
@@ -652,7 +656,6 @@
if test $OPT_DISABLE_MCS51 = 0; then
AC_CONFIG_FILES([src/mcs51/Makefile
- as/mcs51/Makefile
debugger/mcs51/Makefile])
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_FILES([device/lib/mcs51/Makefile
device/lib/small/Makefile

View file

@ -1,27 +1,40 @@
--- device/lib/Makefile.in.orig Tue Nov 15 18:23:59 2005
+++ device/lib/Makefile.in Tue Nov 15 18:24:18 2005
@@ -285,8 +285,6 @@
--- device/lib/Makefile.in.orig Sat Jun 17 16:43:52 2006
+++ device/lib/Makefile.in Wed Jun 28 19:08:03 2006
@@ -337,23 +337,6 @@
# ---------------------------------------------------
install: all installdirs
$(CP_U) -r $(BUILDDIR)/* $(sdcc_libdir)
- $(CP_U) -r ds390 ds400 gbz80 z80 hc08 *.c $(sdcc_libdir)/src
- rm -r `find $(sdcc_libdir)/src -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lst' -o -name '*.asm' -o -name 'CVS'`
- $(CP_U) -r $(MODELS) $(srcdir)/mcs51 $(srcdir)/ds390 $(srcdir)/ds400 \
- $(srcdir)/gbz80 $(srcdir)/z80 $(srcdir)/hc08 \
- $(srcdir)/pic $(srcdir)/pic16 $(srcdir)/*.c $(sdcc_libdir)/src
- $(CP_U) -r $(MODELS) mcs51 ds390 ds400 gbz80 z80 hc08 $(sdcc_libdir)/src
-
- for src in $(MODELS) ds390 ds400 gbz80 z80 hc08 pic pic16; do \
- find $(sdcc_libdir)/src/$$src -depth \
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
- -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'build' -o -name 'bin' -o \
- -name 'Makefile*' \) \
- -exec rm -r {} \; ; \
- done
- find $(sdcc_libdir)/src/mcs51 -depth \
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
- -name '*.lst' -o -name '.svn' -o -name 'build' -o -name 'bin' -o \
- -name 'Makefile*' \) \
- -exec rm -r {} \;
# Deleting all the installed files
# --------------------------------
@@ -307,16 +305,6 @@
@@ -374,14 +357,6 @@
# ---------------------------------
installdirs:
[ -d $(sdcc_libdir) ] || mkdir -p $(sdcc_libdir)
- for model in $(MODELS); do \
- [ -d $(sdcc_libdir)/$$model ] || \
- mkdir -p $(sdcc_libdir)/$$model; \
- [ -d $(sdcc_libdir)/$$model ] || \
- mkdir -p $(sdcc_libdir)/$$model; \
- done
- for libdir in small-stack-auto ds390 ds400 hc08 pic16 pic; do \
- [ -d $(sdcc_libdir)/$$libdir ] || mkdir -p $(sdcc_libdir)/$$libdir; \
- done
- [ -d $(sdcc_libdir)/ds390 ] || mkdir -p $(sdcc_libdir)/ds390
- [ -d $(sdcc_libdir)/ds400 ] || mkdir -p $(sdcc_libdir)/ds400
- [ -d $(sdcc_libdir)/hc08 ] || mkdir -p $(sdcc_libdir)/hc08
- [ -d $(sdcc_libdir)/pic16 ] || mkdir -p $(sdcc_libdir)/pic16
- [ -d $(sdcc_libdir)/pic ] || mkdir -p $(sdcc_libdir)/pic
- mkdir -p $(sdcc_libdir)/src
# Creating dependencies

View file

@ -1,32 +1,32 @@
--- device/lib/pic/Makefile.common.in.orig Tue Nov 15 18:34:37 2005
+++ device/lib/pic/Makefile.common.in Tue Nov 15 18:35:07 2005
--- device/lib/pic/Makefile.common.in.orig Mon May 1 22:47:12 2006
+++ device/lib/pic/Makefile.common.in Wed Jun 28 17:27:29 2006
@@ -12,7 +12,6 @@
### $Id: Makefile.common.in,v 1.1 2005/09/23 21:59:29 tecodev Exp $
### $Id: Makefile.common.in 4148 2006-05-01 20:47:12Z tecodev $
###
-SHELL = bash
#################################################
### verboseness
@@ -23,10 +22,10 @@
@@ -24,10 +23,10 @@
#################################################
### compiler switches
-ARCH ?= 877 # might be overwritten in libio
+PICARCH ?= 877 # might be overwritten in libio
# ARCH might be overwritten in libio
-ARCH ?= 877
+PICARCH ?= 877
CFLAGS ?=
-CFLAGS += -mpic14 -p16f$(ARCH)
+CFLAGS += -mpic14 -p16f$(PICARCH)
CFLAGS += --std-c99
CFLAGS += -I. -I$(topsrcdir)/../../include/pic
CFLAGS += -I. -I$(top_srcdir)/../../include/pic
@@ -53,7 +52,7 @@
@@ -54,7 +53,7 @@
#################################################
### assembler switches
ASFLAGS ?=
-ASFLAGS += -pp16f$(ARCH)
+ASFLAGS += -pp16f$(PICARCH)
ASFLAGS += -I$(topsrcdir)/../../include/pic
ASFLAGS += -I$(top_srcdir)/../../include/pic
ASFLAGS += -I. -I$(srcdir)
#################################################

View file

@ -1,11 +1,11 @@
--- device/lib/pic/Makefile.rules.orig Tue Nov 15 18:36:58 2005
+++ device/lib/pic/Makefile.rules Tue Nov 15 18:37:18 2005
@@ -46,7 +46,7 @@
--- device/lib/pic/Makefile.rules.orig Mon May 1 22:47:12 2006
+++ device/lib/pic/Makefile.rules Thu Jun 29 00:39:50 2006
@@ -56,7 +56,7 @@
ifneq (,$(strip $(SUBDIRS)))
recurse : force
$(Q)+for DIR in $(SUBDIRS) ; do \
- $(GREP) "^$${ARCH}$$" "$${DIR}.ignore" &> /dev/null || ( \
+ $(GREP) "^$${PICARCH}$$" "$${DIR}.ignore" 2>&1 /dev/null || ( \
[ -d "$(topsrcdir)/$(builddir)/$${DIR}" ] || $(MKDIR) "$(topsrcdir)/$(builddir)/$${DIR}"; \
$(MKDIR) "$(top_builddir)$(builddir)/$${DIR}"; \
$(MAKE) -C "$${DIR}" builddir="$(builddir)/$${DIR}" $(MAKECMDGOALS); \
) || exit 1; \

View file

@ -1,7 +1,7 @@
--- device/lib/pic16/Makefile.common.in.orig Sat Aug 20 12:27:03 2005
+++ device/lib/pic16/Makefile.common.in Sat Sep 3 20:21:43 2005
--- device/lib/pic16/Makefile.common.in.orig Mon May 1 22:47:12 2006
+++ device/lib/pic16/Makefile.common.in Wed Jun 28 17:35:09 2006
@@ -16,7 +16,6 @@
### $Id: Makefile.common.in,v 1.10 2005/08/20 10:27:03 sdcc-builder Exp $
### $Id: Makefile.common.in 4148 2006-05-01 20:47:12Z tecodev $
###
-SHELL = bash
@ -19,7 +19,7 @@
-CFLAGS += -mpic16 -p18f$(ARCH)
+CFLAGS += -mpic16 -p18f$(PICARCH)
CFLAGS += --std-c99
CFLAGS += -I. -I$(topsrcdir)/../../include/pic16
CFLAGS += -I. -I$(top_srcdir)/../../include/pic16
@@ -63,7 +62,7 @@
#################################################
@ -27,6 +27,6 @@
ASFLAGS ?=
-ASFLAGS += -pp18f$(ARCH)
+ASFLAGS += -pp18f$(PICARCH)
ASFLAGS += -I$(topsrcdir)/../../include/pic16
ASFLAGS += -I$(top_srcdir)/../../include/pic16
ASFLAGS += -I$(srcdir)
#################################################

View file

@ -1,11 +1,11 @@
--- device/lib/pic16/Makefile.rules.orig Sat Sep 3 20:19:06 2005
+++ device/lib/pic16/Makefile.rules Sat Sep 3 20:19:50 2005
@@ -48,7 +48,7 @@
--- device/lib/pic16/Makefile.rules.orig Mon May 1 22:47:12 2006
+++ device/lib/pic16/Makefile.rules Thu Jun 29 00:40:44 2006
@@ -58,7 +58,7 @@
ifneq (,$(strip $(SUBDIRS)))
recurse : force
$(Q)+for DIR in $(SUBDIRS) ; do \
- $(GREP) "^$${ARCH}$$" "$${DIR}.ignore" &> /dev/null || ( \
+ $(GREP) "^$${PICARCH}$$" "$${DIR}.ignore" 2>&1 > /dev/null || ( \
[ -d "$(topsrcdir)/$(builddir)/$${DIR}" ] || $(MKDIR) "$(topsrcdir)/$(builddir)/$${DIR}"; \
- $(GREP) "^$${ARCH}$$" "$(srcdir)/$${DIR}.ignore" &> /dev/null || ( \
+ $(GREP) "^$${PICARCH}$$" "$(srcdir)/$${DIR}.ignore" 2>&1 /dev/null || ( \
$(MKDIR) "$(top_builddir)$(builddir)/$${DIR}"; \
$(MAKE) -C "$${DIR}" builddir="$(builddir)/$${DIR}" $(MAKECMDGOALS); \
) || exit 1; \

View file

@ -1,9 +1,9 @@
--- device/lib/pic16/libio/Makefile.orig Sat Sep 3 20:23:48 2005
+++ device/lib/pic16/libio/Makefile Sat Sep 3 20:22:58 2005
@@ -35,7 +35,7 @@
--- device/lib/pic16/libio/Makefile.in.orig Mon May 1 22:47:12 2006
+++ device/lib/pic16/libio/Makefile.in Wed Jun 28 17:40:48 2006
@@ -38,7 +38,7 @@
| while read arch; do \
[ "x$${arch}" = "x" ] \
|| ( [ -d "$(builddir)/$${arch}" ] || $(MKDIR) "$(builddir)/$${arch}"; \
|| ( $(MKDIR) "$(top_builddir)$(builddir)/$${arch}"; \
- $(MAKE) MKLIB=libio18f$${arch}.lib builddir=$(builddir)/$${arch} ARCH=$${arch} IO_ARCH=$${arch} $(MAKECMDGOALS); ) \
+ $(MAKE) MKLIB=libio18f$${arch}.lib builddir=$(builddir)/$${arch} PICARCH=$${arch} IO_ARCH=$${arch} $(MAKECMDGOALS); ) \
|| exit 1; \

View file

@ -1,10 +1,10 @@
--- sim/ucsim/cmd.src/Makefile.in.orig Thu Apr 7 13:42:10 2005
+++ sim/ucsim/cmd.src/Makefile.in Thu Apr 7 13:42:26 2005
@@ -43,7 +43,7 @@
--- sim/ucsim/cmd.src/Makefile.in.orig Mon Apr 24 23:19:58 2006
+++ sim/ucsim/cmd.src/Makefile.in Wed Jun 28 17:19:54 2006
@@ -45,7 +45,7 @@
cmduc.o cmdstat.o cmdmem.o \
cmdpars.o cmdlex.o
-DEVEL = $(shell ( bash -c "test -e $(PRJDIR)/devel && echo yes" ))
-DEVEL = $(shell ( bash -c "test -e $(top_builddir)devel && echo yes" ))
+DEVEL = no
# Compiling entire program or any subproject

File diff suppressed because it is too large Load diff