Adding mkcmd version 8.10.
A commandline parse and manual page generator. PR: 14971 Submitted by: Andrew J. Korty <ajk@waterspout.com>
This commit is contained in:
parent
67a1deb7b3
commit
72a241b699
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24129
9 changed files with 207 additions and 0 deletions
|
@ -93,6 +93,7 @@
|
|||
SUBDIR += m68knewlib
|
||||
SUBDIR += makedepend
|
||||
SUBDIR += mico
|
||||
SUBDIR += mkcmd
|
||||
SUBDIR += mkmf
|
||||
SUBDIR += mm
|
||||
SUBDIR += mprof
|
||||
|
|
37
devel/mkcmd/Makefile
Normal file
37
devel/mkcmd/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# New ports collection makefile for: mkcmd
|
||||
# Version required: 8.10
|
||||
# Date created: 17 November 1999
|
||||
# Whom: ajk@waterspout.com
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= mkcmd-8.10
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ajk@waterspout.com
|
||||
|
||||
BUILD_DEPENDS= makeme:${PORTSDIR}/devel/msrc0
|
||||
|
||||
MAKE_FLAGS=
|
||||
MAKEFILE=
|
||||
MAN1= mkcmd.1
|
||||
MAN5= mkcmd.5
|
||||
|
||||
do-build:
|
||||
@(cd ${WRKSRC}/bin/mkcmd && ${SETENV} ${MAKE_ENV} makeme \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
|
||||
do-install:
|
||||
.for d in bin/mkcmd lib/mkcmd
|
||||
@(cd ${WRKSRC}/$d && ${SETENV} ${MAKE_ENV} makeme \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
|
||||
.endfor
|
||||
${INSTALL_MAN} ${WRKSRC}/bin/mkcmd/mkcmd.man \
|
||||
${PREFIX}/man/man1/mkcmd.1
|
||||
${INSTALL_MAN} ${WRKSRC}/lib/mkcmd/mkcmd.man \
|
||||
${PREFIX}/man/man5/mkcmd.5
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/mkcmd/distinfo
Normal file
1
devel/mkcmd/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (mkcmd-8.10.tgz) = b5fd1e05fbf943542147749a7135214e
|
11
devel/mkcmd/files/patch-aa
Normal file
11
devel/mkcmd/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- bin/mkcmd/machine.h.orig Wed Nov 17 12:24:36 1999
|
||||
+++ bin/mkcmd/machine.h Wed Nov 17 12:24:45 1999
|
||||
@@ -13,7 +13,7 @@
|
||||
#endif
|
||||
|
||||
#if !defined(DEFDIR)
|
||||
-#define DEFDIR "/usr/local/lib/mkcmd"
|
||||
+#define DEFDIR "/usr/local/share/mkcmd"
|
||||
#endif
|
||||
|
||||
#if !defined(TILDEDIR)
|
11
devel/mkcmd/files/patch-ab
Normal file
11
devel/mkcmd/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- bin/mkcmd/mkcmd.man.orig Wed Nov 17 12:24:52 1999
|
||||
+++ bin/mkcmd/mkcmd.man Wed Nov 17 12:24:56 1999
|
||||
@@ -43,7 +43,7 @@
|
||||
.TP
|
||||
.BI \-I directory
|
||||
\fBMkcmd\fP searches for the files on the command line first in the
|
||||
-current directory, then in a standard place (\*(lq/usr/local/lib/mkcmd\*(rq),
|
||||
+current directory, then in a standard place (\*(lq/usr/local/share/mkcmd\*(rq),
|
||||
then in any \fIdirectory\fP listed as parameters to this option.
|
||||
.TP
|
||||
.BI \-m manpage
|
11
devel/mkcmd/files/patch-ac
Normal file
11
devel/mkcmd/files/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- lib/mkcmd/Make.host.orig Wed Nov 17 12:28:06 1999
|
||||
+++ lib/mkcmd/Make.host Wed Nov 17 12:28:22 1999
|
||||
@@ -2,7 +2,7 @@
|
||||
# Makefile for mkcmd
|
||||
# Kevin S Braunsdorf, PUCC
|
||||
|
||||
-LIB= ${DESTDIR}/usr/local/lib/mkcmd
|
||||
+LIB= ${DESTDIR}/usr/local/share/mkcmd
|
||||
|
||||
TEMPL= Template.m bytes.m client.m \
|
||||
client.mi cmd.m cmd.mc cmd.mi cmd_add.m cmd_add.mc cmd_cd.m cmd_cd.mc \
|
1
devel/mkcmd/pkg-comment
Normal file
1
devel/mkcmd/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Command-line parser and manual page generator
|
5
devel/mkcmd/pkg-descr
Normal file
5
devel/mkcmd/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
mkcmd lets us build a nifty command line option parser and some
|
||||
on-line documentation in a snap. It is a prerequisite for many of
|
||||
Kevin Braunsdorf's tools.
|
||||
|
||||
FreeBSD port by Andrew J. Korty <ajk@waterspout.com>.
|
129
devel/mkcmd/pkg-plist
Normal file
129
devel/mkcmd/pkg-plist
Normal file
|
@ -0,0 +1,129 @@
|
|||
bin/mkcmd
|
||||
share/mkcmd/Template.m
|
||||
share/mkcmd/bytes.m
|
||||
share/mkcmd/client.m
|
||||
share/mkcmd/client.mi
|
||||
share/mkcmd/cmd.m
|
||||
share/mkcmd/cmd.mc
|
||||
share/mkcmd/cmd.mi
|
||||
share/mkcmd/cmd_add.m
|
||||
share/mkcmd/cmd_add.mc
|
||||
share/mkcmd/cmd_cd.m
|
||||
share/mkcmd/cmd_cd.mc
|
||||
share/mkcmd/cmd_echo.m
|
||||
share/mkcmd/cmd_exec.m
|
||||
share/mkcmd/cmd_exec.mc
|
||||
share/mkcmd/cmd_exit.m
|
||||
share/mkcmd/cmd_help.m
|
||||
share/mkcmd/cmd_help.mc
|
||||
share/mkcmd/cmd_macro.m
|
||||
share/mkcmd/cmd_merge.m
|
||||
share/mkcmd/cmd_parse.m
|
||||
share/mkcmd/cmd_parse.mc
|
||||
share/mkcmd/cmd_shell.m
|
||||
share/mkcmd/cmd_shell.mc
|
||||
share/mkcmd/cmd_source.m
|
||||
share/mkcmd/cmd_source.mc
|
||||
share/mkcmd/cmd_umask.m
|
||||
share/mkcmd/cmd_umask.mc
|
||||
share/mkcmd/cmd_version.m
|
||||
share/mkcmd/date.m
|
||||
share/mkcmd/dir.m
|
||||
share/mkcmd/dir_check.m
|
||||
share/mkcmd/dir_check.mc
|
||||
share/mkcmd/enum.info
|
||||
share/mkcmd/enum.m
|
||||
share/mkcmd/enum.mc
|
||||
share/mkcmd/enum.mh
|
||||
share/mkcmd/enum.mi
|
||||
share/mkcmd/example_cgi.m
|
||||
share/mkcmd/example_cmd.m
|
||||
share/mkcmd/example_date.m
|
||||
share/mkcmd/example_dir.m
|
||||
share/mkcmd/example_dumpdates.m
|
||||
share/mkcmd/example_enum.m
|
||||
share/mkcmd/example_filter.m
|
||||
share/mkcmd/example_fts.m
|
||||
share/mkcmd/example_glob.m
|
||||
share/mkcmd/example_lex.m
|
||||
share/mkcmd/example_macro.m
|
||||
share/mkcmd/example_mult.m
|
||||
share/mkcmd/example_nettime.m
|
||||
share/mkcmd/example_rc.m
|
||||
share/mkcmd/example_server.m
|
||||
share/mkcmd/example_time.m
|
||||
share/mkcmd/example_timebox.m
|
||||
share/mkcmd/getopt.m
|
||||
share/mkcmd/getopt.mc
|
||||
share/mkcmd/getopt.mi
|
||||
share/mkcmd/glob_ieee.m
|
||||
share/mkcmd/glob_ieee.mc
|
||||
share/mkcmd/hosttype.m
|
||||
share/mkcmd/hosttype.mh
|
||||
share/mkcmd/inches.m
|
||||
share/mkcmd/rc.m
|
||||
share/mkcmd/seconds.m
|
||||
share/mkcmd/server.m
|
||||
share/mkcmd/server.mi
|
||||
share/mkcmd/socket.m
|
||||
share/mkcmd/socket.mh
|
||||
share/mkcmd/socket.mi
|
||||
share/mkcmd/std_control.m
|
||||
share/mkcmd/std_datehdr.m
|
||||
share/mkcmd/std_filter.m
|
||||
share/mkcmd/std_fts.m
|
||||
share/mkcmd/std_help.m
|
||||
share/mkcmd/std_lex.m
|
||||
share/mkcmd/std_lex.mc
|
||||
share/mkcmd/std_macro.m
|
||||
share/mkcmd/std_macro.mc
|
||||
share/mkcmd/std_macro.mh
|
||||
share/mkcmd/std_macro.mi
|
||||
share/mkcmd/std_noargs.m
|
||||
share/mkcmd/std_targets.m
|
||||
share/mkcmd/std_version.m
|
||||
share/mkcmd/std_xdev.m
|
||||
share/mkcmd/time.m
|
||||
share/mkcmd/time_tz.m
|
||||
share/mkcmd/timebox.m
|
||||
share/mkcmd/util_by.m
|
||||
share/mkcmd/util_cgi.m
|
||||
share/mkcmd/util_cgi.mc
|
||||
share/mkcmd/util_client.m
|
||||
share/mkcmd/util_client.mc
|
||||
share/mkcmd/util_daemon.m
|
||||
share/mkcmd/util_daemon.mc
|
||||
share/mkcmd/util_daemon.mh
|
||||
share/mkcmd/util_date.m
|
||||
share/mkcmd/util_date.mc
|
||||
share/mkcmd/util_date.mi
|
||||
share/mkcmd/util_fgetln.m
|
||||
share/mkcmd/util_fgetln.mc
|
||||
share/mkcmd/util_fts.m
|
||||
share/mkcmd/util_fts.mc
|
||||
share/mkcmd/util_glob.m
|
||||
share/mkcmd/util_home.m
|
||||
share/mkcmd/util_home.mc
|
||||
share/mkcmd/util_mult.m
|
||||
share/mkcmd/util_mult.mc
|
||||
share/mkcmd/util_mult.mi
|
||||
share/mkcmd/util_rc.m
|
||||
share/mkcmd/util_rc.mc
|
||||
share/mkcmd/util_rc.mi
|
||||
share/mkcmd/util_server.m
|
||||
share/mkcmd/util_server.mc
|
||||
share/mkcmd/util_socket.m
|
||||
share/mkcmd/util_socket.mc
|
||||
share/mkcmd/util_socket.mi
|
||||
share/mkcmd/util_time.m
|
||||
share/mkcmd/util_time.mc
|
||||
share/mkcmd/util_time.mh
|
||||
share/mkcmd/util_time.mi
|
||||
share/mkcmd/util_timebox.m
|
||||
share/mkcmd/util_timebox.mc
|
||||
share/mkcmd/util_timebox.mi
|
||||
share/mkcmd/util_tmp.m
|
||||
share/mkcmd/util_username.m
|
||||
share/mkcmd/util_username.mc
|
||||
share/mkcmd/util_whittle.m
|
||||
@dirrm share/mkcmd
|
Loading…
Reference in a new issue