- Update to 1.0.0

Approved by: Maintainer
This commit is contained in:
Kris Moore 2014-08-09 15:54:11 +00:00
parent 900db324a3
commit 72a345f2b6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364451
4 changed files with 49 additions and 41 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pithos
PORTVERSION= 0.3.18
PORTREVISION= 2
PORTVERSION= 1.0.0
CATEGORIES= audio
DISTNAME= ${PORTVERSION}
@ -15,19 +14,20 @@ LICENSE= GPLv3
USE_GITHUB= yes
GH_ACCOUNT= pithos
GH_PROJECT= pithos
GH_COMMIT= 0770210
GH_COMMIT= 1f5975e
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
${LOCALBASE}/libdata/pkgconfig/notify-python.pc:${PORTSDIR}/devel/py-notify \
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}pylast>0:${PORTSDIR}/audio/py-pylast
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py3-xdg \
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py3-dbus \
${PYTHON_SITELIBDIR}/gi/overrides/Gst.py:${PORTSDIR}/multimedia/py3-gstreamer1 \
${PYTHON_PKGNAMEPREFIX}pylast>0:${PORTSDIR}/audio/py3-pylast \
git:${PORTSDIR}/devel/git
USE_PYTHON= yes
USE_GNOME= pygtk2
USE_GNOME= gtk30 py3gobject3
USE_PYTHON= 3
USE_PYDISTUTILS=yes
USE_GSTREAMER= good bad python
USE_GSTREAMER= core good bad
PYDISTUTILS_AUTOPLIST= yes
INSTALLS_EGGINFO= yes
post-install:
${MKDIR} ${STAGEDIR}${DATADIR}

View file

@ -1,2 +1,2 @@
SHA256 (0.3.18.tar.gz) = e676d455341c03cf271bffc698771713d42f86655f2171a493ffb1a74b51fdac
SIZE (0.3.18.tar.gz) = 115198
SHA256 (1.0.0.tar.gz) = cc0173eef1266945d6f9cb58cdf53b9cb15434e72ffff5d28a0dd0af2e260f99
SIZE (1.0.0.tar.gz) = 107150

View file

@ -1,22 +1,23 @@
--- setup.py 2013-12-05 06:59:17.000000000 -0800
+++ setup.py 2014-01-01 23:25:57.944668958 -0800
@@ -50,12 +50,13 @@
'License :: OSI Approved :: GPL License',
'Programming Language :: Python'
],
+
data_files=[
- ('/usr/share/icons/hicolor/scalable/apps', [
+ ('share/pithos/icons/hicolor/scalable/apps', [
'data/icons/scalable/apps/pithos-mono.svg',
'data/icons/scalable/apps/pithos.svg'
]),
--- setup.py.orig 2014-05-01 18:33:16.000000000 -0400
+++ setup.py 2014-07-24 20:19:53.091960936 -0400
@@ -37,11 +37,11 @@
if sys.platform != 'win32':
data_files = [
- ('/usr/share/icons/hicolor/scalable/apps', ['data/icons/hicolor/pithos.svg']),
- ('/usr/share/icons/hicolor/48x48/apps', ['data/icons/hicolor/pithos-tray-icon.png']),
- ('/usr/share/icons/ubuntu-mono-dark/apps/16', ['data/icons/ubuntu-mono-dark/pithos-tray-icon.svg']),
- ('/usr/share/icons/ubuntu-mono-light/apps/16', ['data/icons/ubuntu-mono-light/pithos-tray-icon.svg']),
- ('/usr/share/applications', ['data/pithos.desktop'])
+ ('share/pithos/applications', ['data/pithos.desktop'])
],
package_data={
'pithos': [
@@ -70,6 +71,7 @@
+ ('share/icons/hicolor/scalable/apps', ['data/icons/hicolor/pithos.svg']),
+ ('share/icons/hicolor/48x48/apps', ['data/icons/hicolor/pithos-tray-icon.png']),
+ ('share/icons/ubuntu-mono-dark/apps/16', ['data/icons/ubuntu-mono-dark/pithos-tray-icon.svg']),
+ ('share/icons/ubuntu-mono-light/apps/16', ['data/icons/ubuntu-mono-light/pithos-tray-icon.svg']),
+ ('share/applications', ['data/pithos.desktop'])
]
else:
data_files = []
@@ -78,6 +78,7 @@
],
packages=find_packages(),
include_package_data=True,

View file

@ -1,11 +1,14 @@
%%DATADIR%%/media/pithos-mono.png
%%DATADIR%%/media/icon.png
%%DATADIR%%/media/rate_bg.svg
%%DATADIR%%/media/album_default.png
%%DATADIR%%/media/rate_bg.png
%%DATADIR%%/media/album_default.svg
%%DATADIR%%/icons/scalable/apps/pithos-mono.svg
%%DATADIR%%/icons/scalable/apps/pithos.svg
%%DATADIR%%/media/icon.svg
%%DATADIR%%/media/pithos-tray-icon.png
%%DATADIR%%/media/rate_bg.png
%%DATADIR%%/media/rate_bg.svg
%%DATADIR%%/icons/hicolor/pithos-tray-icon.png
%%DATADIR%%/icons/hicolor/pithos-tray-icon.svg
%%DATADIR%%/icons/hicolor/pithos.svg
%%DATADIR%%/icons/ubuntu-mono-dark/pithos-tray-icon.svg
%%DATADIR%%/icons/ubuntu-mono-light/pithos-tray-icon.svg
%%DATADIR%%/pithos.desktop
%%DATADIR%%/ui/PithosWindow.ui
%%DATADIR%%/ui/preferences_pithos_dialog.xml
@ -17,7 +20,11 @@
%%DATADIR%%/ui/about_pithos_dialog.xml
%%DATADIR%%/ui/SearchDialog.ui
%%DATADIR%%/ui/StationsDialog.ui
@dirrm %%DATADIR%%/icons/scalable/apps
@dirrm %%DATADIR%%/icons/scalable
@dirrm %%DATADIR%%/media
@dirrm %%DATADIR%%/ui
%%DATADIR%%/ui/app_menu.ui
@dirrmtry %%DATADIR%%/icons/hicolor
@dirrmtry %%DATADIR%%/icons/ubuntu-mono-dark
@dirrmtry %%DATADIR%%/icons/ubuntu-mono-light
@dirrmtry %%DATADIR%%/icons
@dirrmtry %%DATADIR%%/media
@dirrmtry %%DATADIR%%/ui
@dirrmtry %%DATADIR%%