add gregexp 0.3

A graphical regular expression explorer
This commit is contained in:
Ying-Chieh Liao 2004-05-04 05:48:58 +00:00
parent 57c9b6d3ed
commit 72eb522d33
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108336
6 changed files with 50 additions and 0 deletions

View file

@ -129,6 +129,7 @@
SUBDIR += granulate
SUBDIR += grc
SUBDIR += grdb
SUBDIR += gregexp
SUBDIR += gretl
SUBDIR += grun
SUBDIR += gtkfind

27
misc/gregexp/Makefile Normal file
View file

@ -0,0 +1,27 @@
# ex:ts=8
# Ports collection makefile for: gregexp
# Date created: May 4, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= gregexp
PORTVERSION= 0.3
CATEGORIES= misc
MASTER_SITES= http://dentrassi.de/download/gregexp/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical regular expression explorer
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_X_PREFIX= yes
USE_ICONV= yes
USE_GETTEXT= yes
USE_GNOME= gtk20 gnomeprefix
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

2
misc/gregexp/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (gregexp-0.3.tar.gz) = 67310625715c4f13ec65e2ebb90a3654
SIZE (gregexp-0.3.tar.gz) = 96034

View file

@ -0,0 +1,11 @@
--- configure.orig Tue May 4 11:55:27 2004
+++ configure Tue May 4 11:55:45 2004
@@ -5665,7 +5665,7 @@
cat >>confdefs.h <<_ACEOF
-#define DATADIR "${prefix}/share/"
+#define DATADIR "${datadir}/"
_ACEOF

3
misc/gregexp/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
GRegExp Explorer is a graphical regular expression explorer based on the PCRE
regular expression library. It is possible to test regular expressions on the
fly and check the result in detail.

6
misc/gregexp/pkg-plist Normal file
View file

@ -0,0 +1,6 @@
bin/gregexp
share/gnome/applications/gregexp.desktop
share/gnome/pixmaps/gregexp.png
share/gnome/gregexp/glade/gregexp.glade
@dirrm share/gnome/gregexp/glade
@dirrm share/gnome/gregexp