Update to 1.04
PR: 50185 Submitted by: Erwin Lansing <erwin@lansing.dk> (maintainer)
This commit is contained in:
parent
ec9a9a1e3e
commit
73189fe653
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77345
5 changed files with 3 additions and 135 deletions
|
@ -7,8 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= Mail-Procmailrc
|
||||
PORTVERSION= 1.03
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.04
|
||||
CATEGORIES= mail perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
|
||||
http://scott.wiersdorf.org/perl/
|
||||
|
@ -20,7 +19,6 @@ COMMENT= A Perl OO interface to procmail rc files
|
|||
|
||||
PERL_CONFIGURE= YES
|
||||
|
||||
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
|
||||
MAN3= Mail::Procmailrc.3
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (Mail-Procmailrc-1.03.tar.gz) = 2e112f9b9268e3d631c37389ad866c61
|
||||
MD5 (Mail-Procmailrc-1.04.tar.gz) = 35bed916e071db2f0ad84207af1d0638
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.PL.orig Wed Jan 22 15:53:59 2003
|
||||
+++ Makefile.PL Wed Jan 22 15:54:17 2003
|
||||
@@ -3,7 +3,7 @@
|
||||
# the contents of the Makefile that is written.
|
||||
WriteMakefile(
|
||||
'NAME' => 'Mail::Procmailrc',
|
||||
- 'VERSION_FROM' => 'Procmailrc.pm', # finds $VERSION
|
||||
+ 'VERSION' => '1.03',
|
||||
'PREREQ_PM' => {}, # e.g., Module::Name => 1.1
|
||||
($] >= 5.005 ? ## Add these new keywords supported since 5.005
|
||||
(ABSTRACT_FROM => 'Procmailrc.pm', # retrieve abstract from module
|
|
@ -1,120 +0,0 @@
|
|||
--- Procmailrc.pm.orig Wed Nov 20 22:15:55 2002
|
||||
+++ Procmailrc.pm Wed Feb 5 20:48:22 2003
|
||||
@@ -6,14 +6,12 @@
|
||||
package Mail::Procmailrc;
|
||||
##################################
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use warnings;
|
||||
use Carp qw(confess);
|
||||
|
||||
-our $VERSION = '1.03';
|
||||
-our $Debug = 0;
|
||||
-our %RE = (
|
||||
+use vars qw($VERSION); $VERSION = '1.03';
|
||||
+use vars qw($Debug); $Debug = 0;
|
||||
+use vars qw( %RE); %RE = (
|
||||
'flags' => qr/^\s*:0/o,
|
||||
'flagsm' => qr/^\s*(:0.*)$/o,
|
||||
'var' => qr/^\s*[^#\$=]+=.+/o,
|
||||
@@ -389,7 +387,7 @@
|
||||
|
||||
## FIXME: handle comments on the assignment line
|
||||
|
||||
-our $Debug = 0;
|
||||
+use vars qw($Debug);$Debug = 0;
|
||||
|
||||
sub new {
|
||||
my $self = bless { }, shift;
|
||||
@@ -435,10 +433,10 @@
|
||||
$line .= shift @$data;
|
||||
|
||||
## check assignment
|
||||
- confess "Could not init: bad pattern in '$line'\n" unless $line =~ /$RE{'var'}/;
|
||||
+ confess "Could not init: bad pattern in '$line'\n" unless $line =~ /$Mail::Procmailrc::RE{'var'}/;
|
||||
|
||||
## check for continuation
|
||||
- while( $line =~ /$RE{'cont'}/ ) {
|
||||
+ while( $line =~ /$Mail::Procmailrc::RE{'cont'}/ ) {
|
||||
$line .= "\n";
|
||||
$line .= shift @$data;
|
||||
}
|
||||
@@ -571,7 +569,7 @@
|
||||
FLAGS: {
|
||||
$line = shift @$data;
|
||||
$line =~ s/^\s*//;
|
||||
- confess( "Not a recipe: $line\n" ) unless $line =~ /$RE{'flags'}/;
|
||||
+ confess( "Not a recipe: $line\n" ) unless $line =~ /$Mail::Procmailrc::RE{'flags'}/;
|
||||
$self->flags($line);
|
||||
}
|
||||
|
||||
@@ -582,13 +580,13 @@
|
||||
$line =~ s/^\s*//;
|
||||
|
||||
## comment/info
|
||||
- if( $line =~ s/$RE{'comm'}/$1/ ) {
|
||||
+ if( $line =~ s/$Mail::Procmailrc::RE{'comm'}/$1/ ) {
|
||||
push @{$self->info}, $line;
|
||||
redo INFO;
|
||||
}
|
||||
|
||||
## skip empty lines
|
||||
- if( $line =~ /$RE{'blank'}/ ) {
|
||||
+ if( $line =~ /$Mail::Procmailrc::RE{'blank'}/ ) {
|
||||
redo INFO;
|
||||
}
|
||||
|
||||
@@ -603,8 +601,8 @@
|
||||
$line =~ s/^\s*//;
|
||||
|
||||
## check for condition
|
||||
- if( $line =~ s/$RE{'condm'}/$1/ ) {
|
||||
- while( $line =~ /$RE{'cont'}/ ) {
|
||||
+ if( $line =~ s/$Mail::Procmailrc::RE{'condm'}/$1/ ) {
|
||||
+ while( $line =~ /$Mail::Procmailrc::RE{'cont'}/ ) {
|
||||
$line .= "\n"; ## tack on the newline for quoted lines
|
||||
$line .= shift @$data;
|
||||
}
|
||||
@@ -614,12 +612,12 @@
|
||||
}
|
||||
|
||||
## check for embedded comments and skip them
|
||||
- if( $line =~ /$RE{'comt'}/ ) {
|
||||
+ if( $line =~ /$Mail::Procmailrc::RE{'comt'}/ ) {
|
||||
redo CONDITIONS;
|
||||
}
|
||||
|
||||
## check for empty lines and skip them
|
||||
- if( $line =~ /$RE{'blank'}/ ) {
|
||||
+ if( $line =~ /$Mail::Procmailrc::RE{'blank'}/ ) {
|
||||
redo CONDITIONS;
|
||||
}
|
||||
|
||||
@@ -634,7 +632,7 @@
|
||||
$line =~ s/^\s*//;
|
||||
|
||||
## if contains a '{' we pass it to Procmailrc
|
||||
- if( $line =~ /$RE{'blkopen'}/ ) {
|
||||
+ if( $line =~ /$Mail::Procmailrc::RE{'blkopen'}/ ) {
|
||||
unshift @$data, $line;
|
||||
$self->action( Mail::Procmailrc->new( { 'data' => $data,
|
||||
'level' => $self->defaults('level') } ));
|
||||
@@ -642,7 +640,7 @@
|
||||
|
||||
## this is a plain old action line
|
||||
else {
|
||||
- while( $line =~ /$RE{'cont'}/ ) {
|
||||
+ while( $line =~ /$Mail::Procmailrc::RE{'cont'}/ ) {
|
||||
$line .= "\n";
|
||||
$line .= shift @$data;
|
||||
}
|
||||
@@ -761,7 +759,7 @@
|
||||
$pmrc = new Mail::Procmailrc("$HOME/.procmail/rc.spam");
|
||||
|
||||
## add a new variable
|
||||
- $pmrc->push( new Mail::Procmailrc::Variable("FOO=bar") );
|
||||
+ $pmrc->push( new Mail::Procmailrc::Variable(["FOO=bar"]) );
|
||||
|
||||
## add a new recipe
|
||||
$recipe =<<'_RECIPE_';
|
|
@ -1,5 +1,6 @@
|
|||
lib/perl5/site_perl/%%PERL_VER%%/Mail/Procmailrc.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/Procmailrc/.packlist
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod-Mail-Procmailrc
|
||||
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Mail 2>/dev/null || true
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/Procmailrc
|
||||
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue