The nethack dungeon slashing game, Japanese version.

This commit is contained in:
Satoshi Asami 1995-05-14 02:35:19 +00:00
parent 97b2f673f4
commit 731b58471b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=1737
30 changed files with 882 additions and 0 deletions

37
japanese/nethack/Makefile Normal file
View file

@ -0,0 +1,37 @@
# New ports collection makefile for: nethack
# Version required: 3.1.3
# Date created: 13 February 1995
# Whom: asami
#
# $Id:$
#
DISTNAME= nethack3.1.3
PKGNAME= jp-nethack-1.0.2
CATEGORIES+= japanese games
MASTER_SITES= ftp://ftp.uu.net/usenet/comp.sources.games/
EXTRACT_SUFX= .tar.Z
PATCH_SITES= ftp://mitsuko.jaist.ac.jp/pub/jnethack/
PATCHFILES= jnethack-1.0.2.gz
MAINTAINER= asami@FreeBSD.ORG
WRKSRC= ${WRKDIR}/nethack313
USE_GMAKE= yes
SHELL= /bin/sh
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SHELL} setup.sh
pre-install:
@cd ${WRKSRC}/doc; ${MAKE} manpages
post-install:
gzip -9nf ${PREFIX}/man/man6/dgn_comp.6
gzip -9nf ${PREFIX}/man/man6/lev_comp.6
gzip -9nf ${PREFIX}/man/man6/nethack.6
gzip -9nf ${PREFIX}/man/man6/recover.6
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (nethack3.1.3.tar.Z) = f196ed9659814cd85beeee10e60b7e73
MD5 (jnethack-1.0.2.gz) = d89ed77136fe268aa99c6851f1e60d37

View file

@ -0,0 +1,75 @@
--- ./include/unixconf.h.org Wed Dec 21 04:44:02 1994
+++ ./include/unixconf.h Wed Dec 21 04:48:04 1994
@@ -33,7 +33,7 @@
/* #define SVR4 /* use in addition to SYSV for System V Release 4 */
#define NETWORK /* if running on a networked system */
/* e.g. Suns sharing a playground through NFS */
-#define SUNOS4 /* SunOS 4.x */
+/* #define SUNOS4 /* SunOS 4.x */
/* #define NEWSOS4 /* NEWS-OS 4.x */
/* #define LINUX /* Another Unix clone running on Intel processors */
/* #define GENIX /* Yet Another Unix Clone */
@@ -42,11 +42,11 @@
/* #define UNIXPC /* use in addition to SYSV for AT&T 7300/3B1 */
/* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
job control (note that AIX is SYSV otherwise) */
-/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
+#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
/* or ANSI color support on termcap systems */
/* or X11 color */
/* #define POSIX_JOB_CONTROL /* use System V POSIX job control */
-/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
+#define POSIX_TYPES /* use POSIX types for system calls and termios */
/* define for platforms using the GNU libraries */
/* linux, etc .. */
@@ -108,7 +108,7 @@
* A stat system call is done on the mailbox every MAILCKFREQ moves.
*/
-#define MAIL /* Deliver mail during the game */
+/* #define MAIL /* Deliver mail during the game */
/* The Andrew Message System does mail a little differently from normal
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
--- ./include/config.h.org Wed Dec 21 04:44:01 1994
+++ ./include/config.h Wed Dec 21 04:48:46 1994
@@ -273,12 +273,12 @@
#ifdef UNIX
/* path and file name extension for compression program */
-# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
+/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
+/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
/* An example of one alternative you might want to use: */
-/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
-/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
+# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
#endif
#ifndef COMPRESS
# define INTERNAL_COMP /* control use of NetHack's compression routines */
@@ -300,7 +300,7 @@
* If you define HACKDIR, then this will be the default playground;
* otherwise it will be the current directory.
*/
-#define HACKDIR "/usr/games/lib/jnethackdir" /* nethack directory */
+#define HACKDIR "/usr/local/lib/jnethackdir" /* nethack directory */
/*
* Some system administrators are stupid enough to make Hack suid root
--- ./sys/unix/Makefile.top.org Wed Dec 21 04:43:32 1994
+++ ./sys/unix/Makefile.top Wed Dec 21 04:46:51 1994
@@ -32,8 +32,8 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
# instructions)
-GAMEDIR = /usr/games/lib/$(GAME)dir
-SHELLDIR = /usr/games
+GAMEDIR = /usr/local/lib/$(GAME)dir
+SHELLDIR = /usr/local/bin
# by issei 1994/2/5, 1994/6/25
#DATHELP = help hh cmdhelp history opthelp wizhelp

View file

@ -0,0 +1,12 @@
--- ./include/system.h.org Mon Apr 5 08:54:19 1993
+++ ./include/system.h Fri Dec 9 23:41:34 1994
@@ -131,7 +131,9 @@
E int FDECL(write, (int,char *,int));
E int FDECL(link, (const char *, const char*));
#else
+#ifndef __FreeBSD__
E long FDECL(lseek, (int,long,int));
+#endif
# ifdef POSIX_TYPES
E int FDECL(write, (int, const void *,unsigned));
# else

View file

@ -0,0 +1,11 @@
--- ./sys/unix/Makefile.src.org Wed Dec 21 04:43:32 1994
+++ ./sys/unix/Makefile.src Wed Dec 21 04:50:14 1994
@@ -97,7 +97,7 @@
# by issei(94/6/12)
#
-CFLAGS = -g -I../include -I/usr/local/X11R6/include
+CFLAGS = -O2 -I../include -I/usr/local/X11R6/include
LFLAGS =

View file

@ -0,0 +1,19 @@
--- ./sys/unix/Makefile.doc.org Mon Jan 11 13:02:31 1993
+++ ./sys/unix/Makefile.doc Sat Dec 10 00:14:52 1994
@@ -21,7 +21,7 @@
GAME = nethack
-MANDIR = /usr/man/man6
+MANDIR = /usr/local/man/man6
MANEXT = 6
# manual installation for most BSD-style systems
@@ -36,6 +36,7 @@
# RCVRMANCREATE = nroff -man recover.6 >
manpages:
+ -mkdir $(MANDIR)
-$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
-$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
-$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)

View file

@ -0,0 +1,11 @@
--- ./sys/unix/Makefile.utl.org Wed Dec 21 05:25:10 1994
+++ ./sys/unix/Makefile.utl Wed Dec 21 05:46:22 1994
@@ -72,7 +72,7 @@
#
# by issei 1994/1/10
# lex is required 8bit through for japanese.
-LEX = flex -8
+LEX = lex -8
# these are the names of the output files from YACC/LEX. Under MS-DOS
# and similar systems, they may differ

View file

@ -0,0 +1 @@
jp-nethack-1.0.2, a dungeon explorin', slashin', hackin' game

View file

@ -0,0 +1,11 @@
This is the Japanese version 1.0.2 (original 3.1.3) of nethack. You
and your puppy (or kitten) will explore the deep dungeons to retrieve
the long-lost magical item that causes so much trouble to anyone.
Take care, and try not to miss meals.
- Satoshi
asami@cs.berkeley.edu
P.S. There is a newsgroup "rec.games.roguelike.nethack" if you are
truly interested.

115
japanese/nethack/pkg-plist Normal file
View file

@ -0,0 +1,115 @@
@owner games
bin/jnethack
man/man6/dgn_comp.6.gz
man/man6/lev_comp.6.gz
man/man6/nethack.6.gz
man/man6/recover.6.gz
lib/jnethackdir/save
lib/jnethackdir/jnethack
lib/jnethackdir/A-filla.lev
lib/jnethackdir/A-fillb.lev
lib/jnethackdir/A-goal.lev
lib/jnethackdir/A-locate.lev
lib/jnethackdir/A-start.lev
lib/jnethackdir/B-filla.lev
lib/jnethackdir/B-fillb.lev
lib/jnethackdir/B-goal.lev
lib/jnethackdir/B-locate.lev
lib/jnethackdir/B-start.lev
lib/jnethackdir/C-filla.lev
lib/jnethackdir/C-fillb.lev
lib/jnethackdir/C-goal.lev
lib/jnethackdir/C-locate.lev
lib/jnethackdir/C-start.lev
lib/jnethackdir/E-filla.lev
lib/jnethackdir/E-fillb.lev
lib/jnethackdir/E-goal.lev
lib/jnethackdir/E-locate.lev
lib/jnethackdir/E-start.lev
lib/jnethackdir/H-filla.lev
lib/jnethackdir/H-fillb.lev
lib/jnethackdir/H-goal.lev
lib/jnethackdir/H-locate.lev
lib/jnethackdir/H-start.lev
lib/jnethackdir/K-filla.lev
lib/jnethackdir/K-fillb.lev
lib/jnethackdir/K-goal.lev
lib/jnethackdir/K-locate.lev
lib/jnethackdir/K-start.lev
lib/jnethackdir/P-filla.lev
lib/jnethackdir/P-fillb.lev
lib/jnethackdir/P-goal.lev
lib/jnethackdir/P-locate.lev
lib/jnethackdir/P-start.lev
lib/jnethackdir/R-filla.lev
lib/jnethackdir/R-fillb.lev
lib/jnethackdir/R-goal.lev
lib/jnethackdir/R-locate.lev
lib/jnethackdir/R-start.lev
lib/jnethackdir/S-filla.lev
lib/jnethackdir/S-fillb.lev
lib/jnethackdir/S-goal.lev
lib/jnethackdir/S-locate.lev
lib/jnethackdir/S-start.lev
lib/jnethackdir/T-filla.lev
lib/jnethackdir/T-fillb.lev
lib/jnethackdir/T-goal.lev
lib/jnethackdir/T-locate.lev
lib/jnethackdir/T-start.lev
lib/jnethackdir/V-filla.lev
lib/jnethackdir/V-fillb.lev
lib/jnethackdir/V-goal.lev
lib/jnethackdir/V-locate.lev
lib/jnethackdir/V-start.lev
lib/jnethackdir/W-filla.lev
lib/jnethackdir/W-fillb.lev
lib/jnethackdir/W-goal.lev
lib/jnethackdir/W-locate.lev
lib/jnethackdir/W-start.lev
lib/jnethackdir/air.lev
lib/jnethackdir/asmodeus.lev
lib/jnethackdir/astral.lev
lib/jnethackdir/baalz.lev
lib/jnethackdir/bigroom.lev
lib/jnethackdir/castle.lev
lib/jnethackdir/data
lib/jnethackdir/dungeon
lib/jnethackdir/earth.lev
lib/jnethackdir/fakewiz1.lev
lib/jnethackdir/fakewiz2.lev
lib/jnethackdir/fire.lev
lib/jnethackdir/jcmdhelp
lib/jnethackdir/jhelp
lib/jnethackdir/jhh
lib/jnethackdir/jhistory
lib/jnethackdir/jjj
lib/jnethackdir/jopthelp
lib/jnethackdir/joracles
lib/jnethackdir/jrumors
lib/jnethackdir/juiblex.lev
lib/jnethackdir/jwizhelp
lib/jnethackdir/knox.lev
lib/jnethackdir/license
lib/jnethackdir/logfile
lib/jnethackdir/medusa-1.lev
lib/jnethackdir/medusa-2.lev
lib/jnethackdir/mine_end.lev
lib/jnethackdir/minefill.lev
lib/jnethackdir/minetown.lev
lib/jnethackdir/options
lib/jnethackdir/oracle.lev
lib/jnethackdir/orcus.lev
lib/jnethackdir/perm
lib/jnethackdir/quest.dat
lib/jnethackdir/record
lib/jnethackdir/sanctum.lev
lib/jnethackdir/tower1.lev
lib/jnethackdir/tower2.lev
lib/jnethackdir/tower3.lev
lib/jnethackdir/valley.lev
lib/jnethackdir/water.lev
lib/jnethackdir/wizard1.lev
lib/jnethackdir/wizard2.lev
lib/jnethackdir/wizard3.lev
@exec chmod 755 %D/lib/jnethackdir
@unexec rmdir %D/lib/jnethackdir

View file

@ -0,0 +1,37 @@
# New ports collection makefile for: nethack
# Version required: 3.1.3
# Date created: 13 February 1995
# Whom: asami
#
# $Id:$
#
DISTNAME= nethack3.1.3
PKGNAME= jp-nethack-1.0.2
CATEGORIES+= japanese games
MASTER_SITES= ftp://ftp.uu.net/usenet/comp.sources.games/
EXTRACT_SUFX= .tar.Z
PATCH_SITES= ftp://mitsuko.jaist.ac.jp/pub/jnethack/
PATCHFILES= jnethack-1.0.2.gz
MAINTAINER= asami@FreeBSD.ORG
WRKSRC= ${WRKDIR}/nethack313
USE_GMAKE= yes
SHELL= /bin/sh
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SHELL} setup.sh
pre-install:
@cd ${WRKSRC}/doc; ${MAKE} manpages
post-install:
gzip -9nf ${PREFIX}/man/man6/dgn_comp.6
gzip -9nf ${PREFIX}/man/man6/lev_comp.6
gzip -9nf ${PREFIX}/man/man6/nethack.6
gzip -9nf ${PREFIX}/man/man6/recover.6
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (nethack3.1.3.tar.Z) = f196ed9659814cd85beeee10e60b7e73
MD5 (jnethack-1.0.2.gz) = d89ed77136fe268aa99c6851f1e60d37

View file

@ -0,0 +1,75 @@
--- ./include/unixconf.h.org Wed Dec 21 04:44:02 1994
+++ ./include/unixconf.h Wed Dec 21 04:48:04 1994
@@ -33,7 +33,7 @@
/* #define SVR4 /* use in addition to SYSV for System V Release 4 */
#define NETWORK /* if running on a networked system */
/* e.g. Suns sharing a playground through NFS */
-#define SUNOS4 /* SunOS 4.x */
+/* #define SUNOS4 /* SunOS 4.x */
/* #define NEWSOS4 /* NEWS-OS 4.x */
/* #define LINUX /* Another Unix clone running on Intel processors */
/* #define GENIX /* Yet Another Unix Clone */
@@ -42,11 +42,11 @@
/* #define UNIXPC /* use in addition to SYSV for AT&T 7300/3B1 */
/* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
job control (note that AIX is SYSV otherwise) */
-/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
+#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
/* or ANSI color support on termcap systems */
/* or X11 color */
/* #define POSIX_JOB_CONTROL /* use System V POSIX job control */
-/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
+#define POSIX_TYPES /* use POSIX types for system calls and termios */
/* define for platforms using the GNU libraries */
/* linux, etc .. */
@@ -108,7 +108,7 @@
* A stat system call is done on the mailbox every MAILCKFREQ moves.
*/
-#define MAIL /* Deliver mail during the game */
+/* #define MAIL /* Deliver mail during the game */
/* The Andrew Message System does mail a little differently from normal
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
--- ./include/config.h.org Wed Dec 21 04:44:01 1994
+++ ./include/config.h Wed Dec 21 04:48:46 1994
@@ -273,12 +273,12 @@
#ifdef UNIX
/* path and file name extension for compression program */
-# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
+/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
+/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
/* An example of one alternative you might want to use: */
-/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
-/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
+# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
#endif
#ifndef COMPRESS
# define INTERNAL_COMP /* control use of NetHack's compression routines */
@@ -300,7 +300,7 @@
* If you define HACKDIR, then this will be the default playground;
* otherwise it will be the current directory.
*/
-#define HACKDIR "/usr/games/lib/jnethackdir" /* nethack directory */
+#define HACKDIR "/usr/local/lib/jnethackdir" /* nethack directory */
/*
* Some system administrators are stupid enough to make Hack suid root
--- ./sys/unix/Makefile.top.org Wed Dec 21 04:43:32 1994
+++ ./sys/unix/Makefile.top Wed Dec 21 04:46:51 1994
@@ -32,8 +32,8 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
# instructions)
-GAMEDIR = /usr/games/lib/$(GAME)dir
-SHELLDIR = /usr/games
+GAMEDIR = /usr/local/lib/$(GAME)dir
+SHELLDIR = /usr/local/bin
# by issei 1994/2/5, 1994/6/25
#DATHELP = help hh cmdhelp history opthelp wizhelp

View file

@ -0,0 +1,12 @@
--- ./include/system.h.org Mon Apr 5 08:54:19 1993
+++ ./include/system.h Fri Dec 9 23:41:34 1994
@@ -131,7 +131,9 @@
E int FDECL(write, (int,char *,int));
E int FDECL(link, (const char *, const char*));
#else
+#ifndef __FreeBSD__
E long FDECL(lseek, (int,long,int));
+#endif
# ifdef POSIX_TYPES
E int FDECL(write, (int, const void *,unsigned));
# else

View file

@ -0,0 +1,11 @@
--- ./sys/unix/Makefile.src.org Wed Dec 21 04:43:32 1994
+++ ./sys/unix/Makefile.src Wed Dec 21 04:50:14 1994
@@ -97,7 +97,7 @@
# by issei(94/6/12)
#
-CFLAGS = -g -I../include -I/usr/local/X11R6/include
+CFLAGS = -O2 -I../include -I/usr/local/X11R6/include
LFLAGS =

View file

@ -0,0 +1,19 @@
--- ./sys/unix/Makefile.doc.org Mon Jan 11 13:02:31 1993
+++ ./sys/unix/Makefile.doc Sat Dec 10 00:14:52 1994
@@ -21,7 +21,7 @@
GAME = nethack
-MANDIR = /usr/man/man6
+MANDIR = /usr/local/man/man6
MANEXT = 6
# manual installation for most BSD-style systems
@@ -36,6 +36,7 @@
# RCVRMANCREATE = nroff -man recover.6 >
manpages:
+ -mkdir $(MANDIR)
-$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
-$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
-$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)

View file

@ -0,0 +1,11 @@
--- ./sys/unix/Makefile.utl.org Wed Dec 21 05:25:10 1994
+++ ./sys/unix/Makefile.utl Wed Dec 21 05:46:22 1994
@@ -72,7 +72,7 @@
#
# by issei 1994/1/10
# lex is required 8bit through for japanese.
-LEX = flex -8
+LEX = lex -8
# these are the names of the output files from YACC/LEX. Under MS-DOS
# and similar systems, they may differ

View file

@ -0,0 +1 @@
jp-nethack-1.0.2, a dungeon explorin', slashin', hackin' game

View file

@ -0,0 +1,11 @@
This is the Japanese version 1.0.2 (original 3.1.3) of nethack. You
and your puppy (or kitten) will explore the deep dungeons to retrieve
the long-lost magical item that causes so much trouble to anyone.
Take care, and try not to miss meals.
- Satoshi
asami@cs.berkeley.edu
P.S. There is a newsgroup "rec.games.roguelike.nethack" if you are
truly interested.

View file

@ -0,0 +1,115 @@
@owner games
bin/jnethack
man/man6/dgn_comp.6.gz
man/man6/lev_comp.6.gz
man/man6/nethack.6.gz
man/man6/recover.6.gz
lib/jnethackdir/save
lib/jnethackdir/jnethack
lib/jnethackdir/A-filla.lev
lib/jnethackdir/A-fillb.lev
lib/jnethackdir/A-goal.lev
lib/jnethackdir/A-locate.lev
lib/jnethackdir/A-start.lev
lib/jnethackdir/B-filla.lev
lib/jnethackdir/B-fillb.lev
lib/jnethackdir/B-goal.lev
lib/jnethackdir/B-locate.lev
lib/jnethackdir/B-start.lev
lib/jnethackdir/C-filla.lev
lib/jnethackdir/C-fillb.lev
lib/jnethackdir/C-goal.lev
lib/jnethackdir/C-locate.lev
lib/jnethackdir/C-start.lev
lib/jnethackdir/E-filla.lev
lib/jnethackdir/E-fillb.lev
lib/jnethackdir/E-goal.lev
lib/jnethackdir/E-locate.lev
lib/jnethackdir/E-start.lev
lib/jnethackdir/H-filla.lev
lib/jnethackdir/H-fillb.lev
lib/jnethackdir/H-goal.lev
lib/jnethackdir/H-locate.lev
lib/jnethackdir/H-start.lev
lib/jnethackdir/K-filla.lev
lib/jnethackdir/K-fillb.lev
lib/jnethackdir/K-goal.lev
lib/jnethackdir/K-locate.lev
lib/jnethackdir/K-start.lev
lib/jnethackdir/P-filla.lev
lib/jnethackdir/P-fillb.lev
lib/jnethackdir/P-goal.lev
lib/jnethackdir/P-locate.lev
lib/jnethackdir/P-start.lev
lib/jnethackdir/R-filla.lev
lib/jnethackdir/R-fillb.lev
lib/jnethackdir/R-goal.lev
lib/jnethackdir/R-locate.lev
lib/jnethackdir/R-start.lev
lib/jnethackdir/S-filla.lev
lib/jnethackdir/S-fillb.lev
lib/jnethackdir/S-goal.lev
lib/jnethackdir/S-locate.lev
lib/jnethackdir/S-start.lev
lib/jnethackdir/T-filla.lev
lib/jnethackdir/T-fillb.lev
lib/jnethackdir/T-goal.lev
lib/jnethackdir/T-locate.lev
lib/jnethackdir/T-start.lev
lib/jnethackdir/V-filla.lev
lib/jnethackdir/V-fillb.lev
lib/jnethackdir/V-goal.lev
lib/jnethackdir/V-locate.lev
lib/jnethackdir/V-start.lev
lib/jnethackdir/W-filla.lev
lib/jnethackdir/W-fillb.lev
lib/jnethackdir/W-goal.lev
lib/jnethackdir/W-locate.lev
lib/jnethackdir/W-start.lev
lib/jnethackdir/air.lev
lib/jnethackdir/asmodeus.lev
lib/jnethackdir/astral.lev
lib/jnethackdir/baalz.lev
lib/jnethackdir/bigroom.lev
lib/jnethackdir/castle.lev
lib/jnethackdir/data
lib/jnethackdir/dungeon
lib/jnethackdir/earth.lev
lib/jnethackdir/fakewiz1.lev
lib/jnethackdir/fakewiz2.lev
lib/jnethackdir/fire.lev
lib/jnethackdir/jcmdhelp
lib/jnethackdir/jhelp
lib/jnethackdir/jhh
lib/jnethackdir/jhistory
lib/jnethackdir/jjj
lib/jnethackdir/jopthelp
lib/jnethackdir/joracles
lib/jnethackdir/jrumors
lib/jnethackdir/juiblex.lev
lib/jnethackdir/jwizhelp
lib/jnethackdir/knox.lev
lib/jnethackdir/license
lib/jnethackdir/logfile
lib/jnethackdir/medusa-1.lev
lib/jnethackdir/medusa-2.lev
lib/jnethackdir/mine_end.lev
lib/jnethackdir/minefill.lev
lib/jnethackdir/minetown.lev
lib/jnethackdir/options
lib/jnethackdir/oracle.lev
lib/jnethackdir/orcus.lev
lib/jnethackdir/perm
lib/jnethackdir/quest.dat
lib/jnethackdir/record
lib/jnethackdir/sanctum.lev
lib/jnethackdir/tower1.lev
lib/jnethackdir/tower2.lev
lib/jnethackdir/tower3.lev
lib/jnethackdir/valley.lev
lib/jnethackdir/water.lev
lib/jnethackdir/wizard1.lev
lib/jnethackdir/wizard2.lev
lib/jnethackdir/wizard3.lev
@exec chmod 755 %D/lib/jnethackdir
@unexec rmdir %D/lib/jnethackdir

View file

@ -0,0 +1,37 @@
# New ports collection makefile for: nethack
# Version required: 3.1.3
# Date created: 13 February 1995
# Whom: asami
#
# $Id:$
#
DISTNAME= nethack3.1.3
PKGNAME= jp-nethack-1.0.2
CATEGORIES+= japanese games
MASTER_SITES= ftp://ftp.uu.net/usenet/comp.sources.games/
EXTRACT_SUFX= .tar.Z
PATCH_SITES= ftp://mitsuko.jaist.ac.jp/pub/jnethack/
PATCHFILES= jnethack-1.0.2.gz
MAINTAINER= asami@FreeBSD.ORG
WRKSRC= ${WRKDIR}/nethack313
USE_GMAKE= yes
SHELL= /bin/sh
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SHELL} setup.sh
pre-install:
@cd ${WRKSRC}/doc; ${MAKE} manpages
post-install:
gzip -9nf ${PREFIX}/man/man6/dgn_comp.6
gzip -9nf ${PREFIX}/man/man6/lev_comp.6
gzip -9nf ${PREFIX}/man/man6/nethack.6
gzip -9nf ${PREFIX}/man/man6/recover.6
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (nethack3.1.3.tar.Z) = f196ed9659814cd85beeee10e60b7e73
MD5 (jnethack-1.0.2.gz) = d89ed77136fe268aa99c6851f1e60d37

View file

@ -0,0 +1,75 @@
--- ./include/unixconf.h.org Wed Dec 21 04:44:02 1994
+++ ./include/unixconf.h Wed Dec 21 04:48:04 1994
@@ -33,7 +33,7 @@
/* #define SVR4 /* use in addition to SYSV for System V Release 4 */
#define NETWORK /* if running on a networked system */
/* e.g. Suns sharing a playground through NFS */
-#define SUNOS4 /* SunOS 4.x */
+/* #define SUNOS4 /* SunOS 4.x */
/* #define NEWSOS4 /* NEWS-OS 4.x */
/* #define LINUX /* Another Unix clone running on Intel processors */
/* #define GENIX /* Yet Another Unix Clone */
@@ -42,11 +42,11 @@
/* #define UNIXPC /* use in addition to SYSV for AT&T 7300/3B1 */
/* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
job control (note that AIX is SYSV otherwise) */
-/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
+#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
/* or ANSI color support on termcap systems */
/* or X11 color */
/* #define POSIX_JOB_CONTROL /* use System V POSIX job control */
-/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
+#define POSIX_TYPES /* use POSIX types for system calls and termios */
/* define for platforms using the GNU libraries */
/* linux, etc .. */
@@ -108,7 +108,7 @@
* A stat system call is done on the mailbox every MAILCKFREQ moves.
*/
-#define MAIL /* Deliver mail during the game */
+/* #define MAIL /* Deliver mail during the game */
/* The Andrew Message System does mail a little differently from normal
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
--- ./include/config.h.org Wed Dec 21 04:44:01 1994
+++ ./include/config.h Wed Dec 21 04:48:46 1994
@@ -273,12 +273,12 @@
#ifdef UNIX
/* path and file name extension for compression program */
-# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
+/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
+/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
/* An example of one alternative you might want to use: */
-/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
-/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
+# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
#endif
#ifndef COMPRESS
# define INTERNAL_COMP /* control use of NetHack's compression routines */
@@ -300,7 +300,7 @@
* If you define HACKDIR, then this will be the default playground;
* otherwise it will be the current directory.
*/
-#define HACKDIR "/usr/games/lib/jnethackdir" /* nethack directory */
+#define HACKDIR "/usr/local/lib/jnethackdir" /* nethack directory */
/*
* Some system administrators are stupid enough to make Hack suid root
--- ./sys/unix/Makefile.top.org Wed Dec 21 04:43:32 1994
+++ ./sys/unix/Makefile.top Wed Dec 21 04:46:51 1994
@@ -32,8 +32,8 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
# instructions)
-GAMEDIR = /usr/games/lib/$(GAME)dir
-SHELLDIR = /usr/games
+GAMEDIR = /usr/local/lib/$(GAME)dir
+SHELLDIR = /usr/local/bin
# by issei 1994/2/5, 1994/6/25
#DATHELP = help hh cmdhelp history opthelp wizhelp

View file

@ -0,0 +1,12 @@
--- ./include/system.h.org Mon Apr 5 08:54:19 1993
+++ ./include/system.h Fri Dec 9 23:41:34 1994
@@ -131,7 +131,9 @@
E int FDECL(write, (int,char *,int));
E int FDECL(link, (const char *, const char*));
#else
+#ifndef __FreeBSD__
E long FDECL(lseek, (int,long,int));
+#endif
# ifdef POSIX_TYPES
E int FDECL(write, (int, const void *,unsigned));
# else

View file

@ -0,0 +1,11 @@
--- ./sys/unix/Makefile.src.org Wed Dec 21 04:43:32 1994
+++ ./sys/unix/Makefile.src Wed Dec 21 04:50:14 1994
@@ -97,7 +97,7 @@
# by issei(94/6/12)
#
-CFLAGS = -g -I../include -I/usr/local/X11R6/include
+CFLAGS = -O2 -I../include -I/usr/local/X11R6/include
LFLAGS =

View file

@ -0,0 +1,19 @@
--- ./sys/unix/Makefile.doc.org Mon Jan 11 13:02:31 1993
+++ ./sys/unix/Makefile.doc Sat Dec 10 00:14:52 1994
@@ -21,7 +21,7 @@
GAME = nethack
-MANDIR = /usr/man/man6
+MANDIR = /usr/local/man/man6
MANEXT = 6
# manual installation for most BSD-style systems
@@ -36,6 +36,7 @@
# RCVRMANCREATE = nroff -man recover.6 >
manpages:
+ -mkdir $(MANDIR)
-$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
-$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
-$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)

View file

@ -0,0 +1,11 @@
--- ./sys/unix/Makefile.utl.org Wed Dec 21 05:25:10 1994
+++ ./sys/unix/Makefile.utl Wed Dec 21 05:46:22 1994
@@ -72,7 +72,7 @@
#
# by issei 1994/1/10
# lex is required 8bit through for japanese.
-LEX = flex -8
+LEX = lex -8
# these are the names of the output files from YACC/LEX. Under MS-DOS
# and similar systems, they may differ

View file

@ -0,0 +1 @@
jp-nethack-1.0.2, a dungeon explorin', slashin', hackin' game

View file

@ -0,0 +1,11 @@
This is the Japanese version 1.0.2 (original 3.1.3) of nethack. You
and your puppy (or kitten) will explore the deep dungeons to retrieve
the long-lost magical item that causes so much trouble to anyone.
Take care, and try not to miss meals.
- Satoshi
asami@cs.berkeley.edu
P.S. There is a newsgroup "rec.games.roguelike.nethack" if you are
truly interested.

View file

@ -0,0 +1,115 @@
@owner games
bin/jnethack
man/man6/dgn_comp.6.gz
man/man6/lev_comp.6.gz
man/man6/nethack.6.gz
man/man6/recover.6.gz
lib/jnethackdir/save
lib/jnethackdir/jnethack
lib/jnethackdir/A-filla.lev
lib/jnethackdir/A-fillb.lev
lib/jnethackdir/A-goal.lev
lib/jnethackdir/A-locate.lev
lib/jnethackdir/A-start.lev
lib/jnethackdir/B-filla.lev
lib/jnethackdir/B-fillb.lev
lib/jnethackdir/B-goal.lev
lib/jnethackdir/B-locate.lev
lib/jnethackdir/B-start.lev
lib/jnethackdir/C-filla.lev
lib/jnethackdir/C-fillb.lev
lib/jnethackdir/C-goal.lev
lib/jnethackdir/C-locate.lev
lib/jnethackdir/C-start.lev
lib/jnethackdir/E-filla.lev
lib/jnethackdir/E-fillb.lev
lib/jnethackdir/E-goal.lev
lib/jnethackdir/E-locate.lev
lib/jnethackdir/E-start.lev
lib/jnethackdir/H-filla.lev
lib/jnethackdir/H-fillb.lev
lib/jnethackdir/H-goal.lev
lib/jnethackdir/H-locate.lev
lib/jnethackdir/H-start.lev
lib/jnethackdir/K-filla.lev
lib/jnethackdir/K-fillb.lev
lib/jnethackdir/K-goal.lev
lib/jnethackdir/K-locate.lev
lib/jnethackdir/K-start.lev
lib/jnethackdir/P-filla.lev
lib/jnethackdir/P-fillb.lev
lib/jnethackdir/P-goal.lev
lib/jnethackdir/P-locate.lev
lib/jnethackdir/P-start.lev
lib/jnethackdir/R-filla.lev
lib/jnethackdir/R-fillb.lev
lib/jnethackdir/R-goal.lev
lib/jnethackdir/R-locate.lev
lib/jnethackdir/R-start.lev
lib/jnethackdir/S-filla.lev
lib/jnethackdir/S-fillb.lev
lib/jnethackdir/S-goal.lev
lib/jnethackdir/S-locate.lev
lib/jnethackdir/S-start.lev
lib/jnethackdir/T-filla.lev
lib/jnethackdir/T-fillb.lev
lib/jnethackdir/T-goal.lev
lib/jnethackdir/T-locate.lev
lib/jnethackdir/T-start.lev
lib/jnethackdir/V-filla.lev
lib/jnethackdir/V-fillb.lev
lib/jnethackdir/V-goal.lev
lib/jnethackdir/V-locate.lev
lib/jnethackdir/V-start.lev
lib/jnethackdir/W-filla.lev
lib/jnethackdir/W-fillb.lev
lib/jnethackdir/W-goal.lev
lib/jnethackdir/W-locate.lev
lib/jnethackdir/W-start.lev
lib/jnethackdir/air.lev
lib/jnethackdir/asmodeus.lev
lib/jnethackdir/astral.lev
lib/jnethackdir/baalz.lev
lib/jnethackdir/bigroom.lev
lib/jnethackdir/castle.lev
lib/jnethackdir/data
lib/jnethackdir/dungeon
lib/jnethackdir/earth.lev
lib/jnethackdir/fakewiz1.lev
lib/jnethackdir/fakewiz2.lev
lib/jnethackdir/fire.lev
lib/jnethackdir/jcmdhelp
lib/jnethackdir/jhelp
lib/jnethackdir/jhh
lib/jnethackdir/jhistory
lib/jnethackdir/jjj
lib/jnethackdir/jopthelp
lib/jnethackdir/joracles
lib/jnethackdir/jrumors
lib/jnethackdir/juiblex.lev
lib/jnethackdir/jwizhelp
lib/jnethackdir/knox.lev
lib/jnethackdir/license
lib/jnethackdir/logfile
lib/jnethackdir/medusa-1.lev
lib/jnethackdir/medusa-2.lev
lib/jnethackdir/mine_end.lev
lib/jnethackdir/minefill.lev
lib/jnethackdir/minetown.lev
lib/jnethackdir/options
lib/jnethackdir/oracle.lev
lib/jnethackdir/orcus.lev
lib/jnethackdir/perm
lib/jnethackdir/quest.dat
lib/jnethackdir/record
lib/jnethackdir/sanctum.lev
lib/jnethackdir/tower1.lev
lib/jnethackdir/tower2.lev
lib/jnethackdir/tower3.lev
lib/jnethackdir/valley.lev
lib/jnethackdir/water.lev
lib/jnethackdir/wizard1.lev
lib/jnethackdir/wizard2.lev
lib/jnethackdir/wizard3.lev
@exec chmod 755 %D/lib/jnethackdir
@unexec rmdir %D/lib/jnethackdir