Update to 0.1.1
Add regression test support Changes: https://lists.freedesktop.org/archives/libopenraw-dev/2017-March/000133.html
This commit is contained in:
parent
8372492694
commit
732cc4328f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437872
4 changed files with 10 additions and 19 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libopenraw
|
||||
PORTVERSION= 0.1.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.1.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://libopenraw.freedesktop.org/download/
|
||||
|
||||
|
@ -22,11 +21,12 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include \
|
||||
--disable-silent-rules
|
||||
INSTALL_TARGET= install-strip
|
||||
TEST_TARGET= check
|
||||
|
||||
# Unhide SEEK_SET to fix build with GCC 4.9 (ports/193528).
|
||||
CXXFLAGS+= -D_GLIBCXX_USE_C99
|
||||
|
||||
OPTIONS_DEFINE= GNOME
|
||||
OPTIONS_DEFINE= GNOME TEST
|
||||
OPTIONS_DEFAULT= GNOME
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
|
@ -36,6 +36,8 @@ GNOME_USE= GNOME=glib20,gdkpixbuf2
|
|||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|' ${WRKSRC}/configure
|
||||
|
||||
post-patch-TEST-off:
|
||||
@${REINPLACE_CMD} -e 's|testsuite ||' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1480563957
|
||||
SHA256 (libopenraw-0.1.0.tar.bz2) = 4dede1db9b85c9c22a1ddaf37839f2713746a00b81a6d4623d66556000cb76cf
|
||||
SIZE (libopenraw-0.1.0.tar.bz2) = 525449
|
||||
TIMESTAMP = 1491499741
|
||||
SHA256 (libopenraw-0.1.1.tar.bz2) = bbba7fccb2b8ef12c0fa405f6830fa7c9a91c71ea5e97564833d09a1078aa357
|
||||
SIZE (libopenraw-0.1.1.tar.bz2) = 561718
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- demo/ppmload.c.orig 2016-01-24 18:35:23 UTC
|
||||
+++ demo/ppmload.c
|
||||
@@ -30,6 +30,8 @@
|
||||
# include <machine/endian.h>
|
||||
# include <libkern/OSByteOrder.h>
|
||||
# define htobe16(x) OSSwapHostToBigInt16(x)
|
||||
+#elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
|
||||
+# include <sys/endian.h>
|
||||
#else
|
||||
# include <endian.h>
|
||||
#endif
|
|
@ -19,10 +19,10 @@ include/libopenraw-0.1/libopenraw/types.h
|
|||
lib/libopenraw.a
|
||||
lib/libopenraw.so
|
||||
lib/libopenraw.so.7
|
||||
lib/libopenraw.so.7.0.0
|
||||
lib/libopenraw.so.7.0.1
|
||||
%%GNOME%%lib/libopenrawgnome.a
|
||||
%%GNOME%%lib/libopenrawgnome.so
|
||||
%%GNOME%%lib/libopenrawgnome.so.7
|
||||
%%GNOME%%lib/libopenrawgnome.so.7.0.0
|
||||
%%GNOME%%lib/libopenrawgnome.so.7.0.1
|
||||
libdata/pkgconfig/libopenraw-0.1.pc
|
||||
%%GNOME%%libdata/pkgconfig/libopenraw-gnome-0.1.pc
|
||||
|
|
Loading…
Reference in a new issue