Unbreak after r436971.

After the kdelibs update to 4.11.30 the CMake policies used by kdelibs-based
projects got stricter.

- Fix `make configure'. The upstream git repository has a add_subdirectory(doc)
  call, but the code generating the release tarball also added a
  macro_optional_add_subdirectory(doc) call that was causing CMake to error out
  due to the same directory being added twice to the build system.
- Fix `make build' with the MUSEPACK option. The FindMuse.cmake patch from
  r346999 was hardcoding MUSE_LIBRARIES the wrong way. The find_library() call
  should have been kept, otherwise the linker is passed "-lmpcdec" instead of
  "/full/path/to/libmpcdec.so".
This commit is contained in:
Raphael Kubo da Costa 2017-03-27 13:39:03 +00:00
parent b7aeb88b93
commit 734d437047
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437044
2 changed files with 13 additions and 7 deletions

View file

@ -1,3 +1,6 @@
Hunk 1: Pass -std=c99 when building with clang as well as GCC.
Hunk 2: Stop adding the doc/ directory twice, there is another entry for it
at the end of the file.
--- CMakeLists.txt.orig 2014-11-04 18:43:47 UTC
+++ CMakeLists.txt
@@ -106,10 +106,10 @@ if(K3B_BUILD_FFMPEG_DECODER_PLUGIN)
@ -13,3 +16,11 @@
if(FFMPEG_INCLUDE_DIR_OLD_STYLE)
set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${FFMPEG_INCLUDE_DIR_OLD_STYLE})
@@ -339,7 +339,6 @@ add_subdirectory( libk3b )
add_subdirectory( src )
add_subdirectory( kioslaves )
add_subdirectory( plugins )
-add_subdirectory( doc )
if(BUILD_K3BSETUP)
add_subdirectory(k3bsetup)
endif(BUILD_K3BSETUP)

View file

@ -1,6 +1,6 @@
--- cmake/modules/FindMuse.cmake.orig 2014-11-04 18:37:31 UTC
+++ cmake/modules/FindMuse.cmake
@@ -15,13 +15,10 @@ if( MUSE_INCLUDE_DIR AND MUSE_LIBRARIES
@@ -15,9 +15,7 @@ if( MUSE_INCLUDE_DIR AND MUSE_LIBRARIES
endif( MUSE_INCLUDE_DIR AND MUSE_LIBRARIES )
include(CheckIncludeFiles)
@ -10,9 +10,4 @@
+set ( HAVE_MPC_MPCDEC_H 1 )
if( HAVE_MPC_MPCDEC_H )
- find_path( MUSE_INCLUDE_DIR mpc/mpcdec.h )
- find_library( MUSE_LIBRARIES NAMES mpcdec )
+ set( MUSE_LIBRARIES mpcdec )
set( MPC_HEADER_FILE "<mpc/mpcdec.h>" )
elseif( HAVE_MPCDEC_MPCDEC_H )
find_path( MUSE_INCLUDE_DIR mpcdec/mpcdec.h )
find_path( MUSE_INCLUDE_DIR mpc/mpcdec.h )