- Fix MIDI support
- Trim Makefile headers PR: ports/174098 Submitted by: Green Dog <fiziologus@gmail.com>
This commit is contained in:
parent
60a54547f0
commit
7382239e6d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309566
2 changed files with 16 additions and 6 deletions
|
@ -1,13 +1,9 @@
|
|||
# New ports collection makefile for: sdl_sound
|
||||
# Date created: 6 Feb 2003
|
||||
# Whom: David Yeske <dyeske@gmail.com>
|
||||
#
|
||||
# Created by: David Yeske <dyeske@gmail.com>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sdl_sound
|
||||
PORTVERSION= 1.0.3
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://offload1.icculus.org:9090/SDL_sound/downloads/ \
|
||||
http://offload2.icculus.org:9090/SDL_sound/downloads/
|
||||
|
@ -88,4 +84,7 @@ pre-everything::
|
|||
@${ECHO_CMD}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/decoders/timidity/options.h
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
11
audio/sdl_sound/files/patch-decoders-timidity-options.h
Normal file
11
audio/sdl_sound/files/patch-decoders-timidity-options.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- decoders/timidity/options.h.orig 2008-04-17 21:56:20.000000000 +0400
|
||||
+++ decoders/timidity/options.h 2012-12-04 01:38:58.000000000 +0400
|
||||
@@ -80,7 +80,7 @@
|
||||
#define MAX_AMPLIFICATION 800
|
||||
|
||||
/* The TiMidity configuration file */
|
||||
-#define CONFIG_FILE "timidity.cfg"
|
||||
+#define CONFIG_FILE "%%PREFIX%%/share/timidity/timidity.cfg"
|
||||
|
||||
/* These affect general volume */
|
||||
#define GUARD_BITS 3
|
Loading…
Reference in a new issue