Update to 1.9.7.

PR:		ports/156109
Submitted by:	Pan Tsu <inyaoo -at- gmail.com>
This commit is contained in:
Philip Paeps 2011-06-21 09:18:38 +00:00
parent 7f3068dd17
commit 73c16d7b1a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=275975
5 changed files with 114 additions and 66 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
PORTVERSION= 1.9.4
PORTVERSION= 1.9.7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
http://files.wesnoth.org/
@ -16,6 +16,7 @@ MAINTAINER= philip@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-fonts/junicode:extract
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
@ -36,16 +37,15 @@ PORTDATA= *
OPTIONS= ANA "Enable Asynchronous Network API (WIP)" On \
CAMPAIGN "Enable campaign server" On \
EDITOR "Enable map editor" On \
FRIBIDI "Enable bidirectional support" On \
LOWMEM "Reduce memory usage (disables animations)" Off \
NOTIFY "Enable desktop notifications" On \
OPENMP "Enable OpenMP support" Off \
POOLALLOC "Use wesnoth own memory allocator" Off \
PYTHON "Enable python developer tools" Off \
RAWSOCKETS "Use raw receiving sockets in multiplayer" Off \
SERVER "Enable server" On \
TESTS "Enable unit tests" Off \
TINYGUI "Enable tiny gui (down to 320x200)" Off \
TOOLS "Enable extra tools for artists and translators" On
.include <bsd.port.options.mk>
@ -69,14 +69,6 @@ CMAKE_ARGS+= -DENABLE_CAMPAIGN_SERVER=on
PLIST_SUB+= CAMPAIGN=""
.endif
.if defined(WITHOUT_EDITOR)
CMAKE_ARGS+= -DENABLE_EDITOR=off
PLIST_SUB+= EDITOR="@comment "
.else
CMAKE_ARGS+= -DENABLE_EDITOR=on
PLIST_SUB+= EDITOR=""
.endif
.if defined(WITHOUT_FRIBIDI)
CMAKE_ARGS+= -DENABLE_FRIBIDI=off
.else
@ -110,6 +102,12 @@ _MANPAGES+= ${PREFIX}/man/es/man6/wesnothd.6 \
PLIST_SUB+= NLS=""
.endif
.if defined(WITHOUT_OPENMP)
CMAKE_ARGS+= -DENABLE_OMP=off
.else
CMAKE_ARGS+= -DENABLE_OMP=on
.endif
.if defined(WITHOUT_POOLALLOC)
CMAKE_ARGS+= -DENABLE_POOL_ALLOC=off
.else
@ -148,11 +146,6 @@ CMAKE_ARGS+= -DENABLE_TESTS=on
PLIST_SUB+= TESTS=""
.endif
.if !defined(WITHOUT_TINYGUI)
CMAKE_ARGS+= -DGUI=tiny
BUILD_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
.if defined(WITHOUT_TOOLS)
CMAKE_ARGS+= -DENABLE_TOOLS=off
PLIST_SUB+= TOOLS="@comment "
@ -170,6 +163,9 @@ IGNORE= game data is required, undefine NOPORTDATA
.endif
post-install:
${INSTALL_DATA} $$(${MAKE} -V WRKSRC \
-C ${PORTSDIR}/x11-fonts/junicode)/fonts/Junicode-Regular.ttf \
${DATADIR}/fonts
-update-desktop-database ${PREFIX}/share/applications
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (wesnoth-1.9.4.tar.bz2) = 8644fc2efe071c91a306ca91419ccd11221c6930a1889d356c3a31501765e8d0
SIZE (wesnoth-1.9.4.tar.bz2) = 334376625
SHA256 (wesnoth-1.9.7.tar.bz2) = ced4a5f88d650a97e547dfec153c89da04c565b2d705ef0920dbc000338f4492
SIZE (wesnoth-1.9.7.tar.bz2) = 338021134

View file

@ -15,9 +15,9 @@
find_package(X11)
@@ -68,7 +67,7 @@ option(ENABLE_GAME "Enable compilation o
option(ENABLE_GAME "Enable compilation of the game" ON)
option(ENABLE_CAMPAIGN_SERVER "Enable compilation of campaign server")
option(ENABLE_SERVER "Enable compilation of server" ON)
option(ENABLE_EDITOR "Enable compilation of the new map editor into the game executable" ON)
-option(ENABLE_TOOLS "Enable building and installation of tools for artists and WML maintainers")
+option(ENABLE_TOOLS "Enable building and installation of tools for artists and WML maintainers" OFF)
option(ENABLE_TESTS "Build unit tests")
@ -27,8 +27,8 @@
endif(ENABLE_STRICT_COMPILATION)
# Strict compilation for C files is disabled until somebody wants to clean them.
- set(CMAKE_C_FLAGS "-O2 -W -Wall -ansi $ENV{CFLAGS}"
+ set(CMAKE_C_FLAGS "-W -Wall -ansi $ENV{CFLAGS}"
- set(CMAKE_C_FLAGS "-O2 -W -Wall -ansi $ENV{CFLAGS}"
+ set(CMAKE_C_FLAGS "-W -Wall -ansi $ENV{CFLAGS}"
CACHE STRING "Flags used by the C compiler during normal builds." FORCE)
- set(CMAKE_C_FLAGS_DEBUG "-O0 -DDEBUG -ggdb3 -W -Wall -ansi $ENV{CFLAGS}"
+ set(CMAKE_C_FLAGS_DEBUG "-DDEBUG -W -Wall -ansi $ENV{CFLAGS}"
@ -48,26 +48,18 @@
CACHE STRING "Flags used by the CXX compiler during release builds." FORCE)
endif(NOT CONFIGURED)
@@ -151,9 +150,15 @@ if(X11_FOUND)
add_definitions(-D_X11)
endif(X11_FOUND)
+if(IS_ABSOLUTE ${LOCALEDIR})
+ set(LOCALE_INSTALL ${LOCALEDIR})
+ add_definitions(-DLOCALEDIR=\\\"${LOCALE_INSTALL}\\\")
@@ -154,6 +153,7 @@ add_definitions(-DLOCALEDIR=\\\"${LOCALE
if(LOCALEDIR MATCHES "^/")
add_definitions(-DHAS_RELATIVE_LOCALEDIR=0)
set(LOCALE_INSTALL ${LOCALEDIR})
+ set(LOCALEDIR "translations")
+else(IS_ABSOLUTE ${LOCALEDIR})
add_definitions(-DHAS_RELATIVE_LOCALEDIR=1)
add_definitions(-DLOCALEDIR=\\\"${LOCALEDIR}\\\")
set(LOCALE_INSTALL ${DATADIR}/${LOCALEDIR})
+endif(IS_ABSOLUTE ${LOCALEDIR})
add_definitions(-DFIFODIR=\\\"${FIFO_DIR}\\\")
@@ -201,10 +206,14 @@ if(ENABLE_GAME)
pkg_check_modules( FONTCONFIG REQUIRED fontconfig>=2.4.1 )
endif(NOT MSVC)
else(LOCALEDIR MATCHES "^/")
add_definitions(-DHAS_RELATIVE_LOCALEDIR=1)
set(LOCALE_INSTALL ${DATADIR}/${LOCALEDIR})
@@ -213,10 +213,14 @@ if(ENABLE_TESTS)
find_package( Boost 1.35 REQUIRED COMPONENTS unit_test_framework )
endif(ENABLE_TESTS)
if(ENABLE_GAME)
- find_package( FriBiDi )
+ pkg_check_modules( FRIBIDI fribidi>=0.19.0 )
if(ENABLE_FRIBIDI AND FRIBIDI_LIBRARIES)

View file

@ -1,32 +1,34 @@
--- src/ana/src/CMakeLists.txt~
+++ src/ana/src/CMakeLists.txt
@@ -4,7 +4,7 @@ include_directories( ../api )
@@ -4,7 +4,7 @@ include_directories(../api)
find_package( Boost 1.35 REQUIRED COMPONENTS thread system)
find_package(Boost 1.35 REQUIRED COMPONENTS thread system)
-set ( CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -ggdb3" )
+set ( CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}" )
-set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -ggdb3")
+set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")
set ( common_srcs asio_listener.cpp asio_sender.cpp asio_timers.cpp )
set(common_srcs asio_listener.cpp asio_sender.cpp asio_timers.cpp)
@@ -20,19 +20,9 @@ target_link_libraries( ana-static ${Boos
@@ -20,11 +20,11 @@ target_link_libraries( ana-static ${Boos
set ( CMAKE_INSTALL_PREFIX /usr/local )
set(CMAKE_INSTALL_PREFIX /usr/local)
-IF(NOT MSVC)
- set ( CMAKE_INSTALL_PREFIX /usr/local )
- install ( TARGETS ana LIBRARY DESTINATION lib )
- install ( TARGETS ana-static ARCHIVE DESTINATION lib )
-ENDIF(NOT MSVC)
-
set ( ana_headers ../api/ana.hpp
../api/common.hpp
../api/timers.hpp
../api/buffers.hpp
../api/predicates.hpp
../api/binary_streams.hpp )
-
-IF(NOT MSVC)
- install ( FILES ${ana_headers} DESTINATION include/ana )
-ENDIF(NOT MSVC)
\ No newline at end of file
-if(NOT MSVC)
+if(FALSE)
set(CMAKE_INSTALL_PREFIX /usr/local)
install(TARGETS ana LIBRARY DESTINATION lib)
install(TARGETS ana-static ARCHIVE DESTINATION lib)
-endif(NOT MSVC)
+endif(FALSE)
set(ana_headers
../api/ana.hpp
@@ -35,6 +35,6 @@ set(ana_headers
../api/binary_streams.hpp
)
-if(NOT MSVC)
+if(FALSE)
install(FILES ${ana_headers} DESTINATION include/ana)
-endif(NOT MSVC)
+endif(FALSE)

View file

@ -33,7 +33,7 @@ bin/wesnoth
%%PYTHON%%%%PYTHON_SITELIBDIR%%/wesnoth/wmltools.pyc
%%PYTHON%%%%PYTHON_SITELIBDIR%%/wesnoth/wmltools.pyo
share/applications/wesnoth.desktop
%%EDITOR%%share/applications/wesnoth_editor.desktop
share/applications/wesnoth_editor.desktop
%%NLS%%share/locale/af/LC_MESSAGES/wesnoth-anl.mo
%%NLS%%share/locale/af/LC_MESSAGES/wesnoth-aoi.mo
%%NLS%%share/locale/af/LC_MESSAGES/wesnoth-did.mo
@ -59,6 +59,56 @@ share/applications/wesnoth.desktop
%%NLS%%share/locale/af/LC_MESSAGES/wesnoth-units.mo
%%NLS%%share/locale/af/LC_MESSAGES/wesnoth-utbs.mo
%%NLS%%share/locale/af/LC_MESSAGES/wesnoth.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-anl.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-aoi.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-did.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-dm.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-dw.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-editor.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-ei.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-help.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-httt.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-l.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-lib.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-low.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-multiplayer.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-nr.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-sof.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-sotbe.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-tb.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-test.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-thot.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-trow.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-tsg.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-tutorial.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-units.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth-utbs.mo
%%NLS%%share/locale/ang/LC_MESSAGES/wesnoth.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-anl.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-aoi.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-did.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-dm.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-dw.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-editor.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-ei.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-help.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-httt.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-l.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-lib.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-low.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-multiplayer.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-nr.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-sof.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-sotbe.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-tb.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-test.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-thot.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-trow.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-tsg.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-tutorial.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-units.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth-utbs.mo
%%NLS%%share/locale/ang@latin/LC_MESSAGES/wesnoth.mo
%%NLS%%share/locale/ar/LC_MESSAGES/wesnoth-anl.mo
%%NLS%%share/locale/ar/LC_MESSAGES/wesnoth-aoi.mo
%%NLS%%share/locale/ar/LC_MESSAGES/wesnoth-did.mo
@ -1360,10 +1410,14 @@ share/applications/wesnoth.desktop
%%NLS%%share/locale/zh_TW/LC_MESSAGES/wesnoth-utbs.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/wesnoth.mo
share/pixmaps/wesnoth-icon.png
%%EDITOR%%share/pixmaps/wesnoth_editor-icon.png
share/pixmaps/wesnoth_editor-icon.png
%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/wesnoth
@dirrmtry man/af/man6
@dirrmtry man/af
@dirrmtry man/ang/man6
@dirrmtry man/ang
@dirrmtry man/ang@latin/man6
@dirrmtry man/ang@latin
@dirrmtry man/ar/man6
@dirrmtry man/ar
@dirrmtry man/bg/man6
@ -1467,6 +1521,10 @@ share/pixmaps/wesnoth-icon.png
@dirrmtry man/zh_TW/man6
@dirrmtry man/zh_TW
@dirrmtry share/applications
%%NLS%%@dirrmtry share/locale/ang/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ang
%%NLS%%@dirrmtry share/locale/ang@latin/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ang@latin
%%NLS%%@dirrmtry share/locale/ca_ES@valencia/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ca_ES@valencia
%%NLS%%@dirrmtry share/locale/en@shaw/LC_MESSAGES