Add GPASM 0.8.9, the GNU Pic assembler, which can compile assembly files
for 12c508 and 16c84 microcontrollers family. PR: 20396 Submitted by: Samuel Tardieu <sam@inf.enst.fr>
This commit is contained in:
parent
2b4d45c636
commit
73c3ce4c18
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32670
13 changed files with 165 additions and 0 deletions
|
@ -88,6 +88,7 @@
|
|||
SUBDIR += gnomedebug
|
||||
SUBDIR += gnomevfs
|
||||
SUBDIR += gnustep
|
||||
SUBDIR += gpasm
|
||||
SUBDIR += gperf
|
||||
SUBDIR += gtksheet
|
||||
SUBDIR += i386-rtems-binutils
|
||||
|
|
22
devel/gpasm/Makefile
Normal file
22
devel/gpasm/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: gpasm
|
||||
# Date created: 4 Aug 2000
|
||||
# Whom: Samuel Tardieu <sam@inf.enst.fr>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gpasm
|
||||
PORTVERSION= 0.8.9
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://download.sourceforge.net/gpasm/
|
||||
|
||||
MAINTAINER= sam@inf.enst.fr
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-0.0.8
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_ARGS= DATADIR=${PREFIX}/share/gpasm
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/bin/gpasm
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/gpasm/distinfo
Normal file
1
devel/gpasm/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gpasm-0.8.9.tar.gz) = 7558f7289237d8cf7b1cebc5490e7efa
|
48
devel/gpasm/files/patch-aa
Normal file
48
devel/gpasm/files/patch-aa
Normal file
|
@ -0,0 +1,48 @@
|
|||
--- Makefile.in.orig Fri Aug 4 13:51:41 2000
|
||||
+++ Makefile.in Fri Aug 4 13:53:45 2000
|
||||
@@ -20,8 +20,14 @@
|
||||
|
||||
all: gpasm
|
||||
|
||||
-DATADIR = @prefix@/gpasm
|
||||
-CFLAGS = @CFLAGS@ -D DATADIR=\"$(DATADIR)\" # -g --pedantic -Wall
|
||||
+prefix = @prefix@
|
||||
+CFLAGS = @CFLAGS@ -DDATADIR=\"$(DATADIR)\" # -g --pendantic -Wall
|
||||
+LIBS = @LIBS@
|
||||
+YACC = @YACC@
|
||||
+LEX = @LEX@
|
||||
+INSTALL = @INSTALL@
|
||||
+
|
||||
+DATADIR = $(prefix)/gpasm
|
||||
SHELL = /bin/sh
|
||||
|
||||
# All the objects, in alphabetical order
|
||||
@@ -39,23 +46,23 @@
|
||||
util.o
|
||||
|
||||
gpasm: $(OBJECTS)
|
||||
- $(CC) -o gpasm $(OBJECTS) @LIBS@
|
||||
+ $(CC) -o gpasm $(OBJECTS) $(LIBS)
|
||||
|
||||
gpasm.tab.c gpasm.tab.h: gpasm.y
|
||||
- @YACC@ -d gpasm.y
|
||||
+ $(YACC) -d gpasm.y
|
||||
mv y.tab.c gpasm.tab.c
|
||||
mv y.tab.h gpasm.tab.h
|
||||
|
||||
scan.c: scan.l gpasm.tab.h
|
||||
- @LEX@ scan.l
|
||||
+ $(LEX) scan.l
|
||||
mv lex.yy.c scan.c
|
||||
|
||||
########################################################################
|
||||
|
||||
install:
|
||||
- @INSTALL@ -m 755 gpasm @prefix@/bin
|
||||
+ $(INSTALL) -m 755 gpasm $(prefix)/bin
|
||||
mkdir -m 755 -p $(DATADIR)
|
||||
- @INSTALL@ -m 644 special.inc $(DATADIR)/special.inc
|
||||
+ $(INSTALL) -m 644 special.inc $(DATADIR)/special.inc
|
||||
|
||||
########################################################################
|
||||
|
1
devel/gpasm/pkg-comment
Normal file
1
devel/gpasm/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GPASM is the GNU Pic 12c508 and 16c84 microcontrollers family
|
7
devel/gpasm/pkg-descr
Normal file
7
devel/gpasm/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
GPASM is the GNU Pic assembler, and can compile assembly files for 12c508
|
||||
and 16c84 microcontrollers family.
|
||||
|
||||
WWW: http://gpasm.sourceforge.net/
|
||||
|
||||
-- Samuel Tardieu
|
||||
sam@inf.enst.fr
|
3
devel/gpasm/pkg-plist
Normal file
3
devel/gpasm/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/gpasm
|
||||
share/gpasm/special.inc
|
||||
@dirrm share/gpasm
|
22
devel/gputils/Makefile
Normal file
22
devel/gputils/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: gpasm
|
||||
# Date created: 4 Aug 2000
|
||||
# Whom: Samuel Tardieu <sam@inf.enst.fr>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gpasm
|
||||
PORTVERSION= 0.8.9
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://download.sourceforge.net/gpasm/
|
||||
|
||||
MAINTAINER= sam@inf.enst.fr
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-0.0.8
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_ARGS= DATADIR=${PREFIX}/share/gpasm
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/bin/gpasm
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/gputils/distinfo
Normal file
1
devel/gputils/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gpasm-0.8.9.tar.gz) = 7558f7289237d8cf7b1cebc5490e7efa
|
48
devel/gputils/files/patch-aa
Normal file
48
devel/gputils/files/patch-aa
Normal file
|
@ -0,0 +1,48 @@
|
|||
--- Makefile.in.orig Fri Aug 4 13:51:41 2000
|
||||
+++ Makefile.in Fri Aug 4 13:53:45 2000
|
||||
@@ -20,8 +20,14 @@
|
||||
|
||||
all: gpasm
|
||||
|
||||
-DATADIR = @prefix@/gpasm
|
||||
-CFLAGS = @CFLAGS@ -D DATADIR=\"$(DATADIR)\" # -g --pedantic -Wall
|
||||
+prefix = @prefix@
|
||||
+CFLAGS = @CFLAGS@ -DDATADIR=\"$(DATADIR)\" # -g --pendantic -Wall
|
||||
+LIBS = @LIBS@
|
||||
+YACC = @YACC@
|
||||
+LEX = @LEX@
|
||||
+INSTALL = @INSTALL@
|
||||
+
|
||||
+DATADIR = $(prefix)/gpasm
|
||||
SHELL = /bin/sh
|
||||
|
||||
# All the objects, in alphabetical order
|
||||
@@ -39,23 +46,23 @@
|
||||
util.o
|
||||
|
||||
gpasm: $(OBJECTS)
|
||||
- $(CC) -o gpasm $(OBJECTS) @LIBS@
|
||||
+ $(CC) -o gpasm $(OBJECTS) $(LIBS)
|
||||
|
||||
gpasm.tab.c gpasm.tab.h: gpasm.y
|
||||
- @YACC@ -d gpasm.y
|
||||
+ $(YACC) -d gpasm.y
|
||||
mv y.tab.c gpasm.tab.c
|
||||
mv y.tab.h gpasm.tab.h
|
||||
|
||||
scan.c: scan.l gpasm.tab.h
|
||||
- @LEX@ scan.l
|
||||
+ $(LEX) scan.l
|
||||
mv lex.yy.c scan.c
|
||||
|
||||
########################################################################
|
||||
|
||||
install:
|
||||
- @INSTALL@ -m 755 gpasm @prefix@/bin
|
||||
+ $(INSTALL) -m 755 gpasm $(prefix)/bin
|
||||
mkdir -m 755 -p $(DATADIR)
|
||||
- @INSTALL@ -m 644 special.inc $(DATADIR)/special.inc
|
||||
+ $(INSTALL) -m 644 special.inc $(DATADIR)/special.inc
|
||||
|
||||
########################################################################
|
||||
|
1
devel/gputils/pkg-comment
Normal file
1
devel/gputils/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GPASM is the GNU Pic 12c508 and 16c84 microcontrollers family
|
7
devel/gputils/pkg-descr
Normal file
7
devel/gputils/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
GPASM is the GNU Pic assembler, and can compile assembly files for 12c508
|
||||
and 16c84 microcontrollers family.
|
||||
|
||||
WWW: http://gpasm.sourceforge.net/
|
||||
|
||||
-- Samuel Tardieu
|
||||
sam@inf.enst.fr
|
3
devel/gputils/pkg-plist
Normal file
3
devel/gputils/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/gpasm
|
||||
share/gpasm/special.inc
|
||||
@dirrm share/gpasm
|
Loading…
Reference in a new issue