- Update to 0.4.13
PR: ports/80057 Submitted by: Li-Lun Wang (Leland Wang) <llwang@infor.org> (maintainer)
This commit is contained in:
parent
b036e51828
commit
73ed726252
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133747
6 changed files with 45 additions and 33 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libflash
|
||||
PORTVERSION= 0.4.12
|
||||
PORTVERSION= 0.4.13
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gplflash
|
||||
|
@ -27,5 +27,9 @@ CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
|
|||
USE_BZIP2= yes
|
||||
USE_XLIB= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/swf.h
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gplflash-0.4.12.tar.bz2) = 7d53803486b255665a80cd834ee3c463
|
||||
SIZE (gplflash-0.4.12.tar.bz2) = 378727
|
||||
MD5 (gplflash-0.4.13.tar.bz2) = 1b14c21094eb07416842ac0f5298b3f1
|
||||
SIZE (gplflash-0.4.13.tar.bz2) = 323128
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
--- lib/Makefile.in.orig Fri Oct 15 13:34:57 2004
|
||||
+++ lib/Makefile.in Wed Nov 17 16:03:58 2004
|
||||
@@ -256,8 +256,7 @@
|
||||
--- lib/Makefile.in.orig Wed Jan 19 12:30:52 2005
|
||||
+++ lib/Makefile.in Mon Apr 18 04:59:51 2005
|
||||
@@ -256,7 +256,7 @@
|
||||
|
||||
libflash_includedir = $(includedir)
|
||||
libflash_la_LDFLAGS = \
|
||||
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
- -release $(LT_RELEASE) \
|
||||
+ -version-info $(LT_CURRENT) \
|
||||
-export-dynamic \
|
||||
$(LIBJPEG) $(LIBZ) $(LIBMAD)
|
||||
|
|
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME?= flashplugin-mozilla
|
||||
PORTVERSION= 0.4.12
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.4.13
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gplflash
|
||||
|
@ -17,14 +16,13 @@ MAINTAINER= llwang@infor.org
|
|||
COMMENT= A GPL standalone Flash (TM) plugin for Mozilla web browser
|
||||
|
||||
LIB_DEPENDS= flash.0:${PORTSDIR}/graphics/libflash
|
||||
RUN_DEPENDS?= mozilla:${PORTSDIR}/www/mozilla
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/plugin
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_X_PREFIX= yes
|
||||
PLUGIN_DIR?= lib/browser_plugins
|
||||
PLUGIN_DIR= lib/browser_plugins
|
||||
PLIST_SUB+= PLUGIN_DIR=${PLUGIN_DIR}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
|
||||
|
@ -36,5 +34,6 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e "s,-L../lib/.libs,-L${LOCALBASE}/lib," \
|
||||
-e "s/libnpflash.so.0.0.0/libnpflash.so.0/" \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/npapi.h
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gplflash-0.4.12.tar.bz2) = 7d53803486b255665a80cd834ee3c463
|
||||
SIZE (gplflash-0.4.12.tar.bz2) = 378727
|
||||
MD5 (gplflash-0.4.13.tar.bz2) = 1b14c21094eb07416842ac0f5298b3f1
|
||||
SIZE (gplflash-0.4.13.tar.bz2) = 323128
|
||||
|
|
|
@ -1,12 +1,10 @@
|
|||
*** plugin.c.old Mon Jun 12 10:24:09 2000
|
||||
--- plugin.c Mon Sep 30 00:48:40 2002
|
||||
***************
|
||||
*** 193,198 ****
|
||||
--- 193,207 ----
|
||||
--- plugin.c.orig Wed Jan 19 19:30:52 2005
|
||||
+++ plugin.c Wed Apr 20 14:10:14 2005
|
||||
@@ -194,6 +194,15 @@
|
||||
XSync(This->dpy,False);
|
||||
XFreePixmap(This->dpy, This->canvas);
|
||||
shmdt(This->segInfo.shmaddr);
|
||||
+ #ifndef linux
|
||||
+#ifndef linux
|
||||
+ {
|
||||
+ struct shmid_ds buf;
|
||||
+
|
||||
|
@ -14,7 +12,19 @@
|
|||
+ perror("shmctl");
|
||||
+ }
|
||||
+ }
|
||||
+ #endif
|
||||
+#endif
|
||||
|
||||
FlashClose(This->fh);
|
||||
This->fh = 0;
|
||||
@@ -257,10 +266,10 @@
|
||||
static void
|
||||
flashWakeUp(XtPointer client_data, XtIntervalId *id)
|
||||
{
|
||||
- pthread_mutex_lock(&synchro);
|
||||
PluginInstance* This;
|
||||
long cmd;
|
||||
long wakeUp;
|
||||
+ pthread_mutex_lock(&synchro);
|
||||
|
||||
This = (PluginInstance*)client_data;
|
||||
|
||||
|
|
Loading…
Reference in a new issue