projectM is an LGPL'ed reimplementation of Milkdrop under OpenGL. All projectM
requires is a video card with 3D acceleration and your favorite music. WWW: http://projectm.sourceforge.net/ PR: ports/154750 Submitted by: utisoft at gmail.com
This commit is contained in:
parent
359ee6f331
commit
742fdd7077
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=269122
5 changed files with 66 additions and 0 deletions
|
@ -766,6 +766,7 @@
|
|||
SUBDIR += price
|
||||
SUBDIR += processing
|
||||
SUBDIR += proj
|
||||
SUBDIR += projectm-libvisual
|
||||
SUBDIR += pstoedit
|
||||
SUBDIR += pstoepsi
|
||||
SUBDIR += pvmpov
|
||||
|
|
41
graphics/projectm-libvisual/Makefile
Normal file
41
graphics/projectm-libvisual/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# New ports collection Makefile for: projectM-libvisual
|
||||
# Date created: 5 February 2010
|
||||
# Whom: utisoft@gmail.com
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= projectM-libvisual
|
||||
PORTVERSION= 2.0.1
|
||||
CATEGORIES= graphics audio
|
||||
MASTER_SITES= SF/${PORTNAME:L:S/-libvisual//}/${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}-Source
|
||||
|
||||
MAINTAINER= utisoft@gmail.com
|
||||
COMMENT= Allows projectM to be used with libvisual
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= projectM:${PORTSDIR}/graphics/libprojectm \
|
||||
visual-${LIBVISUAL_VER}:${PORTSDIR}/graphics/libvisual${LIBVISUAL_VER:S/.//} \
|
||||
SDL:${PORTSDIR}/devel/sdl12
|
||||
|
||||
USE_CMAKE= yes
|
||||
CMAKE_ARGS+= -DLIBVISUAL_LIBRARIES=visual-${LIBVISUAL_VER}
|
||||
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
|
||||
USE_LDCONFIG= yes
|
||||
LIBVISUAL_VER= 0.4
|
||||
|
||||
PLIST_FILES= lib/libvisual-${LIBVISUAL_VER}/actor/libprojectM_libvisual.so
|
||||
PLIST_DIRS= lib/libvisual-${LIBVISUAL_VER}/actor \
|
||||
lib/libvisual-${LIBVISUAL_VER}
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name "*.[hc]*" | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's#<libvisual#<libvisual-${LIBVISUAL_VER}/libvisual#g'
|
||||
@${REINPLACE_CMD} -e 's#/usr/local#${PREFIX}#' \
|
||||
${WRKSRC}/CPackConfig.cmake \
|
||||
${WRKSRC}/cmake_install.cmake \
|
||||
${WRKSRC}/CPackSourceConfig.cmake
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/projectm-libvisual/distinfo
Normal file
2
graphics/projectm-libvisual/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (projectM_libvisual-2.0.1-Source.tar.gz) = 8526b8687caebcef5f3374dd61665732f10030e970a7db4804eb65a06da18ea0
|
||||
SIZE (projectM_libvisual-2.0.1-Source.tar.gz) = 23128
|
18
graphics/projectm-libvisual/files/patch-actor_projectM-cpp
Normal file
18
graphics/projectm-libvisual/files/patch-actor_projectM-cpp
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- actor_projectM.cpp.orig 2011-02-06 15:46:19.000000000 +0000
|
||||
+++ actor_projectM.cpp 2011-02-06 15:46:38.000000000 +0000
|
||||
@@ -56,7 +56,6 @@
|
||||
static VisPluginInfo info[1];
|
||||
|
||||
actor[0].requisition = lv_projectm_requisition;
|
||||
- actor[0].palette = lv_projectm_palette;
|
||||
actor[0].render = lv_projectm_render;
|
||||
actor[0].vidoptions.depth = VISUAL_VIDEO_DEPTH_GL; /* We want GL clearly */
|
||||
|
||||
@@ -209,7 +208,6 @@
|
||||
* we aren't with projectm, so just ignore :) */
|
||||
extern "C" VisPalette *lv_projectm_palette (VisPluginData *plugin)
|
||||
{
|
||||
- return NULL;
|
||||
}
|
||||
|
||||
/* This is where the real rendering happens! This function is what we call, many times
|
4
graphics/projectm-libvisual/pkg-descr
Normal file
4
graphics/projectm-libvisual/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
projectM is an LGPL'ed reimplementation of Milkdrop under OpenGL. All projectM
|
||||
requires is a video card with 3D acceleration and your favorite music.
|
||||
|
||||
WWW: http://projectm.sourceforge.net/
|
Loading…
Reference in a new issue