devel/py-pygitup: fix port

- fix RUN_DEPENDS
- fix install_requires in setup.py patch
- while there, add dos2unix

PR:		199336
Submitted by:	Maxim Filimonov
This commit is contained in:
Johannes Jost Meixner 2015-07-01 09:26:44 +00:00
parent c63ccc8f16
commit 7435898531
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391038
2 changed files with 15 additions and 2 deletions

View file

@ -11,12 +11,12 @@ COMMENT= Python implementation of 'git up'
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygit2>=0.21.1:${PORTSDIR}/devel/py-pygit2 \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}GitPython>=0.3.6:${PORTSDIR}/devel/py-gitpython \
${PYTHON_PKGNAMEPREFIX}colorama>=0.3.2:${PORTSDIR}/devel/py-colorama \
${PYTHON_PKGNAMEPREFIX}termcolor>=1.1.0:${PORTSDIR}/devel/py-termcolor \
${PYTHON_PKGNAMEPREFIX}docopt>=0.6.1:${PORTSDIR}/devel/py-docopt
USES= python zip
USES= python zip dos2unix
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>

View file

@ -0,0 +1,13 @@
--- setup.py.orig 2015-07-01 09:15:37 UTC
+++ setup.py
@@ -6,8 +6,8 @@ setup(
version="1.2.2",
packages=find_packages(exclude=["tests"]),
scripts=['PyGitUp/gitup.py'],
- install_requires=['GitPython==0.3.2.1', 'colorama==0.3.2',
- 'termcolor==1.1.0', 'docopt==0.6.1'],
+ install_requires=['GitPython>=0.3.2.1', 'colorama>=0.3.2',
+ 'termcolor>=1.1.0', 'docopt>=0.6.1'],
# Tests
test_suite="nose.collector",