Switch back to tracking the upstream trunk instead of OpenOffice 4.1.2
release candidates. Upgrade to SVN revision r1712473. Add an option to build and install the PDF Import extension and enable it by default. Patch the extensions.lst file so that it points to the locations of the extension files rather than passing that information as a configure option. Add a patch to enable enable the use of file:// in extensions.lst for local integrated extensions as is documented in the comments in this file. Nuke the patches that have been committed upstream. Don't try to run the create_tree.sh script with "sh -c" since this script is not marked executable. MFH: 2015Q4
This commit is contained in:
parent
732bf0343e
commit
747c0e2492
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=400938
9 changed files with 44 additions and 1941 deletions
|
@ -98,12 +98,12 @@ RUN_DEPENDS= \
|
|||
${LOCALBASE}/share/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
|
||||
|
||||
AOOVERSION1= 4
|
||||
AOOVERSION2= 1
|
||||
AOOVERSION3= 2
|
||||
AOOVERSION2= 2
|
||||
AOOVERSION3= 0
|
||||
# From solenv/inc/minor.mk SOURCEREVISION LAST_MINOR BUILD
|
||||
AOOTAG= AOO412m3\(Build:9782\)
|
||||
SVNREVISION= 1709696
|
||||
AOORC=rc3
|
||||
AOOTAG= AOO420m1\(Build:9800\)
|
||||
SVNREVISION= 1712473
|
||||
#AOORC=rc3
|
||||
EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20150707.tar.gz
|
||||
|
||||
AOOVERSION= ${AOOVERSION1}.${AOOVERSION2}.${AOOVERSION3}
|
||||
|
@ -147,11 +147,12 @@ WITHOUT_CPU_CFLAGS= true
|
|||
CPE_PRODUCT= ${PORTNAME:S|apache-||}
|
||||
CPE_VENDOR= apache
|
||||
|
||||
OPTIONS_DEFINE= CUPS GNOME GNOMEVFS MMEDIA SDK WIKI_PUBLISHER CCACHE
|
||||
OPTIONS_DEFAULT= CUPS GNOME GNOMEVFS MMEDIA WIKI_PUBLISHER
|
||||
OPTIONS_DEFINE= CUPS GNOME GNOMEVFS MMEDIA PDFIMPORT SDK WIKI_PUBLISHER CCACHE
|
||||
OPTIONS_DEFAULT= CUPS GNOME GNOMEVFS MMEDIA PDFIMPORT WIKI_PUBLISHER
|
||||
GNOME_DESC= GConf + screensaver presentation control via DBUS
|
||||
GNOMEVFS_DESC= GNOME Virtual File System
|
||||
MMEDIA_DESC= Multimedia backend for impress
|
||||
PDFIMPORT_DESC= Build and install PDF import extension
|
||||
SDK_DESC= Build and install software development kit
|
||||
WIKI_PUBLISHER_DESC= Build and install Wiki Publisher extension
|
||||
CCACHE_DESC= Mimimize compile time of C/C++ programs
|
||||
|
@ -173,8 +174,9 @@ MMEDIA_USE= GSTREAMER=yes
|
|||
|
||||
SDK_CONFIGURE_ENABLE= odk
|
||||
|
||||
PDFIMPORT_CONFIGURE_ENABLE= pdfimport
|
||||
|
||||
WIKI_PUBLISHER_CONFIGURE_ENABLE= wiki-publisher
|
||||
WIKI_PUBLISHER_VARS= BUNDLED_EXTENSIONS+=swext/wiki-publisher.oxt
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -276,10 +278,6 @@ CONFIGURE_ARGS+= \
|
|||
--with-system-xrender \
|
||||
--with-system-zlib
|
||||
|
||||
.if defined (BUNDLED_EXTENSIONS)
|
||||
CONFIGURE_ARGS+= --with-bundled-prereg-extensions="${BUNDLED_EXTENSIONS}"
|
||||
.endif
|
||||
|
||||
CREATE_TREE= ${WRKSRC}/sysui/desktop/share/create_tree.sh
|
||||
|
||||
.include <${FILESDIR}/Makefile.knobs>
|
||||
|
@ -443,7 +441,7 @@ do-install:
|
|||
ICON_THEMES="hicolor/??x??" \
|
||||
KDEMAINDIR=${PREFIX} \
|
||||
PREFIX=openoffice${AOOVERSION1} \
|
||||
${SH} -c ${CREATE_TREE} ; \
|
||||
${SH} ${CREATE_TREE} ; \
|
||||
${INSTALL_DATA} apacheopenoffice.xml \
|
||||
${STAGEDIR}/${PREFIX}/share/mime/packages
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
SHA256 (openoffice/apache-openoffice-4.1.2-r1709696-src.tar.bz2) = 2e06774424eb564559f9e6d63ff79aa00522b210067717c5a8cfb54b3b7f1812
|
||||
SIZE (openoffice/apache-openoffice-4.1.2-r1709696-src.tar.bz2) = 219041975
|
||||
SHA256 (openoffice/apache-openoffice-r1712473-src.tar.xz) = 510ea8731ef43c93dfc88dba07d42b3580a38430e2822fd639aefa42a776c71f
|
||||
SIZE (openoffice/apache-openoffice-r1712473-src.tar.xz) = 215169356
|
||||
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
|
||||
SIZE (openoffice/unowinreg.dll) = 6144
|
||||
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
--- configure.in.orig 2015-10-09 07:11:14 UTC
|
||||
+++ configure.in
|
||||
@@ -369,11 +369,11 @@ AC_ARG_WITH(bundled-extension-blobs,
|
||||
and comply with their distribution requirements by updating the
|
||||
files LICENSE_aggregated and NOTICE_aggregated accordingly
|
||||
],,)
|
||||
-#AC_ARG_WITH(bundled-prereg-extensions,
|
||||
-#[ --with-bundled-prereg-extensions Whitespace seperated list of files in the tarball directory that
|
||||
-# are to be bundled as pre-registered extensions. Make sure to only bundle
|
||||
-# extensions which can be installed without requiring a license dialog
|
||||
-#],,)
|
||||
+AC_ARG_WITH(bundled-prereg-extensions,
|
||||
+[ --with-bundled-prereg-extensions Whitespace seperated list of files in the tarball directory that
|
||||
+ are to be bundled as pre-registered extensions. Make sure to only bundle
|
||||
+ extensions which can be installed without requiring a license dialog
|
||||
+],,)
|
||||
AC_ARG_ENABLE(bundled-dictionaries,
|
||||
[ --enable-bundled-dictionaries Download dictionaries (spelling, hyphenation, thesaurus)
|
||||
according to main/extensions.lst and bundle them. Make sure to
|
||||
@@ -1540,9 +1540,9 @@ else
|
||||
fi
|
||||
AC_SUBST(BUNDLED_EXTENSION_BLOBS)
|
||||
|
||||
-#dnl ===================================================================
|
||||
-#dnl Check extensions that are to be bundled as pre-registerd
|
||||
-#dnl ===================================================================
|
||||
+dnl ===================================================================
|
||||
+dnl Check extensions that are to be bundled as pre-registerd
|
||||
+dnl ===================================================================
|
||||
if test -n "$with_bundled_prereg_extensions"; then
|
||||
BUNDLED_PREREG_EXTENSIONS="$with_bundled_prereg_extensions"
|
||||
else
|
17
editors/openoffice-devel/files/patch-extensions.lst
Normal file
17
editors/openoffice-devel/files/patch-extensions.lst
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- extensions.lst.orig 2015-10-24 06:26:40 UTC
|
||||
+++ extensions.lst
|
||||
@@ -37,6 +37,14 @@
|
||||
# [ language=all && ENABLE_XXX ]
|
||||
# file://XXX.oxt
|
||||
|
||||
+# PDF Import extension
|
||||
+[ language=all && ENABLE_PDFIMPORT=YES ]
|
||||
+ file://pdfimport/pdfimport.oxt
|
||||
+
|
||||
+# Wiki Publisher extension
|
||||
+[ language=all && ENABLE_MEDIAWIKI=YES ]
|
||||
+ file://swext/wiki-publisher.oxt
|
||||
+
|
||||
# English dictionary
|
||||
[ language=en.* || language=de || language=it ]
|
||||
f5f6aab4cc5d92a34ab13ad15332770c http://sourceforge.net/projects/aoo-extensions/files/17102/21/dict-en.oxt/download "dict-en.oxt"
|
|
@ -1,73 +0,0 @@
|
|||
--- sal/inc/rtl/math.h.orig 2014-02-25 08:31:58 UTC
|
||||
+++ sal/inc/rtl/math.h
|
||||
@@ -396,6 +396,21 @@ double SAL_CALL rtl_math_round(double fV
|
||||
*/
|
||||
double SAL_CALL rtl_math_pow10Exp(double fValue, int nExp) SAL_THROW_EXTERN_C();
|
||||
|
||||
+/** Similar to pow() with stricter exception handling for indeterminate values.
|
||||
+
|
||||
+ powr is specified in the IEEE 754 - 2008 Floating Point Standard.
|
||||
+
|
||||
+ @param fValue
|
||||
+ The value to be raised.
|
||||
+
|
||||
+ @param fExp
|
||||
+ The exponent.
|
||||
+
|
||||
+ @return
|
||||
+ powr(fValue, fExp)
|
||||
+ */
|
||||
+double SAL_CALL rtl_math_powr(double fValue, double fExp) SAL_THROW_EXTERN_C();
|
||||
+
|
||||
/** Rounds value to 15 significant decimal digits.
|
||||
|
||||
@param fValue
|
||||
--- sal/inc/rtl/math.hxx.orig 2014-02-25 08:31:58 UTC
|
||||
+++ sal/inc/rtl/math.hxx
|
||||
@@ -186,6 +186,13 @@ inline double pow10Exp(double fValue, in
|
||||
return rtl_math_pow10Exp(fValue, nExp);
|
||||
}
|
||||
|
||||
+/** A wrapper around rtl_math_powr.
|
||||
+ */
|
||||
+inline double powr(double fValue, double fExp)
|
||||
+{
|
||||
+ return rtl_math_powr(fValue, fExp);
|
||||
+}
|
||||
+
|
||||
/** A wrapper around rtl_math_approxValue.
|
||||
*/
|
||||
inline double approxValue(double fValue)
|
||||
--- sal/rtl/source/math.cxx.orig 2014-02-25 08:31:57 UTC
|
||||
+++ sal/rtl/source/math.cxx
|
||||
@@ -1113,6 +1113,19 @@ double SAL_CALL rtl_math_expm1( double f
|
||||
return (fe-1.0) * fValue / log(fe);
|
||||
}
|
||||
|
||||
+double SAL_CALL rtl_math_powr( double fValue, double fExp ) SAL_THROW_EXTERN_C()
|
||||
+{
|
||||
+ if ((fValue == 0.0 && fExp == 0.0) ||
|
||||
+ (rtl::math::isInf( fExp ) && !rtl::math::isSignBitSet( fExp )) ||
|
||||
+ (rtl::math::isInf( fValue ) && !rtl::math::isSignBitSet( fValue )))
|
||||
+ {
|
||||
+ double fResult;
|
||||
+ ::rtl::math::setNan( &fResult );
|
||||
+ return fResult;
|
||||
+ }
|
||||
+ return pow(fValue, fExp);
|
||||
+}
|
||||
+
|
||||
|
||||
double SAL_CALL rtl_math_log1p( double fValue ) SAL_THROW_EXTERN_C()
|
||||
{
|
||||
--- sal/util/sal.map.orig 2014-02-25 08:31:48 UTC
|
||||
+++ sal/util/sal.map
|
||||
@@ -629,6 +629,8 @@ UDK_3.12 { # AOO 3.5
|
||||
global:
|
||||
osl_loadAsciiModule;
|
||||
osl_loadAsciiModuleRelative;
|
||||
+
|
||||
+ rtl_math_powr;
|
||||
} UDK_3.11;
|
||||
|
||||
PRIVATE_1.0 {
|
File diff suppressed because it is too large
Load diff
|
@ -1,8 +0,0 @@
|
|||
--- sdext/prj/build.lst.orig 2014-02-25 08:27:02 UTC
|
||||
+++ sdext/prj/build.lst
|
||||
@@ -1,4 +1,4 @@
|
||||
-dx sdext : L10N:l10n offuh comphelper unotools readlicense_oo cppu tools cppuhelper sal javaunohelper officecfg LIBXSLT:libxslt xmlhelp NULL
|
||||
+dx sdext : L10N:l10n offuh comphelper unotools readlicense_oo cppu tools cppuhelper sal javaunohelper officecfg LIBXSLT:libxslt xmlhelp rsc NULL
|
||||
dx sdext usr1 - all sdext_mkout NULL
|
||||
dx sdext\prj get - all sdext_prj NULL
|
||||
dx sdext\source\minimizer nmake - all sdext_minimizer sdext_inc NULL
|
|
@ -0,0 +1,13 @@
|
|||
--- solenv/bin/modules/ExtensionsLst.pm.orig 2014-02-25 08:33:31 UTC
|
||||
+++ solenv/bin/modules/ExtensionsLst.pm
|
||||
@@ -592,8 +592,9 @@ sub GetExtensionList ($@)
|
||||
my $protocol_selector = shift;
|
||||
my @language_list = @_;
|
||||
|
||||
- if (defined $ENV{'ENABLE_BUNDLED_DICTIONARIES'}
|
||||
+ if ((defined $ENV{'ENABLE_BUNDLED_DICTIONARIES'}
|
||||
&& $ENV{'ENABLE_BUNDLED_DICTIONARIES'} eq "YES")
|
||||
+ || $protocol_selector eq "file")
|
||||
{
|
||||
my $full_file_name = Prepare();
|
||||
my @urls = ParseExtensionsLst($full_file_name, \@language_list);
|
|
@ -32,11 +32,7 @@ to your PATH and you will be able to use them.
|
|||
|
||||
OpenOffice does need $LANG to be set to a suitable value.
|
||||
|
||||
4. Wiki Publisher Extension
|
||||
---------------------------
|
||||
The Wiki Publisher extension is now an integrated extension.
|
||||
|
||||
5. If you run into problems
|
||||
4. If you run into problems
|
||||
---------------------------
|
||||
If you somehow run into problems, please remove the already installed
|
||||
"%%AOOUDIR%%" directory in your home directory, then redo the
|
||||
|
|
Loading…
Reference in a new issue