Add WITH_PGSQL knob;
Minor general fixes.
This commit is contained in:
parent
58fb1d85c3
commit
748533e26b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96940
4 changed files with 64 additions and 42 deletions
|
@ -16,29 +16,49 @@ MAINTAINER= demon@FreeBSD.org
|
|||
COMMENT= Online presence and instant messaging server
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-openssl=/usr \
|
||||
--with-libiconv-prefix=${LOCALBASE}
|
||||
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
|
||||
--enable-storage='${STORAGE}' \
|
||||
--enable-authreg='${AUTHREG}'
|
||||
|
||||
.if defined(WITH_BDB)
|
||||
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
|
||||
CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE} \
|
||||
--enable-storage=db \
|
||||
--enable-authreg=db
|
||||
LDFLAGS+= -ldb41
|
||||
CFLAGS+= -I${LOCALBASE}/include/db41
|
||||
STORAGE+= fs
|
||||
AUTHREG+= anon pipe
|
||||
|
||||
.if defined(WITH_PGSQL)
|
||||
LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql-client
|
||||
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/include:${LOCALBASE}/lib
|
||||
STORAGE+= pgsql
|
||||
AUTHREG+= pgsql
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
|
||||
--enable-storage=mysql \
|
||||
--enable-authreg=mysql
|
||||
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/include/mysql:${LOCALBASE}/lib/mysql
|
||||
STORAGE+= mysql
|
||||
AUTHREG+= mysql
|
||||
.endif
|
||||
|
||||
.if defined(WITH_BDB)
|
||||
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
|
||||
CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE}/include/db41:${LOCALBASE}/lib
|
||||
STORAGE+= db
|
||||
AUTHREG+= db
|
||||
.endif
|
||||
|
||||
.if defined(WITH_LDAP)
|
||||
USE_OPENLDAP= yes
|
||||
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}/include:${LOCALBASE}/lib
|
||||
AUTHREG+= ldap
|
||||
.endif
|
||||
|
||||
MAN8= c2s.8 jabberd.8 resolver.8 router.8 s2s.8 sm.8
|
||||
|
||||
pre-everything::
|
||||
@${ECHO}
|
||||
@${ECHO} "You can build jabberd with the following options:"
|
||||
@${ECHO} "WITH_PGSQL use PostgreSQL for storage and authentication"
|
||||
@${ECHO} "WITH_BDB use Berkeley DB for storage and authentication"
|
||||
@${ECHO} "WITH_MYSQL use MySQL for storage and authentication"
|
||||
@${ECHO} "WITH_LDAP use LDAP for authentication"
|
||||
@${ECHO}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,14 +1,5 @@
|
|||
--- configure.orig Mon Dec 29 16:07:44 2003
|
||||
+++ configure Mon Dec 29 16:07:56 2003
|
||||
@@ -23698,7 +23698,7 @@
|
||||
fi;
|
||||
|
||||
if test "$places" = "search"; then
|
||||
- places="std /usr/local/include/db4:/usr/local/lib /usr/local
|
||||
+ places="std /usr/local/include/db41:/usr/local/lib /usr/local
|
||||
/usr/local/BerkeleyDB.4.1 /usr/include/db4:/usr/lib
|
||||
/sw/include/db4:/sw/lib"
|
||||
fi
|
||||
@@ -23734,7 +23734,7 @@
|
||||
;;
|
||||
esac
|
||||
|
|
|
@ -16,29 +16,49 @@ MAINTAINER= demon@FreeBSD.org
|
|||
COMMENT= Online presence and instant messaging server
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-openssl=/usr \
|
||||
--with-libiconv-prefix=${LOCALBASE}
|
||||
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
|
||||
--enable-storage='${STORAGE}' \
|
||||
--enable-authreg='${AUTHREG}'
|
||||
|
||||
.if defined(WITH_BDB)
|
||||
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
|
||||
CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE} \
|
||||
--enable-storage=db \
|
||||
--enable-authreg=db
|
||||
LDFLAGS+= -ldb41
|
||||
CFLAGS+= -I${LOCALBASE}/include/db41
|
||||
STORAGE+= fs
|
||||
AUTHREG+= anon pipe
|
||||
|
||||
.if defined(WITH_PGSQL)
|
||||
LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql-client
|
||||
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/include:${LOCALBASE}/lib
|
||||
STORAGE+= pgsql
|
||||
AUTHREG+= pgsql
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
|
||||
--enable-storage=mysql \
|
||||
--enable-authreg=mysql
|
||||
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/include/mysql:${LOCALBASE}/lib/mysql
|
||||
STORAGE+= mysql
|
||||
AUTHREG+= mysql
|
||||
.endif
|
||||
|
||||
.if defined(WITH_BDB)
|
||||
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
|
||||
CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE}/include/db41:${LOCALBASE}/lib
|
||||
STORAGE+= db
|
||||
AUTHREG+= db
|
||||
.endif
|
||||
|
||||
.if defined(WITH_LDAP)
|
||||
USE_OPENLDAP= yes
|
||||
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}/include:${LOCALBASE}/lib
|
||||
AUTHREG+= ldap
|
||||
.endif
|
||||
|
||||
MAN8= c2s.8 jabberd.8 resolver.8 router.8 s2s.8 sm.8
|
||||
|
||||
pre-everything::
|
||||
@${ECHO}
|
||||
@${ECHO} "You can build jabberd with the following options:"
|
||||
@${ECHO} "WITH_PGSQL use PostgreSQL for storage and authentication"
|
||||
@${ECHO} "WITH_BDB use Berkeley DB for storage and authentication"
|
||||
@${ECHO} "WITH_MYSQL use MySQL for storage and authentication"
|
||||
@${ECHO} "WITH_LDAP use LDAP for authentication"
|
||||
@${ECHO}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,14 +1,5 @@
|
|||
--- configure.orig Mon Dec 29 16:07:44 2003
|
||||
+++ configure Mon Dec 29 16:07:56 2003
|
||||
@@ -23698,7 +23698,7 @@
|
||||
fi;
|
||||
|
||||
if test "$places" = "search"; then
|
||||
- places="std /usr/local/include/db4:/usr/local/lib /usr/local
|
||||
+ places="std /usr/local/include/db41:/usr/local/lib /usr/local
|
||||
/usr/local/BerkeleyDB.4.1 /usr/include/db4:/usr/lib
|
||||
/sw/include/db4:/sw/lib"
|
||||
fi
|
||||
@@ -23734,7 +23734,7 @@
|
||||
;;
|
||||
esac
|
||||
|
|
Loading…
Reference in a new issue