- Fix build on != i386

PR:		ports/64790
Submitted by:	Igor Pokrovsky <tiamat@comset.net> (maintainer)
Tested on:	Sledge
This commit is contained in:
Pav Lucistnik 2004-03-28 12:29:00 +00:00
parent dec3023b99
commit 7495ef527a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105496
3 changed files with 30 additions and 17 deletions

View file

@ -52,12 +52,6 @@ PLIST_SUB= WITH_MOTIF=""
PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
.ifndef (WITH_MOTIF)
pre-everything::
@${ECHO_CMD} ""
@ -99,4 +93,4 @@ post-install:
@(${SED} -e 's|%%DATADIR%%|${DATADIR}|' \
<pkg-message >${PKGMESSAGE} && ${CAT} ${PKGMESSAGE})
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1 +1,2 @@
MD5 (irit-sm.zip) = e57cfb11aec94f1e592fc57b4bbdc7e2
SIZE (irit-sm.zip) = 3128944

View file

@ -1,15 +1,19 @@
--- irender/main.c.orig Mon Feb 2 13:53:42 2004
+++ irender/main.c Mon Feb 2 14:05:03 2004
@@ -13,7 +13,7 @@
--- irender/main.c.orig Thu Dec 25 18:34:39 2003
+++ irender/main.c Fri Mar 26 08:51:39 2004
@@ -12,9 +12,9 @@
#include "parser.h"
#include "config.h"
#ifdef __FreeBSD__
-#ifdef __FreeBSD__
-#include <floatingpoint.h>
-#endif
+#if (defined(__FreeBSD__) && defined(__i386__))
+#include <ieeefp.h>
#endif
+#endif /* __FreeBSD__ && __i386__ */
/* Contains all configuration options. Subject to change by config file and */
@@ -48,15 +48,15 @@
/* and command line parameters. */
@@ -48,16 +48,16 @@
*****************************************************************************/
int main(int argc, char *argv[])
{
@ -22,10 +26,24 @@
*MatrixFiles[] = {NULL, NULL};
IRndrPtrType Rend;
BoolType DoClipping;
+
+#ifdef __FreeBSD__
+ fpsetmask(FP_X_INV | FP_X_DZ);
+#endif /* __FreeBSD__ */
+#if (defined(__FreeBSD__) && defined(__i386__))
+ fpsetmask(FP_X_INV | FP_X_DZ);
+#endif /* __FreeBSD__ && __i386__ */
+
DoClipping = TRUE;
GlblLastTime = IritCPUTime(FALSE);
InitOptions();
@@ -129,10 +129,10 @@
IRndrDestroy(Rend);
TakeTime("Z-Buffer dump");
-#ifdef __FreeBSD__
+#if (defined(__FreeBSD__) && defined(__i386__))
fpresetsticky(FP_X_INV | FP_X_OFL | FP_X_UFL |
FP_X_DZ | FP_X_IMP | FP_X_DNML);
-#endif /* __FreeBSD__ */
+#endif /* __FreeBSD__ && __i386__ */
return 0;
}